SD-Card full through backup of the HDD, won't let me login

  • Hello,


    first of all: thanks to everybody working on OMV, I came from XPenology and I am very happy to use OMV now (with a rPi 4).

    And also thanks to TechnoDadLife, helped me a lot!!!


    I am new to Linux and OMV, so I try to explain everything step by step.


    I am Using OMV 5.


    My Problem now: I played around with the backup Methods. Backup of the System itself and backup of the data (borgbackup, rsync, rsnapshot and USB-backup).

    I am not sure but I think I deleted all backup-Settings except the USB-Backup. Used that and thought that would be the Right one for me. So I did the backup of 3 shared Folders and unplugged the USB-Drive again.


    Next day I wanted to Login to the OMV-Webinterface but when entering "admin" and my Password the screen flashed once and then user and Password where empty again. So OMV recognized the correct Password, but didn't let me in.

    I also use "pihelper" on my iPhone and there it showed me, that my SDCard was completely full. Normally only 2-3 GB of the 32GB-SDcard where used.

    So I shutdown the rPi via putty (here it will still let me Login), put out the SDcard and had a look on it on Windows. Windows will Show me the Card as "rootfs" and there is a Folder called "srv" in which the backup seemed to do the backup. I can see all my Videos, etc. So I assume that it tried to do the backup on my SDcard which was full very quick (don't no why it tried it on the sdcard...)

    So inside the Folder "srv" I deleted the 3 Shared Folders (I did not delete the other Folders "ftp", "pillar" and "salt"). Put in the SDcard but before turning on the rPi again I unplugged the data-HDD (from which the backup was done), so that the backup-Software CANNOT do another backup. But as soon as I started OMV the SDcard was full again with the same data as before.


    I thought Maybe an update will Help, so I logged in via putty as "pi" and did an "apt-get update". The answer was:


    pi@pi4omv:~ $ apt-get update

    Reading package lists... Done

    E: Could not open lock file /var/lib/apt/lists/lock - open (13: Permission denied)

    E: Unable to lock directory /var/lib/apt/lists/

    W: Problem unlinking the file /var/cache/apt/pkgcache.bin - RemoveCaches (13: Permission denied)

    W: Problem unlinking the file /var/cache/apt/srcpkgcache.bin - RemoveCaches (13: Permission denied)


    Can you help me? i am pretty sure that all problems (login to webinterface of OMV, cannot make update via putty) are the result of the SDcard having no free space. How can I solve this?

    BTW: Everything else works like for example that I can connect via SMB to the Shared folders.

  • So everything works fine again.

    The backup tried to find a USB-Hdd which I unplugged and since the backup couldn't find it it used the SDcard.

    Deleted the files from SDcard on Windows --> plugged in the SDcard to rPi WITH the USB-Hdd for backup --> can Login again --> deleted the backup-job

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!