Trying to access SMART menu in the WebUI throw an error message

  • The problem is that OMV does not detect that /dev/sdc is part of a HBA and therefor doesn't append the necessary smartctl arguments. Maybe the detection must be improved:


    https://github.com/openmediava…torage/backend/sd.inc#L74

    https://github.com/openmediava…storage/backend/cciss.inc


    Could you please run the following interactively (as root user) and report the output?

    Code
    root@omv5box:/home/vagrant# python3
    Python 3.7.3 (default, Dec 20 2019, 18:57:59)
    [GCC 8.3.0] on linux
    Type "help", "copyright", "credits" or "license" for more information.
    >>> import openmediavault.device
    >>> sd = openmediavault.device.StorageDevice("/dev/sdc")
    >>> sd.host_driver
    'sym53c8xx'
    >>>

    Following the thread i think this is a bug in smartctl because the device is accessible directly and not behind a CCISS HBA, thus it is not necessary to append the -d cciss,N argument.


    Lets see what you report, but IMO this is a bug in smartctl that can't be fixed by OMV.

  • Hi Votdev, thanks for taking the time to look to that.


    There is the result of the command that i hope i run correctly, first time i run python3 interactive command, not very familiar with this stuff :



    Maybe i should report this to the smartctl team as well ?

    By the way, i noticed that the smartmontools version installed on my system is the 6.6-1, and there seems that a new one is available in the Debian repository which is the 7.1-1. I checked the changelog, didn't find anything related to my behavior, but wasn't able to update the package despite the fact that the mirrors i am using for sure contains that new version. Isn't that weird ?

  • Debian does not update to new major versions in a stable release. The latest version is only in the latest testing release or in the backport repository of a stable release (but this is not supported by OMV because of side effects that appear when newer versions have different configurations).


    I checked the smart.conf manual again and IMO it is a bug in smartmontools.


    Code
    cciss,N - [FreeBSD and Linux only] the device consists of one or more SCSI/SAS or SATA disks connected to a cciss RAID controller. The non-negative integer N (in the range from 0 to 15 inclusive) denotes which disk on the controller is monitored. In log files and email messages this disk will be identified as cciss_disk_XX with XX in the range from 00 to 15 inclusive. Please see the smartctl(8) man page for further details.


    In your case every disk as his dedicated device file, so there is no need to tell smartctl that it should request a special disk behind the HPA 'wall'. Which identifier should be used in the current situation, 0, 1, 2, ... i don't know it. You could try to use

    smartctl -d cciss,0 -x '/dev/sdc' if that works, but again, is 0 the correct identifier of the disk? In my understanding -d cciss,N is ONLY necessary if there is only one device file for the whole HPA and all attached disks are hidden behind that. In that case it is necessary to tell smartctl which disk is requested behind that wall, but only in that case. That's why i think it's a bug. You could open an issue for that at the smartmontools project, maybe this will enlight the problem.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!