Owncloud for external access

  • I've got Owncloud running from the OMV plugin and have been trying to organise remote access - that's kind of the point in my view.


    I've got into my router and created a virtual server pointing port 80 external to the 192.168.1.19 (the machine which OMV is running on).


    I've also created an 'a' record on an external DNS service pointing my intended domain 'cloud.example.com' at my router's ip address (it's fixed).


    I now have two problems:


    Firstly, and this something I haven't encountered before, If I go to that domain from within the LAN it seems to ignore the virtual server rule and direct straight through to the router's webserver, and admin interface. External requests go to 192.168.1.19, the correct ip.


    My second problem is that I can't get apache to point that incoming domain to the Owncloud server, rather than the OMV admin interface.
    I've tried editing /etc/apache2/owncloud-webgui.d/default.conf and replacing the ServerName with cloud.example.com but that doesn't work (and thinking about it that's not right anyway.


    owncloud-webgui seems to be pointing at port 8080 of the root:


    Code
    <VirtualHost *:8080>
    Include /etc/apache2/owncloud-webgui.d/*.conf
    SSLEngine off
    </Virtualhost>


    and the included file seems to be pointing at the document root /var/www/owncloud


    So why's Owncloud appearing at http://example.com/owncloud:80?


    ...actually, I can see in php-fcgi


    Code
    export PHPRC="/var/www/owncloud"


    which presumably is responsible for the subdirectory. But the port?


    What I really want is for Owncloud to be visible to the world, and for OMV to only be visible inside my LAN. I can't see anything good coming from allowing the world to see my OMV admin login screen.


    Any suggestions would be much appreciated.

  • I understand that. What I'd like to do is be able to access it using the domain from both inside and outside the network, and put Owncloud on its own subdomain - without giving any public access to the OMV admin interface.

  • Accessing domain names can sometimes lead to trouble when they are located within the same network so you will get a reverse DNS error or in your case it just ignores the route via the internet and just routes you through your lan.


    Try a vhost config like this:


    Code
    <VirtualHost *:80>
    ServerName cloud.example.com
    ServerAlias *.cloud.example.com
    ServerAdmin email@example.com
    DocumentRoot "/var/www/owncloud/"
    </VirtualHost>


    Greetings
    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

  • Hi David,
    That's just a regular virtualhost config isn't it? I'm a bit confused as to how OMV is runnning it's hosts - I have Slimserver running as well, on port 9000, and it doesn't seem to have a 'sites-enabled' entry. All the debian based apache sites I've set up you just add a config file to 'sites-enabled' like the one you've laid out above, do a reload and that's it. In OMV's case it seems there's more going on.


    PB


    Realised since writing this that Slimserver ain't Apache at all, so that's completely redundant.

  • I've been wondering the same thing (now that 0.5.5 version of the plugin works properly!)...


    My guess is that you'd have to forward 443 port to the openmedia server but then to address restricting the access to just owncloud from anyone outside the local area network - then set up the firewall settings in the openmedia vault admin console (under network) would be the place to do it.


    I've not worked out the rule that would need to be added yet but will let you know if I suss it out... I will be backing up my OMV server first as I don't want to firewall my local area network out by mistake!


    If you get there first, let me know!

  • Does somebody has an solution for this, i want to access the owncloud server from the internet but forwarding the port 80 to the internet is not an solution because the OMV webinterface is accessible for anybody.

  • Use SSL. You don't want the GUI to be accessable but you don't care about plaintext authentication?


    Greetings
    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

  • Hello all,


    Here follows my solution for secure internet access.


    Description:
    I use SSL verification to allow/deny access to my OMV and OwnCloud Webpages. If there is not a valid certificate, WebPages are not accessible.


    How To:
    First, under OMV general settings, I've enabled SSL/TTL secure connection, changed port to 448 (you may choose you own port or even keep default) and forwarded on my ISP router.


    Second, I've generated my own certificates and configured default OMV apache config file with the following lines:
    root@VM-OMV:/etc/apache2/sites-available# cat openmediavault-webgui


    Now, if I want to access my OMV server over the internet I use:

    Quote

    https://<my internet host server address>:448/


    For OwnCloud I use:

    Quote

    https://<my internet host server address>:448/owncloud/


    Hope it helps


    For more details information regarding certificate generation and convertion check sites below:
    http://www.symantec.com/connec…2-ssltls-step-step-part-1
    http://hints.macworld.com/arti…p?story=20041129143420344
    https://www.sslshopper.com/ssl-converter.html


    Regards,
    AT

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!