Failed to start wait for network to be configured, network interface failed

  • Hello, I need help


    I have installed OMV5 on a raspberry pi 3b + and after rebooting while loading the following message appears



    After this I enter username and password and check the configuration of the raspberry. I run the ifconfig command and I get this:




    I run the ipaddress command to see the address of the raspberry and nothing appears to me



    I have read in the forum that executing the following commands was solved but in my case I remain the same


    sudo rm /etc/systemd/network/99-default.link


    sudo omv-salt deploy run systemd-networkd



    If someone could help me, why can't I find the solution

  • Fixed it by myself.

    OMV5 changes the network setting of the system. Fortunately these settings can be configured with the commandline tool omv-firstaid, which comes with omv.


    Steps to fix:

    1. its easiest to access raspi directly via console
    2. configure the network adapter to retrieve the ip-address via dhcp (we'll change it later to a static ip)
    3. install omv5 with the install script - see https://github.com/OpenMediaVa…-Developers/installScript
    4. open a terminal and execute omv-firstaid and assign your static address to your interface (run sudo omv-firstaid)
    5. open a web browser and open http://127.0.0.1
    6. Goto System - Network - Interfaces and add/remove your network adapter. Having WLAN and LAN at the same time is a bit more tricky, if a hidden ssid is used on the wlan. Because I am connected via LAN, I disabled the wlan adapter (can be done by editing the adapter and set the Method of IPv4 and IPv6 to disabled
    7. Don't forget to apply your changes


    Hope that helps.


    Peter

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!