Migration from HP Microserver Gen7 to Gen8 - SATA controller mode

  • Hi, i need some help in migrating my OMV setup.


    So far I have used a Gen7 Microserver, but outgrew the CPU power due to playing around with docker and running several containers, so I got myself an used Gen8 microserver, quickly swapped the drives and was hoping everything will run as before... WRONG!


    My Gen7 setup is 1 SSD boot drive for OMV system & docker, 3 data drives and 1 drive for Snapraid


    So there are several issues:

    1) Gen8 needs some workaround in order to boot from the ODD SATA port, so i temporatily removed the Snapraid backup disk and placed the SSD on its place until i figure out a the SSD booting. (planning to use this approach https://www.admfactory.com/hp-…m-ssd-install-on-odd-bay/ but first i need to tinker with power connector)


    2) Gen8 has a RAID controller and it seems I need to initialize the disks first in the controller before doing anything. From what I read here configuring each disk as a single RAID 0 volume should keep my data intact. with adding the disks one by one I should be on the safe side, adding the snapraid disk only as last when i see everything is working.


    3) Another option seems to be to move the /boot folder of my OMV installation on the SSD to a microSD or USB device and boot from there, leaving the SATA controller in AHCI mode. Not really sure how to do that though, but i guess google is my friend.


    I am slightly leaning to the option 3, but there may be problems with OMV rewriting the fstab with each configuration change (i guess i need to edit it to point to the correct boot and system drives?)


    What is your experience/recommendation in these regards?


    EDIT: Also, here's a post claiming that Ubuntu is able to pass trough the unconfigured SATA drives to the OS with only the SSD configured as RAID0, Can anyone confirm that this works for Debian/OMV as well?

    HP Proliant Microserver Gen8, E3-1265Lv2, 16 GB ECC RAM, 3x WD RED 3TB + 1x WD RED 4TB + Crucial MX300 525 GB SSD.

    Powered by Proxmox VE

  • I have a similar setup with a G8 Microserrver.

    1. Forget about the RAID controller, it's a so called "fake-raid" controller

    I'm using the SATA controller in AHCI mode, so it will always try to boot from the disc in the 1st bay.

    I have my SSD connected to the 5th SATA port, and configured the server to boot from USB/SD-Card.

    To get OMV up and running I did:

    Unplug all data drives,

    One time boot from install media (virtual DVD) and install OMV to SSD, this will also install grub onto the SSD,

    One time boot from harddisc (this will boot from SSD) and do a "grub-install /dev/sdx" followed by "update-grub2" where /dev/sdx is your SD-card (fdisk -l will tell you)

    Reboot and the box will boot from SD-card.

    Shutdown, insert your data drives, poweron and configure as desired.


    Cheers,

    Thomas

  • my drives are still in the old server. so if i understand you correctly, all i need to do is to run grub-install /dev/sdx && update-grub2 from my existing OMV installation to install the bootloader to an SD card?

    HP Proliant Microserver Gen8, E3-1265Lv2, 16 GB ECC RAM, 3x WD RED 3TB + 1x WD RED 4TB + Crucial MX300 525 GB SSD.

    Powered by Proxmox VE

  • If you already have OMV installed on the SSD, inserted the SD-Card and configured the server to boot from the SD-Card --> YES.

    If it worked correct, you will only see, after inserting a harddisc into the 1st bay.


    Good luck,

    Thomas

  • your proposed solution does not seem to work. I have taken the SSD with openmediavault installed from my old server and put it in place of the ODD drive. the SSD booted fine, but OMV did not boot fully due to the missing disks.


    from maintenance mode i did a grub-install /dev/sdc && update-grub2 (tried it without the update-grub2 part as well just in case, as some guides elsewhere on the net did not mention it).

    but when adding a drive into the bays, the system does not boot anymore. I can see in the boot messages that it first tried to boot from the USB DriveKey, then from the harddrive (so my bios boot order is correct), but it fails to succeed.


    any ideas what else can i try?


    edit: turns out i'm just plain stupid. forgot to set the bootable flag for the usb drive :rolleyes: works now

    HP Proliant Microserver Gen8, E3-1265Lv2, 16 GB ECC RAM, 3x WD RED 3TB + 1x WD RED 4TB + Crucial MX300 525 GB SSD.

    Powered by Proxmox VE

    Edited once, last by molnart ().

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!