ATA Errors after Hardware Upgrade and RAID Rebuild

  • Hi guys,

    I just upgraded my hardware with the following specs:

    • ASRock AB450 Pro 4 (BIOS Version 3.9)
    • Ryzen 5 2600
    • 16GB DDR4 3000Mhz RAM
    • bequiet Straight Power 400W PSU (already existed prior to upgrade)
    • Marvell based PCIe SATA Controller (Unfortunately I don't know the exact model)
    • 2TB WD Red RAID 1 (already existed prior to upgrade)
    • 1TB Samung 860 Evo RAID 1 (already existed prior to upgrade)
    • 4 TB WD Red RAID 1 (new)
    • 120GB SanDisk SSD Plus (OS-Drive (OMV 4.1.35-1), already existed prior to upgrade)

    After the first bootup the system was not able to connect one of the Samsung SSDs; therefore mdadm kicked this one out and I had to rebuild the array.

    So far so good, the array and in general the whole system ist working fine.

    SMART on all of my drives also looks fine.

    Unfortunately I get errors after bootup on the login screen (not through SSH) which look like the following:

    [   142.304181] ata18.00: exception Emask 0x0 SAct 0x1800 SErr 0x0 action 0x6 frozen
    [   142.304181] ata18.00: failed command: READ FPDMA QUEUED
    [   142.304181] ata18.00: cmd 60/08:d8:90:01:85/00:00:0c:00:00/40 tag 21 ncq dma 4096 out
    [   142.304181]          res 40/00:01:00:4f:c2/00:00:00:00:00/00 Emask 0x4 (timeout)
    [   142.304181] ata18.00: status: { DRDY }

    I already exchanged the SATA cables, tried different ports, removed the additional SATA PCIe controller card, tried a different card with an ASMedia controller.

    These errors always occur when the Samsung SSDs are connected.

    Weird is that SMART says theses drives are fully OK and they work just fine.

    I also checked both of them for physical damage to the connectors: these are also fine.

    What is especially weird: I cannot find any device which is associated with "ata18.00".

    I really don't know what to do at this point :(

    Thank you very much in advance for all of your assistance :)

  • This seems to be a known issue with Samsung SSDs and AMD/ASMedia SATA Controllers.
    I managed to resolve the issue by using a different Marvell based PCIe SATA Controller Card.

    I don't know why the issue persisted with the initial marvell based card.

  • CmdA

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!