Can't escape the samba permission hell

  • Hello OMV Community, after A LOT of trial and error I try to get some help with getting my SMB to work, as Samba is driving me freaking INSANE!

    (Is it normal, that this piece of **** software behaves like a diva?)



    First of all my config:


    I am using a Raspberry Pi 4B 8GB with the newest stable OMV5 installed on an 250GB USB 3.0 SSD on the newest stable Raspberry OS 32-bit (ARMv71). An 1 TB SSD for data is also plugged in and mounted. No MicroSD is involved or plugged in.



    My drive structure is the following:


    sda (250GB Sata SSD on USB 3.0)


    sda1 boot partition


    sda2 system partition


    sda3 a bigger partition, mounted like any other drives partition for data, including the data in the share, I am trying to get to work


    sdb (1TB Sata SSD on USB 3.0)


    sdb1 another mounted data partition dedicated to my music collection



    And these are my users and groups.




    pi is the standard user I am using SSH with and is also the user that Plex uses to access files


    samuel and samuelreadonly are my users, the last one is dedicated to scenarios where I expect other software to **** up my files while accessing it (did happen with a VMware drive, VMware deleted the entire virtual drive file, that gave me some bad time).


    vivien, heike and marco are family members in my house, who are also going to use my pi-NAS.




    These are my shares:





    So what I want is, for example: I have a share, called “Cloud_Samuel”.


    It should be accessible for the users samuel, samuelreadonly and also for pi.


    I want samuel and pi to have full access (including execute), while samuelread should only have read and execute.


    All other users should not have any access at all (also over NFS and FTP and everything possible else later), and the safer I can avoid them accessing my files, the better.




    What I get is:




    Directories:


    The users get the correct rights but the group "users" does not get any rights (thats not the biggest problem, as my users can access it like I want, but it is still strange behaviour)



    Files:


    Created with a Linux (KDE) Client (different PC, not the raspberry) via SMB in dolphin:


    All files get the correct and configured rights read and execute on samuel, samuelreadonly and pi.


    samuel and pi also get write, but they don’t get full access and modify (which are also rights I want them to have), like the folders get.


    The group “users” get the same rights as the user samuelreadonly, read and execute, which is correct.



    Created with Windows 10:


    Now the fun part starts, I dont have any clue what the hell is going on here.


    The permissions depend on the file type (yes, you read that right), but not in any logical way.


    So for example, if I create an rtf file, it will get the same permissions as the files I create with the Linux, which is the better scenario. Theres still the weird thing with no modify or full access but at least it is, like I configured it in the ACL window in OMV.



    But when I create an .txt or .bmp file, none of the users and also not the group "users" get the permission execute (which I want all files to have).



    I mean what the hell is going on here. I tried like every option and scenario OMV 5 gives me, and this is the best I get. I don’t even know where I should start. Is it Windows or Sambas fault? Is OMV5 not able to configure Samba the way I want it to work or are my Unix-permissions broken?




    Share information:



    Share permissions:



    Share ACL:



    Samba Config:


    Advanced Options:



    Samba Share Config



    smb.conf:



    Let me know where I can find further information to give like logs and stuff, if needed.



    Thanks in advance for any help on this.


    SilverLPs

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!