Cannot connect via SSH after changing public key

  • So, I installed OMV the other day and it has just been constant issues since then, a lot of which I was able to solve after being driven insane by the software. The one I'm not able to solve is SSH denying the connection even though my public SSH key is on the system. It worked fine for a bit on my test key but as soon as I removed that and added my production key it continuously denies connection (system has been rebooted after swapping pub keys just incase it was that). The keys are definitely matching as I can ssh to a different system with the exact same keys without issue. I have tried removing the production key and again adding the test key and that too now gets denied.



    Extra less important question:

    When adding a public key to a user via the Web UI why does it ask for it in RFC 4716 format, why isn't just a standard public key (as in one generated by ssh-keygen) usable?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!