Upgrade from laptop to desktop

  • Hi guys,


    I recently updated my OMV build from laptop to desktop. The CPU is Ryzen 1700, 16GB DDR4 RAM 3000MHz, 4 spin disks, GeForce 8500 GT with passive cooling. The whole server is powered by 400W PSU.


    Now today happened, that the server stopped responding, no ssh connection to the server, all shares were not accessible, nothing helped, i had to use hard power off. After the server started, no issues were found in syslog.


    Im assuming that the LAN cable is bad, but the old laptop used the same cable, and was working without any issues. Or the PSU is not enough for this HW configuration?

    I used this page to check the power consumptions https://outervision.com/power-supply-calculator, but it is showing me that my server should consume 270W. So 400W should be enough, or?


    pls do you have some ideas what to check? or what log to check? thanks for any hints.

  • Im assuming that the LAN cable is bad,

    This happened to me once where my server stopped responding to the network. Re-plugging the Ethernet cable fixed it. The cable doesn't have to be bad. Sometimes they just need to be reseated. RJ45 plugs and connectors are not perfect, with very small contact surfaces. Next time (if there is a next time) move the cable ends around.

    A 400 watt PS should be fine for application. If there was a power issue it would likely show up at start up, when current draw is the highest.

  • crashtest - thx for reply, today it happened again. Exactly that i tried, to unplug the LAN cable and put it back, but no effect on the connection. After that I connected monitor/display to the server and no picture was on it, so it was probably frozen. I had to do hard reset.

    I have seen some errors regarding the system drive in dmesg, so I changed the disk for the one that was on the obsolete laptop. For now no errors in dmesg, lets see if the server will survive at least 24 hours to be reachable and online... but really strange behavior...

  • UPDATE: I had to switch to proxmox 5.4, newer version I had no luck to install (6.2)... OMV is running as VM and no issues so far, except follwing error messages on proxmox during some high IO operations:

    based on some googling, looks like a sata controller issue. i changed sata cable, i changed sata slot position, issue still persist... disk drive doesnt have issues in SMART checks.

    I ordered today a pci-e sata controler for the motherboard and i will see if the issue will persist, when i will connect the system disk to the new sata controller

  • You're doing the right thing, removing or swapping out suspected hardware. But note that just because the disk is passing SMART tests doesn't necessarily mean the disk's SATA board is 100%, which might explain why the issue moves from port to port. True hardware issues can manifest in odd ways.

    That's one of the problems with today's CMOS circuity. A blown gate can still work but be "glitchy".

  • UPDATE 2: so looks like you were right, after plugged in the new sata controller, the error still persist. I will look after some new ssd drive to change it...

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!