How to wake up Fit-pc2 from suspend at particular time?

  • Hello everybody,


    I'm new here... I saw a post in this forum googling the internet, talking about a Fit-pc 2 resuming from -m mem mode suspend at a particular given time.
    When I used # sudo rtcwake -m mem -s 120 (for example...) my fit-pc 2 enter successfully the suspend mode, the power-on green light will successfully light up 2 minutes later but afterwards no reboot happens or better, not even keyboard signals are sent, no video card signals even : the Fit-pc2 seems to be turned off, there's only the power-on green light to give me just the illusion of a running PC . :cry:


    The point is :
    - is this the right way it suspends as I have to push the power button anyway to start it again ? (this would be really disappointing to me :? )


    - Do I have to enable something in my kernel or do I have to change some settings to get it to enter the OS by itself after the suspend given period ?


    My FitPC2 is BIOS rev 1.4 and the BIOS has RTC wake-up ACPI availability through OS (S3) as stated in its website, my OS is Ubuntu 12.04 the great !


    Hope this could help someone else,
    thank you for your attention,
    good day !

  • I have had my Fit-pc2 turning on and of at specific times using rtcwake under ubuntu 12.04. You have the syntax right with

    Code
    rtcwake -m mem -s <seconds_to_sleep>


    I can't remember precisely how i did this but i know that one thing you have et set is that the bios is NOT set to use ACPI wake. I think the best thing to do is to reset bios to be sure old configuration errors in the bios isn't blocking rtcwake.


    Next thing is be sure you do this as root or with "sudo"


    You can test wheter the rtcwake command is setting your wakeup time by using the -m no parameter and then examine the rtc - like:

    Code
    rtcwake -m no -t 600


    This will set the wakeup time to 600 seconds from now
    Then display the rtc wake paramters with:

    Code
    cat /proc/driver/rtc


    It should show alarmtime/date that is 10 minuters into the future UTC time - like:

    Code
    ....
    rtc_time : 08:09:32
    rtc_date : 2014-02-07
    alrm_time : 08:19:21
    alrm_date : 2014-02-07
    alarm_IRQ : yes
    ....


    Note that you need to have the pc to use UTC time to be able to use rtcwake reliably.


    Could you make the above test and se if the alrm_time is set. Also check that the rtc time reflects UTC time

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!