S.M.A.R.T. support is disabled after server WOL

  • Every time after my server wakes from hiberation via WoL I receive the following email notification:


    Quote

    Device: /dev/disk/by-id/ata-ST4000VN008-2DR166_ZGY8AL7G [SAT], Read SMART Self-Test Log Failed


    By looking at the Extended Information and Device Properties I find that SMART support seems to be disabled while monitoring is still enabled:


    Quote

    SMART support is: Available - device has SMART capability.

    SMART support is: Disabled

    Manually disabling and re-enabling SMART monitoring for the specific drive fixes the problem until the server wakes up again.

    I have no clue on how to fix it permanently.




    Device information:

    Model Family: Seagate IronWolf

    Device Model: ST4000VN008-2DR166

    According to the SMART tests the drive has no errors.


    Motherboard: Asrock AM1H-ITX


    RAID config: RAID1 (Mirror)






  • I managed to fix it myself.


    It turned out that S.M.A.R.T. wasn't enabled in the bios.


    Another change that I made was connecting the sata cables of the storage drives to the same group of sata connectors on the motherboard. The motherboard apparently has two groups of sata connectors. One group connects directly to the CPU and the other is supported by a different onboard sata controller. Connecting the storage to the same group made sense to me. Not sure though if this made any difference, because I changed the bios setting in one go.

  • Trebor

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!