omv-firstaid fails to reset a bond interface

  • I ran into trouble with a bond interface on my OMV server yesterday and want to report it, as I'm not sure my system is cleanly configured now and as this might be a bug within the bond configuration and/or a missing feature within omv-firstaid.


    My OMV server has two 1GB NICs, which were configured as bond0 with a static IP address. Trying to change the static IP address to DHCP and applying the new configuration the OMV webui errored out. I'm not sure whether this was a problem on the OMV or on the router side. In any case, afterwards my server disappeared from the network.


    I've then logged into the CLI of my server and ran omv-firstaid to recover a working network configuration. I just tried to reestablish one of the NICs as IP4 client using DHCP, but the configuration with omv-firstaid failed on both,, despite attempts to reboot the server. I've inspected the network configuration wihtin /etc/openmediavault/config.xml and found that the bond-parameter within the interface section still contained a 1. I've changed it to 0 and rebooted, but to no avail.


    I've then found reports on similar issues with RPi's (not what I have, my server is Intel-based), and ran the following commands to fix my network configuration:

    Code
    sudo netplan apply
    sudo omv-salt deploy run systemd-networkd

    After rebooting the device again, the last configuration I tried to establish via omv-firstaid fortunately started working and the server reappeared on my network.


    Logging back into the OMV-GUI, I was immediately asked to apply a changed configuration, which I did. It took several minutes, but afterwards everything seemed fine. The configured NIC is correctly listed under Network -> Interfaces. I've left the second NIC unconfigured and waived the bond for now, as I had no appetite to ask for even more trouble.


    The only observation I've made is that ip a shows two bridge interfaces (something like br-0345234343436) in addition to the two NICs I've expected. I'm not sure whether these are remnants of the broken bond configuration or unrelated (e.g. I do run bridge networks within docker on that server, too).


    In any case, interested in how you read the situation and to share my experience in case somebody else runs into similar issues.

  • I was trying to undo the bonding of my two nics. I used omv-firstaid to define one Nic and it errored out the first two times. I tired a third time and after about a minute, it returned with success.


    I was able to log into OMV from the gui. I checked the interface entry in config.xml and similarly it shows <bondmode>1</bondmode>. It was previously showing <bondmode>4</bondmode>.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!