Error while updating

  • Hello OMV family,

    recently I have been getting errors while checking for updates on OMV 5.5.23-1.

    You can find the log in the attached .txt file


    I am a linux noob so unfortunately I am unable to solve this myself. But it looks like there is a problem with a the docker repository. How do I solve this?

    I already tried disabling ipv6 for apt but that didn't help


    Log:

    • Official Post

    How do I solve this?

    Did the suggestion I gave you in the github issue not work?

    omv 7.1.1-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.14 | compose 7.2.1 | k8s 7.1.1-1 | cputemp 7.0.2 | mergerfs 7.0.5 | scripts 7.0.8


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

    • Official Post

    got the same errors again.

    Post the output. I don't believe they are the same. And post the output from running the command I gave you.

    omv 7.1.1-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.14 | compose 7.2.1 | k8s 7.1.1-1 | cputemp 7.0.2 | mergerfs 7.0.5 | scripts 7.0.8


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • 1. Output when checking for updates via OMV

    2. Output of the command you gave me


    Code
    root@NAS:~# echo 'Acquire::ForceIPv4 "true";' | sudo tee /etc/apt/apt.conf.d/99force-ipv4
    Acquire::ForceIPv4 "true";
    root@NAS:~#
    • Official Post

    Err:16 https://download.docker.com/linux/ubuntu buster Release
    404 Not Found [IP: 143.204.90.90 443]

    This is caused by you. omv-extras doesn't add the Ubuntu docker repo. Not sure how it got there (you added?). What is the output of: grep -r ubuntu /etc/apt/*

    omv 7.1.1-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.14 | compose 7.2.1 | k8s 7.1.1-1 | cputemp 7.0.2 | mergerfs 7.0.5 | scripts 7.0.8


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • I believe I might have added this repo by accident, when trying to install home assistant. I believe I added the wrong repo here but don't know how to remove it.


    The output is:

    root@NAS:~# grep -r ubuntu /etc/apt/*

    /etc/apt/sources.list:deb [arch=amd64] https://download.docker.com/linux/ubuntu buster stable

    /etc/apt/sources.list:# deb-src [arch=amd64] https://download.docker.com/linux/ubuntu buster stable

    /etc/apt/sources.list:# deb-src [arch=amd64] https://download.docker.com/linux/ubuntu buster stable

    /etc/apt/sources.list.save:deb [arch=amd64] https://download.docker.com/linux/ubuntu buster stable

    /etc/apt/sources.list.save:# deb-src [arch=amd64] https://download.docker.com/linux/ubuntu buster stable

    • Official Post

    I believe I might have added this repo by accident, when trying to install home assistant. I believe I added the wrong repo here but don't know how to remove it.

    You definitely added it. Edit /etc/apt/sources.list and remove any docker lines.

    omv 7.1.1-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.14 | compose 7.2.1 | k8s 7.1.1-1 | cputemp 7.0.2 | mergerfs 7.0.5 | scripts 7.0.8


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • and remove any docker lines

    Even if I use Docker on my mashine? Don't I also delete the right repo for my setup when I delete any Docker line?


    I am on Debian Buster 5.10.13-1, if that helps


    It worked. Thanks alot ryecoaaron!!!

    • Official Post

    Even if I use Docker on my mashine?

    First, even if you remove the docker repo, it doesn't remove docker. Second, omv-extras add the proper docker repo to the /etc/apt/sources.list.d/omvextras.list file. Third, you shouldn't add non-Debian repos to /etc/apt/sources.list.

    Don't I also delete the right repo for my setup when I delete any Docker line?

    No.

    omv 7.1.1-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.14 | compose 7.2.1 | k8s 7.1.1-1 | cputemp 7.0.2 | mergerfs 7.0.5 | scripts 7.0.8


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • votdev

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!