can't remove NFS share without triggering omv-salt issue

  • I have a samba share folder that gets a "permission denied" error as "guest allowed" when trying to access via a client. It is set up absolutely exactly the same way as my other shares, but for some reasons, the behaviour is different. The only difference I would say is that the share comes from a different HDD which I had to replace (there is no RAID in place in my OMV instance.)

    Anyway, long story short, after a lot of frustration, I decided to get rid of the faulty share and restart from scratch. I managed to remove the samba share. But removing the NFS share doesn't work. I stopped all my dockers accessing it so that should not be the issue.

    I'm at a point now where I can't do any changes on the NFS/samba and shared folders without triggering the same omv-salt deploy run --no-color fstab 2>&1' type of error. and I run out of options.

    I'm using the latest 5.6 released a few days ago

    I attached the log output of the issue

  • I am now at a stage, where despite the fact that removing a NFS shared failed, and that reverted to the last "kind of working" changes (I also have the same share folder enabled on samba), the folder doesn't exist in the filesystem anymore under /export/***

    Looking at the OMV frontend, I can't see any difference between that share and the other working ones on my machine, but there must be some true wizardly happening behind the scenes

  • after further trial/error, I found out that I can create successfully a new accessible NFS/Samba share folder created on HDD "A" for example, but if I create a folder on another HDD "B", then this folder is not accessible via the Samba share. This doesn't make any sense to me as I can see that the permissions, user:group are set to exactly the same way on the HDD side, the NFS and Samba permissions.

    For clarification, my HDD "A" is an HDD with existing shared folders, which all work fine

    my HDD "B" is a manual replacement of a faulty HDD. I manually removed (via the OMV interface) previous shared folders, NFS/SAMBE shares and created new ones mapping this new HDD. I had done this in the past without any issues. But this time, this hasn't worked as said in my first post

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!