Error when installing ZFS Plugin

  • Hi,

    i just try to set up our file server with OMV 5 and wanted to use the ZFS file system. It always ends with Errors, but OMV tells me, that the plugin is installed.


    OMV itself is installed on a clean system on a small SSD with 2 18TB HDD that shall work as a RAID 1.


    I tried the installation also on a VirtualBox testserver with the same result. No error free installation of the ZFS plugin.


    Or shall i forget ZFS and use BTRFS instead?


    This is the installation log. I started at the first error, as the complete log is too long.

    • Official Post

    Did you reboot after installing the 5.10 kernel? You should. And I would probably use the proxmox kernel.

    omv 7.4.0-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.14 | compose 7.2.1 | k8s 7.2.0-1 | cputemp 7.0.2 | mergerfs 7.0.5 | scripts 7.0.8


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • Did you reboot after installing the 5.10 kernel? You should. And I would probably use the proxmox kernel.

    Yes, one of the first after installing the OMV specials was updating and upgrading everything and a reboot too.

    • Official Post

    modprobe: FATAL: Module zfs not found in directory /lib/modules/5.7.0-0.bpo.2-amd64

    Weird because it is trying to load the module for the 5.7 kernel which typically means the system is running that kernel at that moment. What is the output of:


    dpkg -l | grep linux-

    uname -a

    omv 7.4.0-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.14 | compose 7.2.1 | k8s 7.2.0-1 | cputemp 7.0.2 | mergerfs 7.0.5 | scripts 7.0.8


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

    • Official Post

    You have the 5.10 kernel installed but you are still booting the 5.7 kernel. From the Kernel tab in omv-extras, set the 5.10 kernel to boot.

    omv 7.4.0-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.14 | compose 7.2.1 | k8s 7.2.0-1 | cputemp 7.0.2 | mergerfs 7.0.5 | scripts 7.0.8


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!