OMV chrashes when trying to mount

  • When i try to mount a disk that is freshly formated the omv chrashes and also generates blank /etc/openmediavault/config.xml so it basically kills omv.

    this is the error it throws when trying to mount:

    Removing the directory '/' has been aborted, the resource is busy.

    Error #0:

    OMV\Exception: Removing the directory '/' has been aborted, the resource is busy. in /usr/share/openmediavault/engined/module/

    Stack trace:

    #0 [internal function]: Engined\Module\FSTab->deleteEntry(Array)

    #1 /usr/share/php/openmediavault/engine/module/ call_user_func_array(Array, Array)

    #2 /usr/share/openmediavault/engined/module/ OMV\Engine\Module\ModuleAbstract->execTasks('delete')

    #3 /usr/share/openmediavault/engined/rpc/ Engined\Module\FSTab->preDeploy()

    #4 [internal function]: Engined\Rpc\Config->applyChanges(Array, Array)

    #5 /usr/share/php/openmediavault/rpc/ call_user_func_array(Array, Array)

    #6 /usr/share/php/openmediavault/rpc/ OMV\Rpc\ServiceAbstract->callMethod('applyChanges', Array, Array)

    #7 /usr/share/openmediavault/engined/rpc/ OMV\Rpc\Rpc::call('Config', 'applyChanges', Array, Array)

    #8 [internal function]: Engined\Rpc\OMVRpcServiceFileSystemMgmt->mount(Array, Array)

    #9 /usr/share/php/openmediavault/rpc/ call_user_func_array(Array, Array)

    #10 /usr/share/php/openmediavault/rpc/ OMV\Rpc\ServiceAbstract->callMethod('mount', Array, Array)

    #11 /usr/sbin/omv-engined(537): OMV\Rpc\Rpc::call('FileSystemMgmt', 'mount', Array, Array, 1)

    #12 {main}

  • after blank xml (0kb)

    Error #0:

    OMV\Config\DatabaseException: Fatal error 4: Document is empty (line=1, column=1) in /usr/share/php/openmediavault/config/

    Stack trace:

    #0 /usr/share/php/openmediavault/config/ OMV\Config\DatabaseBackend->load()

    #1 /usr/share/php/openmediavault/config/ OMV\Config\Database->__construct()

    #2 /usr/share/openmediavault/engined/rpc/ OMV\Config\Database::getInstance()

    #3 /usr/share/php/openmediavault/rpc/ Engined\Rpc\OMVRpcServiceFileSystemMgmt->Engined\Rpc\{closure}()

    #4 /usr/share/openmediavault/engined/rpc/ OMV\Rpc\ServiceAbstract->asyncProc(Object(Closure))

    #5 [internal function]: Engined\Rpc\OMVRpcServiceFileSystemMgmt->enumerateFilesystems(NULL, Array)

    #6 /usr/share/php/openmediavault/rpc/ call_user_func_array(Array, Array)

    #7 /usr/share/openmediavault/engined/rpc/ OMV\Rpc\ServiceAbstract->callMethod('enumerateFilesy...', NULL, Array)

    #8 [internal function]: Engined\Rpc\OMVRpcServiceFileSystemMgmt->getList(Array, Array)

    #9 /usr/share/php/openmediavault/rpc/ call_user_func_array(Array, Array)

    #10 /usr/share/php/openmediavault/rpc/ OMV\Rpc\ServiceAbstract->callMethod('getList', Array, Array)

    #11 /usr/share/php/openmediavault/rpc/ OMV\Rpc\ServiceAbstract->OMV\Rpc\{closure}('/tmp/bgstatusXj...', '/tmp/bgoutput5R...')

    #12 /usr/share/php/openmediavault/rpc/ OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))

    #13 /usr/share/openmediavault/engined/rpc/ OMV\Rpc\ServiceAbstract->callMethodBg('getList', Array, Array)

    #14 [internal function]: Engined\Rpc\OMVRpcServiceFileSystemMgmt->getListBg(Array, Array)

    #15 /usr/share/php/openmediavault/rpc/ call_user_func_array(Array, Array)

    #16 /usr/share/php/openmediavault/rpc/ OMV\Rpc\ServiceAbstract->callMethod('getListBg', Array, Array)

    #17 /usr/sbin/omv-engined(537): OMV\Rpc\Rpc::call('FileSystemMgmt', 'getListBg', Array, Array, 1)

    #18 {main}

  • I'm also having the same issue. Trying to mount an external USB drive.

  • See this thread from the beginning to see if you can do the same:

    error mounting disk - General - openmediavault

    Take in consideration that ALL DATA on the drive will be lost.

    I'll take no responsibility on that.

  • Thanks Soma for the help.

    I followed the guide, including a total wipe and repartitioning with gdisk. Then via the OMV GUI I create a file system.

    Each time I get the same error when trying to mount, then an immediate system reboot.

    This error is addressed in this thread but with no solution. Both USB hard drives are plugged into the same USB PCIe expansion card, so I don't know if there is a possible device conflict.

  • verlyn13

    Let's start from the beginning:

    Explain the most details you can about the hardware/software, details of what you done an what you're trying to do.

    How big is the drive you're adding?

  • The trouble started for me when I plugged in a 4TB seagate external USB drive formatted as NTFS. I was hoping to transfer the files to my main storage, then wipe and reformat as EXT4 and keep it secondary storage. The drive showed and mounted and shared. However, it gave errors when trying to transfer files over the network. Any actions in the GUI then led to errors with the drive. I then made the mistake of removing the drive before deleting the share. Once I realized this, I removed the share but then a missing entry showed in the filesystems menu. The 'delete' button was grayed out. I ended up removing the entry by editing the /etc/config file. From there, my efforts are described in the previous post.

    I am able to mount the drive just fine via CLI. The drive shows up in the menu and works. However, its mount conditions were not determined by OMV and I worry about future incompatibilities. Any effort to work the drive via the GUI results in the previously described system errors.

    My admitted mistake was not deleting the share before removing the buggy drive. Also, perhaps editing the config file dug the hole deeper and created a system incompatibility somewhere. Everything else seems to be working fine, or else I'd be more enthusiastic about an entire system reinstall and setup. Also, this is a family backup and a hobby project, not a high-priority business-related project. I'm looking to learn about the system and make things as user-friendly as possible for my family to eventually use and manage.

  • Hi, I recently got this error and had a terrifying time, but I eventually solved my problem, so I want to share my method even if this thread is gone obsolete.

    I'm using OMV 6 right now but I experienced same error when I used OMV 5, and this error occured after changing the main drive to NVMe SSD.

    The error log was like this:

    This error is exactly like verlyn13's error.

    I found the solution by chance, after looking the thread of applying pending configuration on CLI, which is like this;

    This should do the trick:

    sudo /usr/sbin/omv-rpc -u admin "config" "applyChanges" "{ \"modules\": $(cat /var/lib/openmediavault/dirtymodules.json),\"force\": true }"[

    I focused on the json file's location, /var/lib/openmediavault/dirtymodules.json

    If you check the location of the json file, which is /var/lib/openmediavault , hopefully there is a file named 'fstab_tasks.json'.

    In fstab_tasks.json, there are lists of commanding removal of disks which is no longer avaliable, and the file looks like this:

    I solved my error by completely deleting the json file (fstab_tasks.json), because I already modified config.xml and /etc/fstab so my mountpoints are completely stable.

    And, voila, error is gone. I can use webgui like old times.

    I removed it but if your filesystem is in unstable state, you must modify the json file and retry the applying procedure.

    I don't know the json file's logic, especially what the "uuid" means. It doesn't matches of the blkid results if I get one. I think the "uuid"s are openmediavault's exclusive id.

    TL;DR : delete /var/lib/openmediavault/fstab_tasks.json (should backup the file just in case).

    if you think your filesystem status is unstable, you can inspect fstab_tasks.json file and delete the lines which is occuring error. (the lines which the "uuid" section indicates the existing and using filesystem)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!