Windows Previous versions with BTRFS snapshots not working

  • Hi,

    I'm a beginner in OMV and please excuse my bad english as it is not my native language.

    I wanted a NAS at home, and OMV seemed the finest solution. I've set it up, the share's are working.

    For now i am in the testing / configuration level, its not under production yet.

    I want to use this OMV computer for several things, but theres is one thing that i've have'nt managed to advance with : windows previous versions.

    I create the BTRFS file system, i mount it, i create a share.

    The share shows up on my windows 11 clients.

    The problem appears when i take a snapshot : i find the snapshot within OMV GUI and within ".snapshots" folder but on my windows clients, when i go to the "previous versions" tab it is not appearing, the tab is empty.

    I've read several "how to"-s, but there aren't many, they are generally outdated (2015) and i can't get them to work.

    I must be doing something wrong.

    Can somebody please explain me how to populate windows previous versions tab?

    Since OMV implemented BTRFS snapshots in its GUI i think (hope) it should be a lot easyer.

    Thanks in advance.

  • I think i am doing the same thing, only it's not working.

    Does the user has to have some special permissions ? For me it's read/write on the share ...

  • Hi, also an beginner and it's not working for me too.

    My specs:

    • OMV 6.3.10-2 (Shaitan)
    • Odroid HC4 with two 4TB HDDs running in RAID1/Mirror
    • Armbian 23.02.2 Bullseye
    • OMV is installed by the armbian-config tool
    • Desktop is Windows 11 Pro

    What I have tried:

    1. Create new user "testUser"
      • Groups: sambashare, users
    2. Storage > Disks > wipe both HDDs
    3. Software RAID > created raid with mirror option
    4. Shared Folders > created new shared folder named "public"
      • relativ path: public/
      • Administrator: read/write, Users: read/write, Others: read-only
    5. Services > SMB/CIFS > Shares > created new share
      • enabled
      • shared folder: public
      • Guests allowed
      • Browseable
      • Recycle Bin: 1GB, 7 days
    6. In Windows mount share as network drive H:\ with testUser

    Then I created a new txt file and made a snapshot. Changed the txt and created another snapshot. (like in the video).

    But the snapshots don't show up in Windows.

    I also tried without "Software RAID" and created the raid under "File Systems" > btrfs > RAID1 > both HDDs. But sadly no change.

  • I managed to get it to work!

    If you are interested, do the following:

    1. Update OMV to the latest version.

    Log in to it via SSH (login root, password - you know) and run the omv-upgrade command (for some reason, the web ui refuses to completely upgrade the system)

    2. Apply the changes through the web ui (the yellow line at the top of the page)

    3. Reboot OMV

    4. Create a new share on the BTRFS disk, and the Snapshots button will become active

    5. Create an SMB/CIFS share (in the Extra Options, add line shadow:localtime = no. By default OMV sets its yes, and Windows does not show anything in the Previous Versions tab, and in the logs you can see the error filename_convert_internal: check_name failed)

    All done! You can connect now, but do not forget to configure Snapshots to be created on a schedule, or use the button in web ui

    • New
    • Official Post

    Was not able to see any difference when setting to no. Because of that i adapted the source code and OMV will deploy shadow:localtime = no by default in openmediavault 6.4.0. See…1ab73fa1911a720da3f7272db

  • Was not able to see any difference when setting to no.


    I see a difference, putting localtime=no , the snapshot appears as UTC time instead of my local time - continental europe, so in summer 2hours shifted from UTC.

    I corrected putting localtime=yes in smb.conf

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!