6.9.8.1 update failure after power cut

  • Hi,


    After a power cut and crash, think there is corruption on one of my OMV boxes as no updates show in Web GUI, but shown in CLI after apt update.

    The updates not installing and giving errors.

    Error log from apt upgrade attached, any ideas? (I am not a CLI expert).


    Setting up openmediavault (6.9.8-1) ...

    Creating configuration database ...

    Migrating configuration database ...

    Setting up Salt environment ...

    Traceback (most recent call last):

    File "/usr/bin/salt-call", line 33, in <module>

    sys.exit(load_entry_point('salt==3007.0', 'console_scripts', 'salt-call')())

    File "/usr/bin/salt-call", line 25, in importlib_load_entry_point

    return next(matches).load()

    File "/usr/lib/python3.9/importlib/metadata.py", line 77, in load

    module = import_module(match.group('module'))

    File "/usr/lib/python3.9/importlib/__init__.py", line 127, in import_module

    return _bootstrap._gcd_import(name[level:], package, level)

    File "<frozen importlib._bootstrap>", line 1030, in _gcd_import

    File "<frozen importlib._bootstrap>", line 1007, in _find_and_load

    File "<frozen importlib._bootstrap>", line 972, in _find_and_load_unlocked

    File "<frozen importlib._bootstrap>", line 228, in _call_with_frames_removed

    File "<frozen importlib._bootstrap>", line 1030, in _gcd_import

    File "<frozen importlib._bootstrap>", line 1007, in _find_and_load

    File "<frozen importlib._bootstrap>", line 986, in _find_and_load_unlocked

    File "<frozen importlib._bootstrap>", line 680, in _load_unlocked

    File "<frozen importlib._bootstrap_external>", line 790, in exec_module

    File "<frozen importlib._bootstrap>", line 228, in _call_with_frames_removed

    File "/usr/lib/python3/dist-packages/salt/__init__.py", line 140, in <module>

    import salt._logging # isort:skip

    File "/usr/lib/python3/dist-packages/salt/_logging/__init__.py", line 12, in <module>

    from salt._logging.impl import (

    File "/usr/lib/python3/dist-packages/salt/_logging/impl.py", line 29, in <module>

    from salt._logging.handlers import DeferredStreamHandler # isort:skip

    File "/usr/lib/python3/dist-packages/salt/_logging/handlers.py", line 16, in <module>

    from salt.utils.versions import warn_until_date

    File "/usr/lib/python3/dist-packages/salt/utils/versions.py", line 11, in <module>

    import datetime

    File "<frozen importlib._bootstrap>", line 1007, in _find_and_load

    File "<frozen importlib._bootstrap>", line 986, in _find_and_load_unlocked

    File "<frozen importlib._bootstrap>", line 680, in _load_unlocked

    File "<frozen importlib._bootstrap_external>", line 786, in exec_module

    File "<frozen importlib._bootstrap_external>", line 918, in get_code

    File "<frozen importlib._bootstrap_external>", line 587, in _compile_bytecode

    ValueError: bad marshal data (invalid reference)

    dpkg: error processing package openmediavault (--configure):

    installed openmediavault package post-installation script subprocess returned error exit status 1

    dpkg: dependency problems prevent configuration of openmediavault-usbbackup:

    openmediavault-usbbackup depends on openmediavault (>= 6.5.0); however:

    Package openmediavault is not configured yet.


    dpkg: error processing package openmediavault-usbbackup (--configure):

    dependency problems - leaving unconfigured

    dpkg: dependency problems prevent configuration of openmediavault-clamav:

    openmediavault-clamav depends on openmediavault (>= 6.5.0); however:

    Package openmediavault is not configured yet.


    dpkg: error processing package openmediavault-clamav (--configure):

    dependency problems - leaving unconfigured

    Errors were encountered while processing:

    openmediavault

    openmediavault-usbbackup

    openmediavault-clamav

    Traceback (most recent call last):

    File "/usr/sbin/omv-mkaptidx", line 39, in <module>

    import apt

    File "/usr/lib/python3/dist-packages/apt/__init__.py", line 26, in <module>

    from apt.package import Package as Package, Version as Version

    File "/usr/lib/python3/dist-packages/apt/package.py", line 32, in <module>

    from http.client import BadStatusLine

    File "/usr/lib/python3.9/http/client.py", line 71, in <module>

    import email.parser

    File "/usr/lib/python3.9/email/parser.py", line 12, in <module>

    from email.feedparser import FeedParser, BytesFeedParser

    File "/usr/lib/python3.9/email/feedparser.py", line 27, in <module>

    from email._policybase import compat32

    File "/usr/lib/python3.9/email/_policybase.py", line 9, in <module>

    from email.utils import _has_surrogates

    File "/usr/lib/python3.9/email/utils.py", line 30, in <module>

    import datetime

    File "<frozen importlib._bootstrap>", line 1007, in _find_and_load

    File "<frozen importlib._bootstrap>", line 986, in _find_and_load_unlocked

    File "<frozen importlib._bootstrap>", line 680, in _load_unlocked

    File "<frozen importlib._bootstrap_external>", line 786, in exec_module

    File "<frozen importlib._bootstrap_external>", line 918, in get_code

    File "<frozen importlib._bootstrap_external>", line 587, in _compile_bytecode

    ValueError: bad marshal data (invalid reference)

    E: Sub-process /usr/bin/dpkg returned an error code (1)

    root

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!