Permission denied-error on TFTP-service (but file is set on 777...)

  • Hi there

    seems there is nearly no action in the tftp-section, but I'm struggling hard with this.

    Goal: network boot for 5x raspi 4b (RaspOS lite 64bit)

    - installed OMV (Hostname: omvNAS, Version: 7.0-24 (Sandworm), Kernel: Linux 6.1.0-17-amd64); IP:

    - activated nfs and tftp

    - nfs-share for boot/rootfiles is "Cluster" --> there are separated dirs for root- (named by hostname) and bootfiles (named by raspi-serial-no.)

    - files are synced to the folders from the raspi

    TFTP-options in tftpd-hpa (I edited everything in the omv-gui)

    # This file is auto-generated by openmediavault

    # WARNING: Do not edit this file, your changes will get lost.




    TFTP_OPTIONS="--secure --blocksize 512 --retransmit 1000000 --create --verbose,--permissive"

    Error: starting the raspi shows the IP of the tftp-server, but also a "file not found" error

    what I tried:

    - I'm able to connect to the tftp-server from my desktop. but I can't download a testfile. I can upload a testfile.

    $ tftp
    tftp> put test.txt
    tftp> get cluster.txt
    tftp: cluster.txt: Permission denied
    tftp> get cluster.txt
    tftp: cluster.txt: Permission denied

    on the OMV the permissions look like this:

    (I already used chmod 777 on cluster.txt, after it did not work with 644
    and I even added the tftp-user to the users-group )

    # ls -l
    insgesamt 12
    drwxr-sr-x  3 root users 4096 21. Jan 11:32 07535901
    -rwxrwxrwt  1 root users    8 21. Jan 11:32 cluster.txt
    drwxr-xr-x 18 root root  4096 21. Jan 11:33 piCluster05
    -rw-rw-rw-  1 tftp users    0 21. Jan 13:02 test.txt

    Don't see why this is not working!

    What I couldn't try was to delete the "--secure"-option as this seems to be set by the omv-default when starting the tftp-server.

    Who knows about this?

  • chente

    Approved the thread.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!