can't write to NAS drives, permissions problem

  • hello everyone



    It's my first time with OMV. Before i used a Dlink NAS, recently i think in change for a solution based on OMV



    The hardware is:

    • Raspberry pi 3b,
    • 1 hd mechanic with 1,3TB, the file system is ExtFat connect to the USB port
    • 1 hd M.2 with 2TB, the file System is EXT4 connect to the USB port

    The version of OVM is 6.9.15-1, the raspberry boot in a SD card



    I want shared folders by SMB



    I HAVE READ ALL THE SHARED FOLDERS BUT, I HAVEN'T PERMISSION FOR WRITE IN THE HD'S. I HAVE PERMISSION FOR WRITE IN THE SD CARD



    The user who I log in the interface is admin


    The user for SMB is joaquin



    In the Storage - Disk section I have mounted the two hd and the SD card


    In "File systems" I have the two HD mounted with the green signal (Status Online)


    In “Share folders”:

    • I have put the root of the disk M.2 with the path “NAS/”,
    • I have put the root of the disk HD Mecanical with the path "Peliculas/"
    • I have put a folder in the SD Card with the path "prueba/" (only form testing proposes)



    In the two Disk Joaquín user and Joaquín group is with permissions Read/Write, but in the SD card Joaquín user and Joaquín group haven't any permission, the SD Card have the possibility to use ACL but I don't use it



    The three paths are enabled in “Services – SMB/CIFS – Shared”



    If I connect by SMB using “Joaquin” user I saw the folders, I can read the files but u can’t read


    If I Connect by ssh I have the same problem, if I try create a file with “Joaquín” user I can’t create this file, but if I do a “sudo su” and I became root I can write in this folders



    However, in the test folder “prueba” I can read and write perfectly



    Is not a problem of SMB is a permissions problem


    • In the “prueba” folder inside the SD Card the properties are: RWXRWXRWX root users
    • In the “/” of HD’s I have the properties: RWXR-XR-X root root


    I really want the two HDs in ExFat, it's for personal use, I don't need much security, but I want to be able to read and write to them.



    Thank you

  • crashtest

    Approved the thread.
    • New
    • Official Post

    Try creating a shared folder / SMB network share, in accordance with this process -> Creating a Network Share. The resultant shared folder will be at the root of the data drive. For simplicity in permissions (and to avoid permissions issues that can be created by using a nested path), that's where your data folders should be - at the root of the data drive. The created shared folder / network share will have wide open permissions.

    Once you have the above network share working and writable, you can tighten permissions up in accordance with this doc -> NAS permissions.


  • I do not get it. I have formatted the system, reinstalled Raspbian and OMV and I followed the instructions, this time I have left only the M.2 disk, through USB port with ExtFat file system


    Is there one difference, the previous installation of omv but the results are similar


    This time my old user “PI” has not been deleted, so now I have two users

    • “Joaquin”, added to the user, sambashare, ssh, sudo groups
    • “Pi”, added to the groups adm, audio, cdrom, dialout, games, gpio, i2c, input, netdev, pi, plugdev, render, sambashare, spi, ssh, sudo, users, video
    • and the "PI" group

    Both users and the group have read write permissions in the "storage" menu "shared folder" option


    As for the instructions I have done everything except put guest access in the folder, because that meant that it did not ask for any password when logging in from Samba, it always logged in as a guest


    Result

    • None of the users, neither "joaquin" nor "Pi" with any of the "ssh" or "smb" protocols can create files and folders on the unit, only from ssh by becoming root can I create files and folders, In this case the permissions with which the new files are created are rwxr-xr-x root root
    • I can't mount the SSD card to run tests on it like the previous time


    I don't know the bug, this is hell. =O =O =O


    Thanks for the help :love:

  • ExtFat file system

    Ext4 or exFAT?


    If exFAT, you will never be able to smb share to users other than root.


    Windows FS don't accept permissions changed.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!