Netplan Exit Status 127

  • I've been running OMV for about 12 years now, upgraded back in 2021 something like that (unsure on version of OMV not current) and hasn't really been updated at all since.

    Today I had a power cut and my OMV server went down, upon boot I was getting errors all over and missing EFI among other things and failing to boot to OMV,

    I've ran fsck -f on my boot drive and seems to have repaired it and can now get to the OMV login screen

    Before this I could see a error about Netplan with a exit status 127, from this I have no way of reaching the server over the network, SSH times out as does FTP and SMB .

    I've ran fsck again but still the same.

    Trying to get netplan to generate a new config results in a symbol error

    lib/netplan/generate: symbol lookup error: /lib/x86_64-linux-gnu/ undefined symbol: g_reahloc 

    Any suggestions on recovering this

  • It looks like your root file system is mounted to read-only by the kernel.

    Ye that was from me umount the drive to fsck the drive, rebooted and tried again and the access denied message is gone, but still get the errors for unresolved host, trying to reinstall glib also results in the same and any other dependencies too, like the address no longer exists, but I know still works

    From what I can tell I'm on a depreciated version of debian now (buster?), do I need to update my source list? or is there another problem somewhere else

    Update: gave up, LIVE distro to recover data and moved to another OS, waiting on response here for "help" for the most obvious replies isn't something I want to wait for.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!