openmediavault-emby plugin (formerly mediabrowser)

  • I am having issues with 4.4.1. It starts to play but only plays like 2 minutes and then stops. It is like a cache issue with transcoding.


    People should not upgrade to the newer mono yet. Luke is recommending stay at mono 4.2.3.4


    4.4 working for me but with 4.4.1 I am getting issues others were saying about 4.4.



  • When I do this, I can not install the plugin, because it's not found .... just when I add the monorepo from omv webgui, I can install the plugin.


    apt-get purge mono* basically wants to remove everything from my system ! - I'm sure I dont wanna be doing that :)


    It must be apt-get-purge mono-*
    Had the same problem

  • For people that want to try the beta that is working, maybe not perfect, with mono 4.4.1:


    Edit this file-
    /usr/share/openmediavault/mkconf/emby


    Then change the LINK variable that is at the beginning of the file to this:


    LINK="https://github.com/MediaBrowser/Emby/releases/tag/3.1.53"


    Save it and then use the force update button. After installing that you will need to restart the server once.


  • Typo, it should be:


    /usr/share/openmediavault/mkconf/emby

  • Quote from Bambuleee: “When I do this, I can not install the plugin, because it's not found .... just when I add the monorepo from omv webgui, I can install the plugin.”


    Same here !


    See this post. Not mentioned however was that I had to enable Mono like usual then edit it out of omv-extras-org-stoneburner.list.

  • I am watching developments on 4.4.1 mono closely. I'm testing new versions too when they are out. I will let you know when things are working as they should with the new version of mono. If someone wants to put out clear instructions for the downgrading to the working version of mono that would be nice.

  • Thanks tekkb. :saint: Here's some clearer (noob friendly) instructions for anyone who might need them, since I literally just did it myself (and yes, I'm mostly a noob).


    Downgrading to Mono 4.2.3.4:
    (Thanks to tekkb, marc_al2 and Bambuleee)


    You can check what your current version of Mono is by entering the following command.


    Code
    dpkg -l | grep mono


    Prerequisites:
    Emby is currently installed.


    WARNING: You will lose all your Emby settings/preferences and metadata, so make sure to back them up.


    1. Remove Mono, Emby and it's dependencies by entering the following commands (one at a time in this order).
    (Note: Some of these commands may do nothing but do them anyway).


    Code
    apt-get purge mono-*
    apt-get purge libmono-*
    apt-get purge openmediavault-emby
    apt-get autoremove


    2. Disable the Mono Repo in System>OMV-Extras.org via the Web UI.


    3. Create a new Mono Repo for 4.2.3.4.


    Code
    cd /etc/apt/sources.list.d
    touch mono-xamarin.list


    4. Open the newly created file in Nano.


    Code
    nano mono-xamarin.list


    Then input the Repo location.


    Code
    deb http://download.mono-project.com/repo/debian wheezy/snapshots/4.2.3.4/. main


    (Ctrl+O to save, Ctrl+X to exit Nano text editor)


    5. Enable the Mono Repo in System>OMV-Extras.org via the Web UI.


    6. Access and open the following file with Nano.


    Code
    cd /etc/apt/sources.list.d
    nano omv-extras-org-stoneburner.list


    Comment out the location for the latest Mono Repo (add "#" at the beginning of the line, without quotes).


    Code
    # deb http://download.mono-project.com/repo/debian wheezy main


    7. Update your source list.


    Code
    apt-get update


    8. Install Emby like usual in System>Plugins in the WebUI.


    Note: To return to the latest mono, perform steps 1. and 2. then delete the file mono-xamarin.list. Then perform steps 5. through 8 EXCEPT skip step 6.

  • When you run this command are the mono packages saying 4.2.3.4???


    dpkg -l | grep mono


    Hi tkkb


    I just tried to rollback the mono release but when I do apt update I get the message:


    Code
    W: Konflikt bei Distribution: http://download.mono-project.com wheezy/snapshots/4.2.3.4 Release (wheezy/snapshots erwartet, aber wheezy bekommen)


    Is that ok this way?

  • It seems to be working remotely.... I get the version number. I can't test locally because I'm not at home.


    Version 3.0.5985


    Nope... One movie was playing fine but then tried another one and same thing.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!