Posts by dapyr0x

    move category and minfreespace to beginning on the options. I am pretty sure they have to be before "defaults". Otherwise, they are ignored. Or just remove default all together.

    I solved it! Thank you and gderf for all your help.


    I noticed that if I ran mount -a after booting that the mount would work, so the problem wasn't the entry in /etc/fstab as I had believed.


    The problem was the order of operations in systemd. By adding x-systemd.requires-mounts-for= for each of the drives to be merged together, the mount finally works! My working fstab entry is below


    Code
    /srv/dev-disk-by-*/media* /srv/mergedfs fuse.mergerfs category.create=mfs,minfreespace=10G,defaults,nonempty,allow_other,direct_io,use_ino,x-systemd.requires-mounts-for=/srv/dev-disk-by-uuid-7e3d4e5e-228e-47cd-ac2c-77e7f9c1f64e,x-systemd.requires-mounts-for=/srv/dev-disk-by-uuid-2d0face8-47a8-492a-a2fb-f50bcd2826c5,x-systemd.requires-mounts-for=/srv/dev-disk-by-uuid-02c39460-394e-4bec-aecd-33fade3843cf,x-systemd.requires-mounts-for=/srv/dev-disk-by-uuid-dc17cfe1-1df5-4a88-941a-7f90bfd1b071 0 0

    I think I figured out the problem. mount.fuse is not installed (which mount.fuse returns not found) and is a requirement for mounting from fstab. I'm running on the latest OMV ISO.


    Unfortunately, from what I read for Debian this is supposed to be included in the fuse package. The fuse package is definitely installed, and I've force reinstalled it as well but no dice.


    I was wrong, I do have mount.fuse, it's just in /sbin which isn't included in my user $PATH. Running sudo which mount.fuse returns /sbin/mount.fuse which should work, right?

    In your fstab statement you have several places where you have two or three blank spaces instead of one. I suggest fixing that and trying again.

    Thanks for the suggestion. Unfortunately, no dice.


    Code
    sudo mergerfs -o allow_other,use_ino,direct_io,category.create=mfs,minfreespace=10G,nonempty /srv/dev-disk-by-\*/media\* /srv/mergerfs1

    This works, I just need to run it every time the machine boots which is less than optimal. I can probably get it into a systemd service, I've just had bad luck trying to do that in the past. When it comes to these sorts of things, I only really know enough to be dangerous.


    The same thing in fstab gives me a folder that lists as "no such file or directory" with ???? for permissions, owner, and group when I ls /srv [using /srv/mergedfs instead of /srv/mergerfs1 intentionally so I can see the difference between the two methods]


    Code
    /srv/dev-disk-by-*/media* /srv/mergedfs fuse.mergerfs defaults,allow_other,direct_io,use_ino,category.create=mfs,minfreespace=10G,nonempty 0 0

    Thanks gderf. Maybe I shouldn't have upgraded to OMV 6, it requires a drive (like /dev/sdc) to create shared folders from.


    Your /etc/fstab globbing solution doesn't work for me, either. Not sure what I've done wrong, but if I boot with this enabled my entire filesystem gets mounted as read-only.


    Code
    /srv/dev-disk-by-*/media* /srv/mergedfs fuse.mergerfs defaults,allow_other,direct_io,use_ino,category.create=mfs,minfreespace=10G 0 0


    I have the same problem even if I explicitly call out the drives. Explicitly calling the drives works if I use the mergerfs command, but putting anything from mergerfs in my fstab appears to cause problems.

    This is awesome thank you for posting. I had mine manually keyed in with UUIDs which was a pain.


    How do you get a manually added mergerfs share to show up in the OMV 6 UI? Or do you handle that manually as well? I have a merged folder in /srv but I can't see it to create a shared folder on it within the UI.

    Hi, I have been trying to figure out this problem for a while now to no avail. I run OMV in a Hyper-V VM. It runs great most of the time, but occasionally something will go wrong where all hard disk read operations will hang indefinitely. Even going into the terminal and typing df -h hangs the console indefinitely, ctrl+c doesn't even clear it. I've just spotted what I think is going on in the logs, can anyone help me understand what happened here and what I can do to prevent it moving forward?


    Start:


    After this, the mergerfs error lines repeat every 2 minutes. I then have this before the system hung and required a reboot


    Code
    Apr 15 05:41:22 omv kernel: [160018.813049] sd 0:0:0:5: [sdd] tag#728 FAILED Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK
    Apr 15 05:41:22 omv kernel: [160018.813052] sd 0:0:0:5: [sdd] tag#728 CDB: Read(16) 88 00 00 00 00 03 2f 54 4b e0 00 00 00 08 00 00
    Apr 15 05:43:21 omv kernel: [160137.937115] sd 0:0:0:5: [sdd] tag#832 FAILED Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK
    Apr 15 05:43:21 omv kernel: [160137.937115] sd 0:0:0:5: [sdd] tag#832 CDB: Read(16) 88 00 00 00 00 01 24 81 5f 18 00 00 00 08 00 00
    Apr 15 06:05:58 omv kernel: [161495.382572] sd 0:0:0:5: [sdd] tag#1522 FAILED Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK
    Apr 15 06:05:58 omv kernel: [161495.382572] sd 0:0:0:5: [sdd] tag#1522 CDB: Write(16) 8a 00 00 00 00 00 00 00 08 00 00 00 00 08 00 00
    Apr 15 06:26:08 omv kernel: [162704.751608] sd 0:0:0:5: [sdd] tag#2071 FAILED Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK
    Apr 15 06:26:08 omv kernel: [162704.751608] sd 0:0:0:5: [sdd] tag#2071 CDB: Read(16) 88 00 00 00 00 01 24 81 5f 18 00 00 00 08 00 00
    Apr 15 06:46:46 omv kernel: [163942.595368] sd 0:0:0:5: [sdd] tag#2071 FAILED Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK
    Apr 15 06:46:46 omv kernel: [163942.595368] sd 0:0:0:5: [sdd] tag#2071 CDB: Write(16) 8a 00 00 00 00 00 00 00 08 00 00 00 00 08 00 00

    Hi there,
    I'm very new to OMV, and only slightly less new to linux overall, and I'm trying to get things going.


    I've managed to get 3 rsync jobs set up where they work when they are run manually, but the automation functions through cron don't seem to do anything at all


    Bash
    SHELL=/bin/sh
    PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
    # m h dom mon dow user command
    */3 * * * * root /var/lib/openmediavault/cron.d/rsync-80ff6ed8-d3bc-4a7d-8c39-673a6973fbf9 >/dev/null 2>&1
    */30 * * * * root /var/lib/openmediavault/cron.d/rsync-b39f0bd4-fee1-4359-8584-867271854d82 >/dev/null 2>&1
    */15 * * * * root /var/lib/openmediavault/cron.d/rsync-c66de143-ae1d-4acb-b9f6-b958c9046e0a >/dev/null 2>&1

    This is how /etc/cron.d/openmediavault-rsync looks which seems to make sense. I just don't see it ever being called. What am I missing?