Posts by JryL

    Solved it! If any one is interested, here's the solution that worked for me.


    SSH in as root and type this:

    Code
    cat /sys/module/kernel/parameters/consoleblank

    That will tell you the current setting. In my case it was 0, for off.

    Next, edit GRUG commandline:


    Code
    sudo nano /etc/default/grub

    Look for: GRUB_CMDLINE_DEFAULT


    In my case, this was in my file:


    Code
    before:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet"
    after:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet consoleblank=60"

    I add 60 (for seconds), you can add your desire setting here (in seconds though).

    Then close the file and save it, and run:


    Code
    sudo update-grub


    Now, reboot and wait (60 secs, in my case), and the screen will go blank if idle. Hit any key to activate the screen and use as normal... (again, if idle, screen will go blank).


    Good luck!

    Hello folks! I have a old unused Surface Pro 4 and Surface Pro 4 Dock that I'm testing OMV5 on. The system is working well and has been on for several days. The only problem I have is that the screen is on all the time (at the login screen). Having the attached Surface keyboard up (closed) will cause the device to enter suspend mode. I was able to fix this by editing the logind.conf (/etc/systemd/logind.conf) and adding these lines:


    HandleLidSwitch=ignore

    HandleLidSwitchDocked=ignore

    HandleLidSwitchExternalPower=ignore


    Now the system stays on with the keyboard closed (up) but the screen remains on all the time. Is there a way to blank or turn off the screen on idle, let say after 10 mins or so? I know the device is able to do this under Windows but I don't know how to with Debian (OMV5). Thanks!

    Thank you for the comments that you are annoyed. They are very helpful.


    apt-get purge dhcpcd5 will fix the issue. The install script has been updated.

    Thank you for the fix. And sorry for the "annoyed" comment as well. I tried explaining the issue. Good day! :)

    Some people read the Wall Street Journal over their breakfast coffee. I read the forum. It’s mildly hugely entertaining. :D
    I have to pay for the WSJ. This is free.

    Glad to provide some entertainment. :)


    Will try installing OVM5 again... soon. Thanks again!

    I have two usb3 drives I'm using with my setup and have them configured to spin down after 60mins of inactivity but only one of them ever spins down. The one that doesn't spin down is where I keep my portainer/docker "apps" settings and related data stored and at least one app is always running. Can this prevent that drive from spinning down, even when that app isn't being used? I had both of these drives in a different setup, and both did spin down or could I have setup something incorrectly?


    Thanks for any suggestions. I

    I thought maybe rather than modifying the existing network from DHCP to static, you are adding a new static network from scratch. I never set up a static ip from the router. In the networks tab, from the initial existing network, I set up a static ip outside of the router’s DHCP assignment range.

    Yes, that's what I did.. static ip set outside of DHCP assignment. I'd prefer assigning static ip on the device rather than dhcp server when possible.

    "Feature"?, not really. It's not like the RPi4 has dual NICs and if it did, I'd hope it would be used for load balancing, but that's me. It's a NAS, you want it to always be found on the same Ip and not set to DHCP. Hopefully OMV5 final will stick with the single Ip? I'm really impress with the RPi4 and OMV4, the R/W isn't bad for what it is and can rival what other company try to pass off as a NAS. It's no Qnap or Synology but for the price, it can't be beat. Since my Qnap is back up, I'll stick with my original plan and use OVM4 as a temp NAS on the RPi4 for now or until OMV5 is stable ... or another RPi4 project pops up. Thanks!

    Hey crashtest.


    "Did you start off with a static address or did you use DHCP for the first boot?"


    DHCP for first boot.


    "This is idle speculation, but your DHCP server may be reserving an IP
    address that it has associated with the R-PI4's mac address.



    I'd try:



    1. shutting down the R-PI

    2. Rebooting your router (with hard power off and power on)

    3. Start up the R-PI"


    That's what I thought was happening but even after releasing the DHCP reservation for the Pi4 and rebooting both Pi and Router, the Pi4 would get assign a new IP address even when OMV5 has a static IP already. So I'm at a lost, hence the post.


    Any ways, since I have a 2nd Pi4 on hand for another project, I installed a 2nd OMV5 installation... same result. The new Pi4 gets two IPs as well; one static and one from DHCP server. I've even went as far as installing OVM4 with the old image (OMV_4_Raspberry_Pi_2_3_3Plus_4.img.xz) on one of the Pi4. Once I gave it a static IP in OMV4, it retains and only uses the static IP. So, what ever... The only way that I was able to force this install of OMV5 to use one IP was to set a static IP in OMV5 and configure it in Raspbian Buster Lite with the same IP (dhcpcd.conf) and reboot. Since then, only one IP... the static I've given it. So whatever.



    System Information/Performance statistics on OMV4 for the Pi4 wasn't really working properly on OMV4 but at least it gave some data where as on OMV5, nothing... just the sad face.




    If no other solution, then I'll just stay on OMV4 since I'm only using it as temp storage and considered the current stable OS.



    Thanks.

    Anyone have any suggestion to fix this? I've also noticed that under: System Information/Performance statistics .. CPU usage .. Disk usage .. Load average .. Memory usage .. Network interfaces .. Uptime ... are not working. Only a sad face for stats. Also CPU usage is quite low (0.1% - 1%) on OMV5 than OMV4... and so is memory usage (0.1% of 3.81 GiB). On OMV4, on average: CPU is usually around 5 - 10% (depending on activity) and memory usage is usually at 6-8% of 3.81 GiB.


    Any help would be appreciated. Thanks.

    Hello all. First time user, here.


    I've been using a Raspberry Pi 4 with OMV4 since Oct. of this year as a temporary nas until I can upgrade my Qnap. Originally I used the image that was found in the download section of this site (OMV_4_Raspberry_Pi_2_3_3Plus_4.img.xz) and things worked perfectly for the most part, no major issues. Anyways, after finally upgrading my Qnap, I've decided to keep running Openmediavault on my Raspberry Pi 4 and wanted to try out OMV 5, which I used the instructions found on: RPi and other SBC/armbian images .

    I successfully installed a fresh copy of Raspbian Buster Lite and than OMV5 (wget -O - https://github.com/OpenMediaVa…Script/raw/master/install | sudo bash). I've configured a static IP for the RPi4 but now notice that I it keeps getting assign two IP address. One, the static IP I've assigned OMV5 through the Network/Interface and the other through my DHCP server. Why is this happening? I've tried assigning a static IP for the raspberry pi 4 only and left the network interface in OMV5 unassigned but have problems installing docker. When I tried to assign the same static IP (as the RPi4) through OMV5, I keep getting an error when trying to apply the settings; plus rebooting the RPi4 takes a bit longer since it keeps getting stuck at:

    .

    .
    [OK] Started Wait for Network to be Configured.

    Starting Hostname Service...

    Started Hostname Service.

    [ * ] A start job is running for dhcpcd on all interfaces (10s / 1min 35s)
    .
    .
    And when the RPi4 does finally boot and reaches the standard login prompt, I get this:


    To manage the system visit the openmediavault web control panel:


    eth0: 192.168.1.33
    eth0: 192.168.1.155


    The x.x.x.33 is the static IP I've assigned OMV5, the other is through my DHCP server.


    Any way to fix this? I'm sure I'm doing something wrong here. Thanks!