Posts by wildernessfamily


    I can't believe the amount of time I have put into this. Maybe this is why I became a developer. Sometimes I think I should have been a detective. When there is a mystery I can't let it go. I have to find the answer. The countless hours that I have put into this. I don't even want to think about the number of times I have flash OMV, the number of SD cards I have tried, resetting my router multiple times, changing DNS servers, trying just IPV4 or IPV6. But, I finally remembered how I did it the very first time. And that was the answer to solving this problem.

    To recap. No matter what I did I couldn't get OpenMediaVault to install and work with WiFi. Or it would give me errors installing. But that's all the farther I went. I would stop there and re-install...And the process would repeat.

    Yesterday was different. I've been working with Django and loving it. So much better than WordPress (legal disclaimer: in my opinion 😁). I wanted to set up OMV and use Docker/Portainer with OMV. OMV makes it super easy to use Docker. I got some 3M command hooks and was just going to stick the Rasp next to the router and use Cat5. I had trouble installing OMV. Even with CAT-5. I would receive the error while installing that some packages could not be installed. It would stop and prompt me to try running apt update --fix-missing. Sometimes that worked. Sometimes I would have to try multiple times. Reboot the Rasp. Try again. Frustrating to say the least 🤯🤬

    I would finally get Docker and Portainer installed. But, I was downloading images on Portainer and I would receive DNS errors. Which was the light bulb in my head that went off💡. I remembered that I had received DNS errors before. I did a search and I immediately found the article that I had the first time I installed OMV.

    The default mirror: buster main contrib non-free rpi

    was causing all the problems. I have no idea why and at this point I really don't care.

    I switched to a new mirror repository.

    And, everything works perfectly. WiFi works, Docker works, Portainer is able to download images.

    If anyone else seems to have this problem these are the steps I did to make my OMV setup work with Rasp.

    Now, depending on when your reading this you may not be on Buster (Raspberry OS version) which just happens to be the name of my dog. The yellow in my avatar. Just thought I throw that out there. You may have to change to the current version.

    Here is the list of Rasp mirrors:

    Good luck!

    SteveG I completely understand your frustration. I'm even an advanced Python developer and tried and tried to get it to work. I even went into and worked on the code. I can't explain it. Obviously, if you have read the other posts from other individuals they have absolutely no problem. What we are doing differently I have absolutely no idea. I followed the instructions to the "T"...multiple times. I even had a professor do it with me and we both can't get it to work. I'm at a loss.

    So, I wish I personally had better news for you on my side. I just ended up not using WiFI. I'm using my MediaVault with Plex and Roku. And ethernet actually is much better. The connection is more stable. That said, I gave up and just went with Ethernet. :/

    Hi, crashtest

    I figured it has to be me. I can't be the only person building Rasp with OMV on it at this present moment. It's to popular.

    Flashing and building OMV is snap of the fingers to me. I have a 4K TV that i use as my monitor. I have my Mac plugged into one of the HDMI ports and then when I build Raps it connected to the other HDMI port. I just switch between input's while the script does it's thing.

    I don't the other router, I gave it away. But, I'll turn on my phone's hotspot. And completely do it through my hotspot.

    Thank you for showing a screen shot of your OMV WIFI. My initial OMV that is working may not be setup correctly. In the WIFI settings are (see screen shot) it does not display any wifi settings. Or when connected to ethernet it does not show that either. hmmm.

    Thanks for responding crashtest

    That's actually the guide I've been going off of :) But it's a little conflicting from what ryecoaaron has said. To flash rasp. Do not apt update / upgrade first. Install OpenMediaVault first than do the update/upgrade.

    The only thing I strayed from on regards to the guide was using this version of Raspberry Lite that it states.

    1. Buster Lite was:9e5cf24ce483bb96e7736ea75ca422e3560e7b455eee63dd28f66fa1825db70e

    I couldn't find it. I looked through all the repositories and I wasn't able to find it.

    I'm using the official MacOS Imager from the Raspberry Pi website

    To create my images. When I choose "Other" from the imager --> Raspberry Lite 32bit version is the version I'm using.

    I don't see what I'm doing different than anyone else. Plus, like I said in my first post. I have the very same setup using a Rasp 4 8gb with OpenMediaVault working like a charm. I have docker setup, with Plex. And, it's doing fantastic. I used the same script. Same procedures. In fact, I used your guide and did the apt update / upgrade first prior to installing OpenMediaVault with no problems. After setting this up and about 4 to 8 weeks later I decided that this was perfect to use for my so called backup server.

    That's when I ordered a Raspberry Pi 3B (for a weather station I'm building), 4GB 2GB (for my backup server), 4gb 8GB (to develop some python scripts for a few Rasp projects), and another Rasp 4 8gb for the backup server.

    🤔The only variables that I can see that are different than the first setup of OpenMediaVault is:

    1. I have a new router. I have a high end Asus router that I flash OpenWRT with a private ALGO VPN / WireGuard setup on it. (But, it's running my other OpenMediaVault, I have NUMEROUS LoT devices attached to it running the house, and all my other computer equipment (MacBook Pro, iPad, Phones, etc.) with no problem.

    2. I purchased these three new Raspberry Pi from (an official vendor of Raspberry Pi). The first Rasp that has OpenMediaVault running with Plex from VilROS (another official vendor of Raspberry Pi) on Amazon. They come from Raspberry Pi, they were in the official box. I don't see how that could be it either.

    At this point I throwing in the towel. I don't know what else I can do. Last night I flash Raspberry Pi Light. Using the command line I encrypted the drives with Luks. I have it all installed outside. And RSync is running as we speaking backup everything with no problems. It would have been nice to have OpenMediaVault on it for the U.I. but...being just a backup server and only needing Rsync, Luks, and S.M.A.R.T I probably should have just done it this way from the beginning.

    All that said...I want to thank ryecoaaron and crashtest for your input and your time. I do appreciate it!

    Hi ryecoaaron ,

    First, let me just say, I do appreciate the time you take to respond. It's greatly appreciated.

    Before, I responded I wanted to verify because I had tried this several weeks ago. I did want to try again just to verify using just ethernet.

    Side note: I prefer to install over ethernet. In fact, if possible I would like to keep it on Ethernet and not deal with WiFi. But, this is the back-up sever in case of a wildfire and I don't have the means to run a cable to where it will be located.

    I erased three SD cards. Flash Raspberry OS Lite on them. (Rasp 3B+, Rasp4,2gb, Rasp4, 8gb)
    I have the HDMI-Mini, USB Keyboard, and Cat5 plugged in.

    Turned all three Rasps on and booted up.
    I did edit the keyboard file so I could use my keyboard on all three rasps
    sudo nano /etc/default/keyboard
    and change gb to us

    On two of the Rasps (3B+ 4,8GB)

    I typed in the install script:
    wget -O -…Script/raw/master/install | sudo bash

    On the Rasp 4,2gb I did
    sudo rfkill unblock all

    and then the install script.

    I read in another post that your script does the rfkill unblock. I read that after I already done it. But. either way I have the other two rasps running as normal.

    All three installed with no problems.

    I logged into terminal and did a ifconfig

    eth0 is showing with an ip address assigned but not wlan0 (which is correct)

    I logged into the web UI. Network-->Interfaces-->Add Wifi The wifi interface was available in the drop down.

    I added the network and password. For both IP4 and IP6 set to DHCP.

    Applied the changes

    No ip address

    I logged into terminal, performed ifconfig

    eth0 is still there and wlan0 is now showing with the mac address but no IP.

    I rebooted.

    Again, wlan0 is showing but no ip address

    The only thing I can think of is that when I setup a Raspberry Pi for other projects and turn on wifi I have to perform the rfkill unblock which your script does.

    But...if I don't assign a country for the wifi


    wlan0 does show up with the mac address when I perform a ifconfig but will not allow it to hit the dhcp server until I assign the country in the wpa_supplicant.conf file.

    Does the script set a country for the wifi adapter?

    That is the only thing I can think of.

    I'll keep trying if you have suggestions for me to try. But, I can't think of anything else at point.

    Again, I appreciate any feedback and your time.


    I have no idea what is going on. I have been working on this problem every day for a week.

    These are the steps I have done.

    Background: I tried on a Pi3B+, Pi4,2gb, and Pi4,8gb

    I'm on a Mac. I downloaded the Raspberry Pi Imager that I have used for....over year...+

    I placed my MicroSD card into the slot. Choose Erase, then choose Raspberry Pi OS (Other)-->Raspberry Pi OS Lite (32bit). I flash the sd card and all goes well.

    I place it in the Raspberry Pi and boot it up. I have no USB drives connected. Only my monitor, and USB keyboard and no cat5.

    I first edit the keyboard file so I can use my keyboard.
    sudo nano /etc/default/keyboard

    I change

    XKBLAYOUT from gb to us

    I then edit the wpa_supplicant.conf file adding under the last line update_config=1

    network {

    Note: Yes, I created a SSID on my router called OMV-Test so I could watch it and keep it away from any other traffic.

    I then run

    wpa_cli -i wlan0 reconfigure

    I receive an "OK" back

    At this point per the Raspberry Pi instruction WiFi should be working. What they don't tell you is since a recent update you have to unblock/turn on your WiFi radio by running this command then rebooting.

    sudo rfkill unblock all
    sudo reboot

    Once the machine reboots and I perform an

    ifconfig wlan0

    I have an ip address and I confirm this with my router.

    Note: I DO NOT run apt update | apt upgrade at all. At anytime.

    I then run the command:


    OpenMediaVault installer runs and installs. The system reboots per the install script.

    When it reboots and I login and run ifconfig wlan0 there is no ipaddress. I confirm with the router.

    I then do a sudo cat /etc/wpa_supplicant/wpa_supplicant.conf and my text that I added is still there.

    I try running wpa_cli -i wlan0 reconfigure again. I receive an OK.

    No ip address

    I try sudo rfkill unblock all


    No ip address

    I plug the cat5 cable in and receive an ipaddress.

    I log-in to OpenMediaVault, proceed to Network-->interfaces. My information is in there that I had initially added to wpa_supplicant.conf

    I change network in OpenMediaVault to OMV-Test-2 --> Password --> Save

    It then asks if I want to apply the changes. I say yes.

    I'm connected to my network. I unplug the cat5

    I go back and do the procedure again in OpenMediaVault back to the original network SSID: OMV-Test, apply the changes and I'm connected.

    I reboot the machine and no connection

    I log-in do a ifconfig wlan0 and confirm no ipaddress

    It looses something when I reboot.

    At the command line I edit:

    sudo nano /etc/network/interfaces

    I add the line:

    iface wlan0 inet dhcp

    save and exit

    sudo ifup wlan0

    After running that I have an ip address. I'm connected to the router.

    I reboot the machine. Again, all is loss.

    I go back to /etc/network/interfaces and my text that I had added is gone.

    There is no iface wlan0 inet dhcp in the interface file.

    Like I said, I have tried this several times, on several Pis, several SD cards, several flashes. I've tried being connected entirely with cat5 and not even editing the wpa_supplicant.conf file at all.

    I have no idea what I'm doing wrong or what the problem is.

    ryecoaaron is there anything you can recommend? I don't know what else to try.

    Thank you for any assistance!


    Ahh, gotcha ya! Totally understandable.

    I'm just going to do.

    1. Flash SD

    2. Update the wpa_supplicant.conf with nano

    3. run OMV script.

    I'm sure it's something that I'm doing not your script. Most likely what you said. I'm proceeding with the wrong order of things.

    Thanks for an awesome script.

    And, thanks for WiFi! I live up in the mountain of Colorado and don't have internet. Just the mobile hotspot...waiting anxiously for StarLink to come online. I can't backup my files to the cloud because all I have is the hotspot. I purchased a weatherproof box and installing it in an unattached ground cellar. Just in case god forbid a fire or wildfire happens.

    I try to support OpenSource projects. I'l be doing that with OMV. It's great and extremely beneficial for my situation up here in the mountains. Again, great job and thank you!


    Thanks for responding.

    I tried that. I flashed the sd card. Did the normal sudo update, upgrade, reboot, and then install OMV with the script.

    Then I did the raspi-config the first time. And when I reboot it looses the config and wlan0 dosn't obtain ip. I cat the wpa_supplicant file and it's empty other than the basic first line that ships with the Rasp. Then (which I prefer anyway) I edited wpa_supplicant.conf with nano per that guide. On my other OMV server I actually use this guide Rasp WIFI guide and encrypt the PSK key with wpa_passphrase but I haven't even attempted that on this OMV server until I can fix this WiFi problem I'm facing.

    I just ran sudo omv-firstaid and it said it configured the wifi. I'm not setting my hopes to hi but before I flash the sd card again I figure why not try.

    If it dosn't work than I'm going to try:
    1. Flash SD
    2. apt update upgrade
    3. reboot
    5. OMV install script
    6. omv-firstaid
    and 🤞🤞🤞that will solve the wifi problem. What is so baffling is that I have the other OMV on Rasp working with no problem and I havn't done anything different. It's driving me nuts trying to figure out what I'm doing wrong.
    I'll post my results on what happens.


    Macom, first thanks for taking the time to help.

    I actually have tried that twice. I skipped the step 2. Installed OMV.

    1. Logged into OMV. Network --> Interfaces

    eth0 is added but no wifi (of course since I havn't set it up yet)

    I click add --> wifi.

    I add wlan0. Set the SSID and password. I setup IP4 and IP6 to DHCP. And Save

    No wifi connection. I reboot.

    Still no wifi connection.

    I run sudo raspi-config setup wifi in raspi-config

    And then run ifconfig and confirm I have a IP address. All is good.

    But, when I reboot, I loose wifi and have to repeat the raspi-config procedure again.


    I'm confused. Am I missing a step on updating Raspian OS?

    1. Flashed Raspberry Lite on to the 32gb micro sd card

    2. sudo raspi-config (Turned on SSH, configured WiFI, and change hostname to omv-bckup

    (Unplugged the cat-5 cable and SSH in from my desktop Mac)

    3. sudo apt-get update | sudo apt-get upgrade

    4. reboot

    5. sudo wget -O - https://raw.githubusercontent.…tallScript/master/install | sudo bash

    If I don't do raspi-config on step 2 it dosn't save my WiFi settings after step 5. I have to re-install.

    * My asterisk clause quote. --> I'm well versed in computers (I've been teaching computer/programming for decades)

    There are very few problems that I can't figure out when it comes to computers. Usually, it's something extremely simple, which I'm making it more complicated than it is. I've taught myself to walk away, take a shower, walk the pups, get a good night sleep, and then I can usually figure it out. Most the time it's something extremely simple.

    I have been racking my brain 🤯🤯 for two weeks on this. I can't figure it out, so I need some help from the community to help me solve this problem.

    I have a Raspberry Pi 4 8gb of memory as my Plex media server (using docker), and NAS for family file server. It's on WiFi, sits over in the corner of the house and works flawlessly. No problems at all. Love the little thing.

    I have another Raspberry Pi 4, 2gb of memory. My procedure that I have done:

    1. Flashed Raspberry Lite on to the 32gb micro sd card (I've tried two different SD cards)

    2. sudo raspi-config (Turned on SSH, configured WiFI, and change hostname to omv-bckup

    (Unplugged the cat-5 cable and SSH in from my desktop Mac)

    3. sudo apt-get update | sudo apt-get upgrade
    4. reboot

    5. sudo wget -O - https://raw.githubusercontent.…tallScript/master/install | sudo bash

    6. After install rebooted the machine

    (Things I have tried, skip the sudo raspi-config on setting up the WiFi in the beginning. Install OMV then add the WiFi device in OMV. But that doesn't work. And going back into raspi-config works but when I reboot it resets the WiFi config. In /etc/wpa_supplicant/wpa_supplicant.conf is empty except that first starter line. So I have to re-install OMV.)

    7. I setup the NTP to Mountain time, upgrade the plugins (only one needs upgraded), install the Luks Encryption plugin as my hard drive is encrypted using Luks plugin.

    After about two hours I can't access OMV by WiFi. I'm using an old 5TB seagate (When I say old it's three years old lol technology world I guess it's old)USB3.0 hard drive. So, I tried a new hard drive. (Just FYI. the hard drive has it's own power cable, the Rasp is not powering the hard drive).

    The only way I can access the OMV is either: Plugin the cat-5 cable in again (I have access again) or reboot the Rasp.

    Since I already have one OMV up and running on the Rasp using WiFi with (with basically the same procedures that I did on this one) no problems I figured maybe I just have a bad Rasp.

    I repeated all these procedures with a new microSD card on a new Rasp 4 with 8GB this time. Just like my main OMV server. Save thing is happening. WiFi stops working after about 2 hours.

    I check the logs and I can't find anything out of the ordinary. I'm pulling my hair out at this point 😖😣😣. I'm so frustrated...and as I teach my kids in life and especially in programming...KISS. Keep it simple stupid. I'm sure it's something simple that I'm missing.

    Any help would be greatly appreciated!

    Thank you,


    Thank you! :) I'll post some pictures as soon as I have it finished. Just waiting for the weather proof container from Amazon to arrive next Tuesday. I added a BME280 sensor to the Rasp Pi to monitor temperature and humidity inside the box. Plus, even when StarLink comes online I'll still be saving about 40.00 a month in cloud storage. And, again when StarLink comes online I can just add NextCloud through Docker if I need access for my files when away from home.


    A little background. I live pretty much on top of a mountain. There is no internet service here (can't wait for StarLink). I use my phone as a hot spot but the speeds are about the same as dial-up (if that on some days). So my option of backing up all my files to the cloud is a pipe dream. My solution that I turned to is OpenMediaVault. I have an OpenMediaVault server in my house with an 8Tb drive attached to it. In the shed cellar I have another OpenMediaVault server on Raspberry Pi 4 with 2Gb of memory with another 8Tb drive attached. I have it in the shed (God forbid) in case of a forest fire. The shed server is using a 25 watt solar panel and battery as there is no power in the shed.

    I have a RSync job setup on my home OpenMediaVault server to run at 2am to back up all files to the shed server.

    Instead of having the shed server on all day long (especially in winter with little sun hours) I thought Wake-On-Lan would be my solution. I'm new to Wake-On-Lan and have read many articles about it in the past two days. It sounds great for what I'm looking to do.

    On the shed server I enabled Wake-On-Lan in the network portion of OpenMediaServer. I use OpenWRT and created a static IP for both OpenMediaServers and updated the network settings on both servers with the static IP's.

    My question:

    I read the man pages on RSync and don't see an option to be able to send Wake-On-Lan command when starting the RSync job; including an option to run a script that perform the Wake-On-Lan.

    Again, I'm new to this. Can anyone provide me with some advice or point me in the right direction on how I can send the Wake-On-Command packets when starting the RSync job at 2am to the shed server?

    Thank you in advance for your time on helping me.