Posts by gderf

    Add following to override.conf in /etc/systemd/system/plexmediaserver.service.d:

    [Service]

    Environment="TMPDIR=/srv/dev-disk-by-label-data1/plex_media_server_tmpdir"

    Unfortunately this can't be done AFAIK when running Plex in a docker unless that variable is supported via an entry in the Environment table of the container. I have no knowledge if the docker supports it or not. If it does it isn't documented.

    Sorry, I am out of ideas.


    Edit:


    It may be possible that the Plex configuration library became corrupted. You might try deleting it and allowing Plex to rebuild it from scratch. Also, if you brought up a new container, make sure you either delete the old one or be certain it isn't runing.

    That doesn't look good with it starting so many times. What restart policy did you set? Don't use Always for now. Use Unless Stopped.

    They will be there where they were. Deleting a container isn't going remove them. Just don't do a purge if the option for that comes up.

    Depending on how many media files you have applying ownership and permission fixes can take a while.


    Here is what a trouble free startup with an upgrade looks like.


    That's not all of it. There either is more or will be more when the update completes and the service starts.


    Edit:


    And that is the latest version it has downloaded.

    Connection refused means the service is not running. Check the docker log and then restart the container, then look at the log again. If it's crashing the log should offer clues. If the log indicates a normal startup you should be able to connect to it.

    I don't have any suggestions about your Plex account problems, but until that is solved I don't know to what reduced degree, if any, you can use the Plex Media server.


    You might try using the Plex Media Player application on a PC to try and get it logged into your Plex account. I would concentrate on this first. If you can do that I don't see why the server can't be connected.