Posts by donh

    I have posted a script here.

    Active Directory / LDAP Revisited


    It is probably that uids are out of range. Windows uses high numbers like 1334455. You can edit a file to allow them. Should be explained in the thread above. /etc/login.defs


    This link is broken.

    blog.cadena-it.com/linux-ceh/i…crosoft-active-directory/

    ...?

    No No No No No. Have you seen such a button in a professional software? Not me. OMV already is testing the configuration during the deployment phase.

    Seems there was no error when saving the config. Maybe there was but it was not obvious or mentioned by the op. I don't see what would have told him to try testparm. Maybe testparm could be run on save. Then display the errors? But that might confuse people too. There may be minor warnings that don't actually break things?


    Thanks

    Glad you got it going. No idea why the permissions were wrong, maybe votdev can look into it. Testparm would make a nice test button on the samba settings page I think.


    You fixed it the way I would have suggested if I had got back quicker. LOL

    Maybe if you provide more info about your hardware like x86, rpi or whatever. Also what iso or image you used. Anything else that may be relevant. Better questions get better answers.


    Also you could up the log level on the smb/cifs settings page.

    Since you are getting winbind error I assume you are trying to do some form of ldap or active directory. If so please give some info on that. In the past I have had to modify /etc/nsswitch.conf to get name resolution to work.It is mentioned in the man page excerpt above.

    From the man page.

    name resolve order (G)

    This option is used by the programs in the Samba suite to determine what naming services to use and in what order to resolve host names to IP addresses. Its main purpose to is to control how netbios name resolution is performed. The option takes a space separated string of name resolution options.

    The options are: "lmhosts", "host", "wins" and "bcast". They cause names to be resolved as follows:

    •lmhosts : Lookup an IP address in the Samba lmhosts file. If the line in lmhosts has no name type attached to the NetBIOS name (see the manpage for lmhosts for details) then any name type matches for lookup.

    •host : Do a standard host name to IP address resolution, using the system /etc/hosts, NIS, or DNS lookups. This method of name resolution is operating system depended for instance on IRIX or Solaris this may be controlled by the /etc/nsswitch.conf file. Note that this method is used only if the NetBIOS name type being queried is the 0x20 (server) name type or 0x1c (domain controllers). The latter case is only useful for active directory domains and results in a DNS query for the SRV RR entry matching _ldap._tcp.domain.

    ...


    So it should work with /etc/hosts file. If it is not it is an upstream bug. Not an OMV bug. FYI

    Run omv as a vm on your proxmox server. Not sure about "HA" but I have been running OMV on proxmox for years with no problems.

    Do the zfs in proxmox and assign virtual disks to omv as needed. Pi-hole works well as a vm and even as a container. A samba ad will work to I am sure. Search for active directory and choose a version that is shown to work with omv. Before setting it up and beating your head against the wall. I am using windows 2012 server but will dump that when it goes end of life.


    Had freenas a long time ago. Dumped it as I am more familiar with debian/linux than freebsd. Your milage may very.


    I ifirc Votedev (the developer here) was part of freenas years ago.