Probleme mit Zertifikaten

    • Resolved
    • OMV 2.x
    • Probleme mit Zertifikaten

      Hallo,

      ich habe im OMV zwei Zertifikate erstellt, eines mit der IP-Adresse des OMV und eines mit seiner DDNS-Adresse. Trotzdem kommen beim Aufruf von hxxps://DDNS-Adresse:443 immer wieder Zertifikatfehler, trotz der Auswahl: "SSL erzwingen". Auch beim Aufruf von owncloud dasselbe Phänomen.

      Was kann man tun, um diese Fehlermeldungen zu beseitigen, außer vielleicht sie zu ignorieren?

      Viele Grüße.
    • @omavoss das ist doch normal. Wenn du ein Zertifikat möchtest wo diese Meldung nicht kommt musst du Geld bezahlen damit eine "dritte Person" die bestätigt das du keine "bösen" Absichten hast und jemand reelles dahinter steht.
      omv 4.0.19 | 64 bit | omvextrasorg 4.1.2 | kernel 4.14
      used plugins: nginx | mysql | docker-gui |rsnapshot | antivirus | apt tool | letsEncrypt |
      used other: netxtcloud | logitechmediaserver | emby
    • Es isst ein selbst erstelltes Zertifikat. Ich habe einen Account bei ca-cert, dort könnte ich meine Zertifikate beglaubigen lassen. Doch dazu müsste ich sie erstmal aus OMV heraus exportieren bzw. ein von cacert erstelltes Zertifikat in OMV importieren; und damit gehen die Probleme schon los.

      und ja, die Client-Uhrzeit stimmt.
      Viele Grüße.

      The post was edited 1 time, last by omavoss ().

    • In den verschiedenen Browsern sieht die "Ablehnung" des Zertifikats lediglich unterschiedlich aus, es kommt aber alles auf dasselbe raus: den Fehler ignorieren und trotzdem die Seite aufrufen. Das ist aber sehr unerfreulich, denn wenn man z.B. mit owncloud einen Link teilt, kriegt derjenige, dem man diesen Link geschickt hat, ebenfalls diesen Zertifikatfehler zu sehen. Manche sind da sehr ängstlich und erschrocken ... rufen dann übervorsichtig bei mir an und fragen nach, was denn da eigentlich los ist. Das ist eben nervig, und deshalb wollte ich diesen "Fehler" eigentlich beseitigen, obwohl es mit IGNORIEREN eigentlich getan ist.


      Ich werde mich nun von einem weiteren cacert-Benutzer aus der Umgebung "assuren" lassen, dann sehen wir mal weiter.

      Danke und viele Grüße.
    • Probleme mit Zertifikaten

      omavoss wrote:

      In den verschiedenen Browsern sieht die "Ablehnung" des Zertifikats lediglich unterschiedlich aus, es kommt aber alles auf dasselbe raus: den Fehler ignorieren und trotzdem die Seite aufrufen. Das ist aber sehr unerfreulich, denn wenn man z.B. mit owncloud einen Link teilt, kriegt derjenige, dem man diesen Link geschickt hat, ebenfalls diesen Zertifikatfehler zu sehen. Manche sind da sehr ängstlich und erschrocken ... rufen dann übervorsichtig bei mir an und fragen nach, was denn da eigentlich los ist.

      Du könntest ihnen auch das Zertifikat vorher schicken damit sie es aufnehmen können ;)
      ... Ich weis, ist auch lästig
      omv 4.0.19 | 64 bit | omvextrasorg 4.1.2 | kernel 4.14
      used plugins: nginx | mysql | docker-gui |rsnapshot | antivirus | apt tool | letsEncrypt |
      used other: netxtcloud | logitechmediaserver | emby
    • Gut, das Zertifikat schicken wäre eine Lösung. Nur: wie kriege ich das aus OMV exportiert in eine *.cer-Datei?

      Mein Bild oben ist vom MS-IE, Firefox benutze ich nicht, und bei Opera sieht es so aus wie hier zu sehen:
      Wenn man "Approve" klickt, ist das dasselbe wie "Ignorieren" ... und bei Waterfox steht dafür: "I Understand the Risks" ... und Safari zeigt auch etwas gleichartiges ...
      Images
      • 2016-01-31 18_29_51-Speed Dial - Opera.png

        11.35 kB, 465×482, viewed 207 times
      • 2016-01-31 18_37_26-Untrusted Connection - Waterfox.png

        25.75 kB, 702×408, viewed 217 times
      • 2016-01-31 18_42_06-.png

        17.3 kB, 477×200, viewed 193 times

      The post was edited 5 times, last by omavoss ().

    • Probleme mit Zertifikaten

      Hier das gewünschte Bild:
      aber es scheint nicht das richtige Zertifikat zu sein, denn es weist auf die lokale IP-Adresse hin ... irgendwie benutzt OMV das falsche Zertifikat, wie kann ich das löschen?
      Images
      • 2016-01-31 20_17_11-Untrusted Connection - Waterfox.png

        31.59 kB, 706×519, viewed 218 times
      • 2016-01-31 20_33_21-openmediavault web administration interface - MD.fritz.box ‎- Microsoft Edge.png

        50 kB, 1,058×368, viewed 251 times

      The post was edited 1 time, last by omavoss ().

    • Hey,
      das erste Problem (login zum OMV per https) konnte ich lösen mit omv-firstaid. Hier kann man das richtige Zertifikat auswählen, wenn man unter "Configure WebGUI" entsprechendes auswählt, also Port 443 für OMV. Geht aber nur mit MS Edge, da ist das Schloss "geschlossen". Waterfox, Opera und Safari unverändert.

      Nun aber habe ich für OwnCloud den Port 8443 gewählt, und dort kriege ich die Zertifikatsfehler einfach nicht weg. Wie kriege ich OC dazu, NICHT das Zertifikat für die lokale IP-Adresse, sondern das Zertifikat für die DDNS-Adresse auszuwählen?

      The post was edited 1 time, last by omavoss ().