owncloud and ntfs

    • OMV 1.0
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • owncloud and ntfs


      I am setting up Owncloud (again) after a reinstallation of omv, and I want the data to be stored on my media partition. Unfortunately this has to be mounted as NTFS, both because I want windows to see it (work laptop) and also because backing it up to reformat will be a bitch! (and will require me to buy another HDD)

      My main problem is that owncloud wants me to set the permissions to 770, but as the drive is ntfs, I cant change the permissions. I tried editing the fstab to add the permissions option, but this was removed on rebooting the system (and didn't let me chmod anyway)

      Can anyone help?

      Cheers :)
    • Well, it seemed to sort itself out, but I have just realised that it has made the owncloud folder in the root directory (on the root drive). while looking at the shares I get this error:
      Failed to get configuration (xpath=//system/fstab/mntent[uuid='1aba7ae0-0997-48dc-8f18-7c97070757ec'])

      With the following:

      Source Code

      1. Error
      2. #3003:
      3. exception 'OMVException' with message 'Failed to get configuration
      4. (xpath=//system/fstab/mntent[uuid='1aba7ae0-0997-48dc-8f18-7c97070757ec'])'
      5. in /usr/share/openmediavault/engined/rpc/sharemgmt.inc:258
      6. Stack trace:
      7. #0 [internal function]: OMVRpcServiceShareMgmt->get(Array, Array)
      8. #1 /usr/share/php/openmediavault/rpcservice.inc(125):
      9. call_user_func_array(Array, Array)
      10. #2 /usr/share/php/openmediavault/rpc.inc(79):
      11. OMVRpcServiceAbstract->callMethod('get', Array, Array)
      12. #3 /usr/sbin/omv-engined(501): OMVRpc::exec('ShareMgmt', 'get', Array,
      13. Array, 1)
      14. #4 {main}
      Display All

      This happens with all shares.
    • fixed the error message by deleting all of the shares. Now I just have the original issue, cannot set permissions on the ntfs drive. I have tried editing the config.xml and I can now get my changes to survive a reboot in fstab, but still cant chmod the damn directories!
    • OMG I am getting closer! After adding dmask=007 to config.xml file and rebooting I now have drwxrwx--- permissions on the drive (so far so good), but now owncloud in winging about something else:
      Can't create data directory (/media/2FEAE88E665EDA39/Owncloud)

      This can usually be fixed by giving the webserver write access to the root directory.

      The folder is currently owned by root and group root. I tried:

      Source Code

      1. chown www-data Owncloud

      But this had no effect.

      Any ideas?
    • It's all working boys and girls!!!
      Re-edited the config.xm, removed the dmask and replaced it with permissions. Then REBOOTED and I could now chown to my hearts content! Not sure why I had to reboot though as I ran omv-mkfstab and mount -a, but the changes never applied themselves properly. Would be good to know what I am doing wrong to save rebooting in future.
    • As far as I know mount -a does not remount anything... thus it does not apply.

      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.