SMB/CIFS - cannot connect to shared folders

    • OMV 3.x
    • SMB/CIFS - cannot connect to shared folders

      Been running into lots of config errors after a clean reinstall of OMV3. I've had guest only SMB/CIFS sharing for years without an issue. After the install, I cannot connect to any shares. Below is smb.conf file and some output for the samba service. Again, this is on a clean install of OMV3 without only the docker plugin enabled. I've tried connecting to the samba shares from win10 and RPi3. Neither one can even find OMV using the web address. On the RPi3, for instance, I just get "Unable to find suitable address."


      I have no clean what is going on with this. I've been working at it for several hours and need to stop. Any help is much appreciated.


      root@openmediavault:/srv# sudo cat /etc/samba/smb.conf
      #======================= Global Settings =======================
      [global]
      workgroup = WORKGROUP
      server string = %h server
      dns proxy = no
      log level = 0
      syslog = 0
      log file = /var/log/samba/log.%m
      max log size = 1000
      syslog only = yes
      panic action = /usr/share/samba/panic-action %d
      encrypt passwords = true
      passdb backend = tdbsam
      obey pam restrictions = no
      unix password sync = no
      passwd program = /usr/bin/passwd %u
      passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
      pam password change = yes
      socket options = TCP_NODELAY IPTOS_LOWDELAY
      guest account = nobody
      load printers = no
      disable spoolss = yes
      printing = bsd
      printcap name = /dev/null
      unix extensions = yes
      wide links = no
      create mask = 0777
      directory mask = 0777
      map to guest = Bad User
      use sendfile = yes
      aio read size = 16384
      aio write size = 16384
      null passwords = no
      local master = yes
      time server = no
      wins support = no
      #======================= Share Definitions =======================
      [Server]
      path = /srv/dev-disk-by-label-Server
      guest ok = yes
      guest only = yes
      read only = no
      browseable = yes
      inherit acls = yes
      inherit permissions = no
      ea support = no
      store dos attributes = no
      vfs objects =
      printable = no
      create mask = 0664
      force create mode = 0664
      directory mask = 0775
      force directory mode = 0775
      hide special files = yes
      follow symlinks = yes
      hide dot files = yes
      [Media]
      path = /srv/dev-disk-by-label-Media
      guest ok = yes
      guest only = yes
      read only = no
      browseable = yes
      inherit acls = yes
      inherit permissions = no
      ea support = no
      store dos attributes = no
      vfs objects =
      printable = no
      create mask = 0664
      force create mode = 0664
      directory mask = 0775
      force directory mode = 0775
      hide special files = yes
      follow symlinks = yes
      hide dot files = yes


      root@openmediavault:/srv# ps aux |grep smb
      root 17006 0.0 0.0 12728 2280 pts/0 S+ 16:17 0:00 grep smb


      root@openmediavault:/srv# systemctl status smbd -l
      ● smbd.service - LSB: start Samba SMB/CIFS daemon (smbd)
      Loaded: loaded (/etc/init.d/smbd)
      Active: active (exited) since Sun 2017-12-10 16:13:29 MST; 4min 26s ago

      Dec 10 16:13:29 openmediavault smbd[16497]: Starting SMB/CIFS daemon: smbd.
      Dec 10 16:13:29 openmediavault systemd[1]: Started LSB: start Samba SMB/CIFS daemon (smbd).


      root@openmediavault:/srv# systemctl status nmbd -l
      ● nmbd.service - LSB: start Samba NetBIOS nameserver (nmbd)
      Loaded: loaded (/etc/init.d/nmbd)
      Active: active (exited) since Sun 2017-12-10 16:13:30 MST; 4min 28s ago

      Dec 10 16:13:30 openmediavault nmbd[16549]: Starting NetBIOS name server: nmbd.
      Dec 10 16:13:30 openmediavault systemd[1]: Started LSB: start Samba NetBIOS nameserver (nmbd).


      root@openmediavault:/srv# smbstatus

      Samba version 4.2.14-Debian
      PID Username Group Machine Protocol Version
      ------------------------------------------------------------------------------

      Service pid machine Connected at
      -------------------------------------------------------

      /var/run/samba/locking.tdb not initialised
      This is normal if an SMB client has never connected to your server.
    • The smb.conf looks ok, except it doesnt have any privileges set up (login control access). Go to shared folder section and select these folders and add some users you want to allow access. To discard any dns issues just the ip address of omv in win10 in the location bar

      \\IPNAS

      Also as it has been mentioned in several forums w10 recently deactivated smb1 support in an update. So maybe add

      server min protocol = SMB2

      in the extra options in general
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10
      telegram.me/openmediavault broadcast channel
      openmediavault discord server
    • Still nothing. Here is the ouput:


      root@openmediavault:~# ps axf | grep smbd
      9376 pts/0 S+ 0:00 \_ grep smbd


      root@openmediavault:~# systemctl start smbd


      root@openmediavault:~# systemctl status smbd -l
      ● smbd.service - LSB: start Samba SMB/CIFS daemon (smbd)
      Loaded: loaded (/etc/init.d/smbd)
      Active: active (exited) since Sun 2017-12-10 21:15:29 MST; 2min 8s ago

      Dec 10 21:15:29 openmediavault smbd[9198]: Starting SMB/CIFS daemon: smbd.
      Dec 10 21:15:29 openmediavault systemd[1]: Started LSB: start Samba SMB/CIFS daemon (smbd).
      Dec 10 21:15:34 openmediavault systemd[1]: Started LSB: start Samba SMB/CIFS daemon (smbd).
      Dec 10 21:17:35 openmediavault systemd[1]: Started LSB: start Samba SMB/CIFS daemon (smbd).
    • Same outcome. Nothing happening. I am running OMV on a USB 3.0. But, I've been running it on flash drives since I started running OMV about 6 years ago. I posted the cat /etc/init.d/smbd below this time because I thought maybe the init script is incorrect?


      root@openmediavault:~# systemctl unmask smbd

      root@openmediavault:~# systemctl start smbd

      root@openmediavault:~# ps axf | grep smbd
      4046 pts/0 S+ 0:00 \_ grep smbd

      root@openmediavault:~# systemctl status smbd -l
      ● smbd.service - LSB: start Samba SMB/CIFS daemon (smbd)
      Loaded: loaded (/etc/init.d/smbd)
      Active: active (exited) since Mon 2017-12-11 10:01:08 MST; 8s ago
      Process: 4033 ExecStart=/etc/init.d/smbd start (code=exited, status=0/SUCCESS)

      Dec 11 10:01:08 openmediavault smbd[4033]: Starting SMB/CIFS daemon: smbd.
      Dec 11 10:01:08 openmediavault systemd[1]: Started LSB: start Samba SMB/CIFS daemon (smbd).




      root@openmediavault:~# cat /etc/init.d/smbd
      #!/bin/sh

      ### BEGIN INIT INFO
      # Provides: smbd
      # Required-Start: $network $local_fs $remote_fs
      # Required-Stop: $network $local_fs $remote_fs
      # Default-Start: 2 3 4 5
      # Default-Stop: 0 1 6
      # Should-Start: slapd cups
      # Should-Stop: slapd cups
      # Short-Description: start Samba SMB/CIFS daemon (smbd)
      ### END INIT INFO


      PIDDIR=/var/run/samba
      SMBDPID=$PIDDIR/smbd.pid

      # clear conflicting settings from the environment
      unset TMPDIR

      # See if the daemons are there
      test -x /usr/sbin/smbd || exit 0

      . /lib/lsb/init-functions

      case $1 in
      start)
      if init_is_upstart; then
      exit 1
      fi
      SERVER_ROLE=`samba-tool testparm --parameter-name="server role" 2>/dev/null | tail -1`
      if [ "$SERVER_ROLE" = "active directory domain controller" ]; then
      exit 0
      fi

      log_daemon_msg "Starting SMB/CIFS daemon" smbd
      # Make sure we have our PIDDIR, even if it's on a tmpfs
      install -o root -g root -m 755 -d $PIDDIR

      if ! start-stop-daemon --start --quiet --oknodo --exec /usr/sbin/smbd -- -D; then
      log_end_msg 1
      exit 1
      fi

      log_end_msg 0
      ;;
      stop)
      if init_is_upstart; then
      exit 0
      fi

      log_daemon_msg "Stopping SMB/CIFS daemon" smbd

      start-stop-daemon --stop --quiet --pidfile $SMBDPID
      # Wait a little and remove stale PID file
      sleep 1
      if [ -f $SMBDPID ] && ! ps h `cat $SMBDPID` > /dev/null
      then
      # Stale PID file, remove it (should be removed by
      # smbd itself IMHO).
      rm -f $SMBDPID
      fi

      log_end_msg 0

      ;;
      reload)
      log_daemon_msg "Reloading /etc/samba/smb.conf" smbd

      start-stop-daemon --stop --quiet --signal HUP --pidfile $SMBDPID

      log_end_msg 0
      ;;
      restart|force-reload)
      if init_is_upstart; then
      exit 1
      fi
      $0 stop
      sleep 1
      $0 start
      ;;
      status)
      status_of_proc -p $SMBDPID /usr/sbin/smbd smbd
      exit $?
      ;;
      *)
      echo "Usage: /etc/init.d/smbd {start|stop|reload|restart|force-reload|status}"
      exit 1
      ;;
      esac

      exit 0
    • dhawk312 wrote:

      But, I've been running it on flash drives since I started running OMV about 6 years ago
      All flash media will die eventually (as every other hardware too). Details (why dumb thumb drives are somewhat special especially when longer used). And then I would take a look into the logfiles (/var/log/syslog and of course Samba logs if the daemons fail to start) instead of config files or start scripts. Also

      Source Code

      1. dmesg | curl -F 'sprunge=<-' http://sprunge.us
      And if there's something suspicious I would check whole OS installation for corruption (please use search bar above and search for 'dpkg verify')
    • Here are the various output from these commands.

      Source Code

      1. root@openmediavault:~# dpkg --verify
      2. ??5?????? c /etc/default/docker
      3. ??5?????? c /etc/cron-apt/action.d/3-download
      4. ??5?????? c /etc/cron-apt/config
      5. ??5?????? c /etc/watchdog.conf
      6. ??5?????? c /etc/default/monit
      7. ??5?????? c /etc/monit/monitrc
      8. ??5?????? c /etc/collectd/collectd.conf
      9. ??5?????? /var/lib/smartmontools/drivedb/drivedb.h
      10. ??5?????? c /etc/cron.daily/mdadm
      11. ??5?????? c /etc/default/avahi-daemon
      12. ??5?????? c /etc/avahi/avahi-daemon.conf
      13. ??5?????? c /etc/issue
      14. ??5?????? c /etc/default/acpid
      15. ??5?????? c /etc/default/collectd
      16. ??5?????? c /etc/default/rrdcached
      Display All


      No clue what this is but here you go:

      HTML Source Code

      1. root@openmediavault:~# dmesg | curl -F 'sprunge=<-' http://sprunge.us
      2. <html>
      3. <head>
      4. <title>500 Internal Server Error</title>
      5. </head>
      6. <body>
      7. <h1>500 Internal Server Error</h1>
      8. The server has either erred or is incapable of performing the requested operation.<br /><br />
      9. </body>
      10. </html>root@openmediavault:~#
      Display All



      From syslog:

      Source Code

      1. Dec 11 09:54:00 openmediavault systemd[1]: Stopping LSB: start Samba SMB/CIFS daemon (smbd)...
      2. Dec 11 09:54:01 openmediavault smbd[2660]: Stopping SMB/CIFS daemon: smbd.
      3. Dec 11 09:54:01 openmediavault systemd[1]: Stopped LSB: start Samba SMB/CIFS daemon (smbd).
      4. Dec 11 09:54:02 openmediavault systemd[1]: Reloading.
      5. Dec 11 09:54:25 openmediavault systemd[1]: mdmonitor.service: main process exited, code=exited, status=1/FAILURE
      6. Dec 11 09:54:25 openmediavault systemd[1]: Unit mdmonitor.service entered failed state.
      7. Dec 11 09:54:25 openmediavault systemd[1]: Starting LSB: start Samba SMB/CIFS daemon (smbd)...
      8. Dec 11 09:54:26 openmediavault smbd[2886]: Starting SMB/CIFS daemon: smbd.
      9. Dec 11 09:54:26 openmediavault systemd[1]: Started LSB: start Samba SMB/CIFS daemon (smbd).
      10. Dec 11 09:54:26 openmediavault systemd[1]: Reloading.
      11. Dec 11 21:38:18 openmediavault systemd[1]: Starting Enable File System Quotas...
      12. Dec 11 21:38:18 openmediavault systemd[1]: Starting MD array monitor...
      13. Dec 11 21:38:18 openmediavault systemd[1]: Started MD array monitor.
      14. Dec 11 21:38:18 openmediavault mdadm[13425]: mdadm: No mail address or alert command - not monitoring.
      15. Dec 11 21:38:18 openmediavault quotaon[13424]: quotaon: using /srv/dev-disk-by-label-Server/aquota.group on /dev/md126 [/srv/dev-disk-by-label-Server]: Device or resource busy
      16. Dec 11 21:38:18 openmediavault quotaon[13424]: quotaon: cannot find /srv/dev-disk-by-label-Server/aquota.user on /dev/md126 [/srv/dev-disk-by-label-Server]
      17. Dec 11 21:38:18 openmediavault quotaon[13424]: quotaon: using /srv/dev-disk-by-label-Media/aquota.group on /dev/md127 [/srv/dev-disk-by-label-Media]: Device or resource busy
      18. Dec 11 21:38:18 openmediavault quotaon[13424]: quotaon: using /srv/dev-disk-by-label-Media/aquota.user on /dev/md127 [/srv/dev-disk-by-label-Media]: Device or resource busy
      19. Dec 11 21:38:18 openmediavault systemd[1]: quotaon.service: main process exited, code=exited, status=4/NOPERMISSION
      20. Dec 11 21:38:18 openmediavault systemd[1]: Failed to start Enable File System Quotas.
      21. Dec 11 21:38:18 openmediavault systemd[1]: Unit quotaon.service entered failed state.
      22. Dec 11 21:38:18 openmediavault systemd[1]: mdmonitor.service: main process exited, code=exited, status=1/FAILURE
      23. Dec 11 21:38:18 openmediavault systemd[1]: Unit mdmonitor.service entered failed state.
      24. Dec 11 21:38:18 openmediavault systemd[1]: Starting LSB: start Samba NetBIOS nameserver (nmbd)...
      25. Dec 11 21:38:19 openmediavault nmbd[13429]: Starting NetBIOS name server: nmbd.
      26. Dec 11 21:38:19 openmediavault systemd[1]: Started LSB: start Samba NetBIOS nameserver (nmbd).
      Display All



      I enabled SMB/CIFS "full" logging but haven't gotten any logs yet.

      Source Code

      1. root@openmediavault:/var/log/samba# cd /var/log/samba
      2. root@openmediavault:/var/log/samba# ls -l
      3. total 0


      When I try go access this info via the OMV web GUI, I get this error:

      Source Code

      1. Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; export SYSTEMD_COLORS=0; journalctl --quiet --no-pager --priority='notice' SYSLOG_FACILITY=23 SYSLOG_IDENTIFIER='smbd_audit' --output=short 1>/tmp/logfile3E0znv 2>&1' with exit code '1':
    • Here is the out of smbd -F -d 3 -S:

      Source Code

      1. root@openmediavault:~# smbd -F -d 3 -S
      2. Maximum core file size limits now 16777216(soft) -1(hard)
      3. smbd version 4.2.14-Debian started.
      4. Copyright Andrew Tridgell and the Samba Team 1992-2014
      5. uid=0 gid=0 euid=0 egid=0
      6. lp_load_ex: refreshing parameters
      7. Initialising global parameters
      8. Processing section "[global]"
      9. WARNING: The "null passwords" option is deprecated
      10. Registered MSG_REQ_POOL_USAGE
      11. Registered MSG_REQ_DMALLOC_MARK and LOG_CHANGED
      12. lp_load_ex: refreshing parameters
      13. Initialising global parameters
      14. Processing section "[global]"
      15. WARNING: The "null passwords" option is deprecated
      16. Processing section "[TV_Shows]"
      17. Processing section "[Server]"
      18. adding IPC service
      19. added interface docker0 ip=172.17.0.1 bcast=172.17.255.255 netmask=255.255.0.0
      20. added interface eth0 ip=192.168.0.87 bcast=192.168.0.255 netmask=255.255.255.0
      21. loaded services
      22. Standard input is not a socket, assuming -D option
      23. Becoming a daemon.
      24. Could not open tdb: No such file or directory
      25. Failed to fetch domain sid for WORKGROUP
      26. Failed to fetch domain sid for WORKGROUP
      27. Could not open tdb: No such file or directory
      28. account_policy_get: tdb_fetch_uint32 failed for type 1 (min password length), re turning 0
      29. account_policy_get: tdb_fetch_uint32 failed for type 2 (password history), retur ning 0
      30. account_policy_get: tdb_fetch_uint32 failed for type 3 (user must logon to chang e password), returning 0
      31. account_policy_get: tdb_fetch_uint32 failed for type 4 (maximum password age), r eturning 0
      32. account_policy_get: tdb_fetch_uint32 failed for type 5 (minimum password age), r eturning 0
      33. account_policy_get: tdb_fetch_uint32 failed for type 6 (lockout duration), retur ning 0
      34. account_policy_get: tdb_fetch_uint32 failed for type 7 (reset count minutes), re turning 0
      35. account_policy_get: tdb_fetch_uint32 failed for type 8 (bad lockout attempt), re turning 0
      36. account_policy_get: tdb_fetch_uint32 failed for type 9 (disconnect time), return ing 0
      37. account_policy_get: tdb_fetch_uint32 failed for type 10 (refuse machine password change), returning 0
      38. tdbsam_open: Converting version 0.0 database to version 4.0.
      39. WARNING: database '/var/lib/samba/private/passdb.tdb.tmp' does not end in .[n]tdb: treating it as a TDB file!
      40. tdbsam_convert_backup: updated /var/lib/samba/private/passdb.tdb file.
      41. tdb(/var/lib/samba/winbindd_idmap.tdb): tdb_open_ex: could not open file /var/lib/samba/winbindd_idmap.tdb: No such file or directory
      42. TDBSAM converted successfully.
      43. STATUS=daemon 'smbd' finished starting up and ready to serve connections
      44. waiting for connections
      45. Could not find child 19735 -- ignoring
      46. Could not find child 19737 -- ignoring
      47. Could not find child 19742 -- ignoring
      Display All
    • That worked, finally! But, lots of errors, and the connection is slow.

      And, as soon as I ctrl-c or exit the SSH connection, the network connection closes immediately.

      Source Code

      1. root@openmediavault:~# smbd -F -d 3 -S
      2. Maximum core file size limits now 16777216(soft) -1(hard)
      3. smbd version 4.2.14-Debian started.
      4. Copyright Andrew Tridgell and the Samba Team 1992-2014
      5. uid=0 gid=0 euid=0 egid=0
      6. lp_load_ex: refreshing parameters
      7. Initialising global parameters
      8. Processing section "[global]"
      9. WARNING: The "null passwords" option is deprecated
      10. Registered MSG_REQ_POOL_USAGE
      11. Registered MSG_REQ_DMALLOC_MARK and LOG_CHANGED
      12. lp_load_ex: refreshing parameters
      13. Initialising global parameters
      14. Processing section "[global]"
      15. WARNING: The "null passwords" option is deprecated
      16. Processing section "[TV_Shows]"
      17. Processing section "[Server]"
      18. adding IPC service
      19. added interface docker0 ip=172.17.0.1 bcast=172.17.255.255 netmask=255.255.0.0
      20. added interface eth0 ip=192.168.0.87 bcast=192.168.0.255 netmask=255.255.255.0
      21. loaded services
      22. Standard input is not a socket, assuming -D option
      23. Becoming a daemon.
      24. Failed to fetch domain sid for WORKGROUP
      25. Failed to fetch domain sid for WORKGROUP
      26. STATUS=daemon 'smbd' finished starting up and ready to serve connections
      27. waiting for connections
      28. Allowed connection from 192.168.0.X (192.168.0.X)
      29. GENSEC backend 'gssapi_spnego' registered
      30. GENSEC backend 'gssapi_krb5' registered
      31. GENSEC backend 'gssapi_krb5_sasl' registered
      32. GENSEC backend 'spnego' registered
      33. GENSEC backend 'schannel' registered
      34. GENSEC backend 'naclrpc_as_system' registered
      35. GENSEC backend 'sasl-EXTERNAL' registered
      36. GENSEC backend 'ntlmssp' registered
      37. GENSEC backend 'ntlmssp_resume_ccache' registered
      38. GENSEC backend 'http_basic' registered
      39. GENSEC backend 'http_ntlm' registered
      40. GENSEC backend 'krb5' registered
      41. GENSEC backend 'fake_gssapi_krb5' registered
      42. Got NTLMSSP neg_flags=0xe2088297
      43. Got user=[X@outlook.com] domain=[MicrosoftAccount] workstation=[HTPC]len1=24 len2=308
      44. lp_load_ex: refreshing parameters
      45. Initialising global parameters
      46. Processing section "[global]"
      47. WARNING: The "null passwords" option is deprecated
      48. Processing section "[TV_Shows]"
      49. Processing section "[Server]"
      50. adding IPC service
      51. check_ntlm_password: Checking password for unmapped user [MicrosoftAccount]\[X@outlook.com]@[HTPC] with the new password interface
      52. check_ntlm_password: mapped user is: [OPENMEDIAVAULT]\[X@outlook.com]@[HTPC]
      53. check_sam_security: Couldn't find user 'X@outlook.com' in passdb.
      54. check_ntlm_password: Authentication for user [X@outlook.com] -> [X@outlook.com] FAILED with error NT_STATUS_NO_SUCH_USER
      55. No such user X@outlook.com [MicrosoftAccount] - using guest account
      56. Allowed connection from 192.168.0.X (192.168.0.X)
      57. Allowed connection from 192.168.0.X (192.168.0.X)
      58. Allowed connection from 192.168.0.X (192.168.0.X)
      59. Could not find child 2379 -- ignoring
      60. Allowed connection from 192.168.0.X (192.168.0.X)
      61. GENSEC backend 'gssapi_spnego' registered
      62. GENSEC backend 'gssapi_krb5' registered
      63. GENSEC backend 'gssapi_krb5_sasl' registered
      64. GENSEC backend 'spnego' registered
      65. GENSEC backend 'schannel' registered
      66. GENSEC backend 'naclrpc_as_system' registered
      67. GENSEC backend 'sasl-EXTERNAL' registered
      68. GENSEC backend 'ntlmssp' registered
      69. GENSEC backend 'ntlmssp_resume_ccache' registered
      70. GENSEC backend 'http_basic' registered
      71. GENSEC backend 'http_ntlm' registered
      72. GENSEC backend 'krb5' registered
      73. GENSEC backend 'fake_gssapi_krb5' registered
      74. Got NTLMSSP neg_flags=0xe2088297
      75. Got user=[X@outlook.com] domain=[MicrosoftAccount] workstation=[HTPC] len1=24 len2=308
      76. lp_load_ex: refreshing parameters
      77. Initialising global parameters
      78. Processing section "[global]"
      79. WARNING: The "null passwords" option is deprecated
      80. Processing section "[TV_Shows]"
      81. Processing section "[Server]"
      82. adding IPC service
      83. check_ntlm_password: Checking password for unmapped user [MicrosoftAccount]\[X@outlook.com]@[HTPC] with the new password interface
      84. check_ntlm_password: mapped user is: [OPENMEDIAVAULT]\[X@outlook.com]@[HTPC]
      85. check_sam_security: Couldn't find user 'X@outlook.com' in passdb.
      86. check_ntlm_password: Authentication for user [X@outlook.com] -> [X@outlook.com] FAILED with error NT_STATUS_NO_SUCH_USER
      87. No such user X@outlook.com [MicrosoftAccount] - using guest account
      88. Allowed connection from 192.168.0.x (192.168.0.x)
      89. Allowed connection from 192.168.0.x (192.168.0.x)
      90. Allowed connection from 192.168.0.x (192.168.0.x)
      91. Allowed connection from 192.168.0.x (192.168.0.x)
      92. Could not find child 2389 -- ignoring
      93. Allowed connection from 192.168.0.x (192.168.0.x)
      94. Allowed connection from 192.168.0.x (192.168.0.x)
      95. Allowed connection from 192.168.0.x (192.168.0.x)
      96. Could not find child 2400 -- ignoring
      97. Allowed connection from 192.168.0.x (192.168.0.x)
      98. GENSEC backend 'gssapi_spnego' registered
      99. GENSEC backend 'gssapi_krb5' registered
      100. GENSEC backend 'gssapi_krb5_sasl' registered
      101. GENSEC backend 'spnego' registered
      102. GENSEC backend 'schannel' registered
      103. GENSEC backend 'naclrpc_as_system' registered
      104. GENSEC backend 'sasl-EXTERNAL' registered
      105. GENSEC backend 'ntlmssp' registered
      106. GENSEC backend 'ntlmssp_resume_ccache' registered
      107. GENSEC backend 'http_basic' registered
      108. GENSEC backend 'http_ntlm' registered
      109. GENSEC backend 'krb5' registered
      110. GENSEC backend 'fake_gssapi_krb5' registered
      111. Got NTLMSSP neg_flags=0xe2088297
      112. Got user=[X@outlook.com] domain=[MicrosoftAccount] workstation=[HTPC] len1=24 len2=308
      113. lp_load_ex: refreshing parameters
      114. Initialising global parameters
      115. Processing section "[global]"
      116. WARNING: The "null passwords" option is deprecated
      117. Processing section "[TV_Shows]"
      118. Processing section "[Server]"
      119. adding IPC service
      120. check_ntlm_password: Checking password for unmapped user [MicrosoftAccount]\[X@outlook.com]@[HTPC] with the new password interface
      121. check_ntlm_password: mapped user is: [OPENMEDIAVAULT]\[X@outlook.com]@[HTPC]
      122. check_sam_security: Couldn't find user 'X@outlook.com' in passdb.
      123. check_ntlm_password: Authentication for user [X@outlook.com] -> [X@outlook.com] FAILED with error NT_STATUS_NO_SUCH_USER
      124. No such user X@outlook.com [MicrosoftAccount] - using guest account
      125. Allowed connection from 192.168.0.X (192.168.0.X)
      126. Could not find child 2410 -- ignoring
      127. Allowed connection from 192.168.0.X (192.168.0.X)
      128. Could not find child 2421 -- ignoring
      129. Allowed connection from 192.168.0.X (192.168.0.X)
      130. Could not find child 2434 -- ignoring
      131. Allowed connection from 192.168.0.X (192.168.0.X)
      132. Allowed connection from 192.168.0.X (192.168.0.X)
      133. Could not find child 2444 -- ignoring
      Display All
    • I renamed start-stop-daemon start-stop-daemon.REAL as stated in the link you sent. I then tried restarting the services, but smbd failed.


      Source Code

      1. root@openmediavault:/sbin# systemctl restart smbd
      2. Job for smbd.service failed. See 'systemctl status smbd.service' and 'journalctl -xn' for details.
      3. root@openmediavault:/sbin# systemctl restart nmbd
      4. Job for nmbd.service failed. See 'systemctl status nmbd.service' and 'journalctl -xn' for details.
      5. root@openmediavault:/sbin# systemctl status smbd.service
      6. ● smbd.service - LSB: start Samba SMB/CIFS daemon (smbd)
      7. Loaded: loaded (/etc/init.d/smbd)
      8. Active: failed (Result: exit-code) since Tue 2017-12-12 17:43:33 MST; 15s ago
      9. Process: 2395 ExecStop=/etc/init.d/smbd stop (code=exited, status=0/SUCCESS)
      10. Process: 2448 ExecStart=/etc/init.d/smbd start (code=exited, status=1/FAILURE)
      11. Dec 12 17:43:33 openmediavault smbd[2448]: Starting SMB/CIFS daemon: smbd/et...d
      12. Dec 12 17:43:33 openmediavault smbd[2448]: failed!
      13. Dec 12 17:43:33 openmediavault systemd[1]: smbd.service: control process exi...1
      14. Dec 12 17:43:33 openmediavault systemd[1]: Failed to start LSB: start Samba ....
      15. Dec 12 17:43:33 openmediavault systemd[1]: Unit smbd.service entered failed ....
      16. Hint: Some lines were ellipsized, use -l to show in full.
      Display All
    • Don’t know what to tell you. Is the system completely up to date ?

      I would recommend you then try to install plain Debian from iso. Install all the Debian updates and finally install Omv on top.
      Use the netinst iso or full one just select ssh server nothing else, no desktop anything.
      Make sure also data disks are disconnected to avoid any overwrite or format mistake.
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10
      telegram.me/openmediavault broadcast channel
      openmediavault discord server