Autoshoutdown, after list active host end of task

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Autoshoutdown, after list active host end of task

      Hello,

      VERSION="0.9.9.10"

      After config still the same, there are two hosts (IP from DHCP) one is laptop and second is TV. Why the script not pass next steps and finally sleep the machine?

      Brainfuck Source Code

      1. root@omv1T:/tmp/autoshutdown# tail /var/log/autoshutdown.log
      2. Mar 4 19:40:54 omv1T root: autoshutdown[28622]: INFO: ' retrieve list of active IPs for 'enp0s10' ...'
      3. Mar 4 19:41:07 omv1T root: autoshutdown[28622]: INFO: ' Found IP 192.168.10.145 as active host.'
      4. Mar 4 19:41:07 omv1T root: autoshutdown[28622]: INFO: ' Found IP 192.168.10.242 as active host.'
      5. Mar 4 19:41:07 omv1T root: autoshutdown[28622]: INFO: ' sleep for 60s.'
      6. Mar 4 19:42:07 omv1T root: autoshutdown[28622]: INFO: '------------------------------------------------------'
      7. Mar 4 19:42:07 omv1T root: autoshutdown[28622]: INFO: ' new supervision cycle started - check active hosts or processes'
      8. Mar 4 19:42:07 omv1T root: autoshutdown[28622]: INFO: ' retrieve list of active IPs for 'enp0s10' ...'
      9. Mar 4 19:42:20 omv1T root: autoshutdown[28622]: INFO: ' Found IP 192.168.10.145 as active host.'
      10. Mar 4 19:42:20 omv1T root: autoshutdown[28622]: INFO: ' Found IP 192.168.10.242 as active host.'
      11. Mar 4 19:42:20 omv1T root: autoshutdown[28622]: INFO: ' sleep for 60s.'
      12. root@omv1T:/tmp/autoshutdown#
      Display All


      Configuration is:


      Source Code

      1. # This configuration file is auto-generated.
      2. # WARNING: Do not edit this file, your changes will be lost.
      3. ENABLE="true"
      4. CYCLES=6
      5. SLEEP=60
      6. RANGE="10..254"
      7. SHUTDOWNCOMMAND="systemctl suspend"
      8. CHECKCLOCKACTIVE="false"
      9. UPHOURS="6..20"
      10. NSOCKETNUMBERS="21,22,80,139,445"
      11. ULDLCHECK="true"
      12. ULDLRATE=80
      13. LOADAVERAGECHECK="false"
      14. LOADAVERAGE=40
      15. HDDIOCHECK="false"
      16. HDDIO_RATE=401
      17. CHECK_SAMBA="false"
      18. CHECK_CLI="true"
      19. SYSLOG="true"
      20. VERBOSE="false"
      21. FAKE="false"
      Display All



      The script come from OMV: 4.1.19-1 (Arrakis)

      Please help

      BR, Krzysie
    • I have exactly the same content in the /var/log/autoshutdown.log file - only two cycles. But when I look to "Systems log -> logs -> AutoShutdown", the content is constantly growing with each cycle.

      And you have two active hosts. If this hosts are off the OMV machine should make a shutdown.

      If you enable the "Verbose mode" a lot of more information is written to the log.
      OMV 3.0.90 (Gray style)
      ASRock Rack C2550D4I - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304

      The post was edited 1 time, last by cabrio_leo ().

    • oneiro wrote:

      there are two hosts (IP from DHCP) one is laptop and second is TV

      oneiro wrote:

      ok, but how disabled active hosts ?
      I didn´t understand what you mean exactly. You simply have to ensure that your Laptop and your TV isn´t anymore active in the network. E.g. a ping must not be responded by the systems in the network.
      But if you control your smart TV with an app, it is always active in the network, while it is in standby to be accessible by the app. Often there is an setup option to switch the network completely off also in standby.
      OMV 3.0.90 (Gray style)
      ASRock Rack C2550D4I - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304