Festplatten werden nicht ins RAID eingebunden

  • Hallo,
    physisch werden alle 9 im System vorhandenen Festplatten angezeigt (1x für BS und 8x für Daten). Wen ich ein RAID, Stripeset oder was auch immer erstellen will, bekomme ich nur 6 Platten zur Auswahl angezeigt.


    Bitte um Hilfe.
    Viele Grüße.

    2 BananaPi, 1 OrangePiPC+, 2 x86-PC with OMV 5.5.x.x

    Edited once, last by omavoss ().

  • Hallo,
    habe den Fehler gefunden:
    die Platten sind an einem RAID-Controller Promise Fasttrak66 angeschlossen, dafür gibts keine Debian-Unterstützung.


    Viele Grüße.

    2 BananaPi, 1 OrangePiPC+, 2 x86-PC with OMV 5.5.x.x

  • Hallo,
    ich habe jetzt den Promise fasttrak 66 gegen einen Promise Fasttrak Ultra 100 ausgetauscht und komme einfach nicht weiter.
    die Platten werden pysisch vom System erkannt und im OMV angezeigt. Wenn ich sie nun in ein RAID einbinden will, kommt KEINE der Platten zur Auswahl. Es funktioniert einfach nicht.


    Am IDE-Controller des Mainboards hängen drei Platten, eine Für das BS und zwei für RAID. Die werden erkannt und ich kann einRAID erstellen. Nur die Platten, die an einem weiteren Controller hängen, werden einfach nicht zur Verwendung für ein RAID angezeigt.


    Was kann man tun bzw. was mache ich falsch?


    Ich Installiere das System "nackt" auf einer Festplatte und wenn es läuft, schließe ich zuerst die Platten an den Mainboard-IDE-Controller an. Die werden richtig erkannt und ich kann sie verwenden. Dann stecke ich den Promise-Controller mit dranhängenden Platten rein, die werden als physisch vorhanden erkannt, aber nicht für die Verwendung in einem RAID angezeigt.


    Ist mir bitte noch zu helfen?


    viele Grüße.

    2 BananaPi, 1 OrangePiPC+, 2 x86-PC with OMV 5.5.x.x

  • Sieht so aus als ob der RAID-Controller einfach nicht von OMV unterstützt wird. Das ist dann der Fall wenn die Platten nicht dem Muster /dev/sdX entsprechen. Für einen RAID-Controller wurde das schon gefixt (keine Ahnung welcher das war), aber die Device Files sehen folgendermaßen aus: /dev/cciss/cXdX. Wahrscheinlich muss einfach das Backend für den entsprechenden RAID-Controller angepasst werden.


    Wenn Du mehr Infos zu dem Controller hast dan öffne doch im Bugtracker einen neuen Feature-Request. Entwicklungsangelegenheiten können nicht im Forum betreut werden, da fehlt irgendwann der Überblick.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!