problems with automatic tasks

  • I have made some pull tasks which are doing fine when I test them, and also start by hand they sync.


    But when checking on the minute parameter, and say 5, it does not sync or try to sync every 5 minutes.
    In the syslog:

    Code
    Aug 18 12:33:01 OMV cron[2506]: Error: bad minute; while reading /etc/cron.d/openmediavault-rsync
    Aug


    what is going wrong? Even with the hour set it not work.

    ---------------------------------------------
    My HP T610 thin client NAS
    ---------------------------------------------
    ---------------------------------------------
    My Thin Client single drive NAS build
    ---------------------------------------------
    -----------------------------------------------------
    I'm from the Netherlands, excuse me for bad english
    -----------------------------------------------------------------

  • Code
    root@OMV:~# cat /etc/cron.d/openmediavault-rsync
    SHELL=/bin/sh
    PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
    # m h dom mon dow user command
    */5 * * * * root /var/lib/openmediavault/cron.d/rsync-7b793b58-dee6-4c48-9f03-e703046cdaf7
    */0 */2 * * * root /var/lib/openmediavault/cron.d/rsync-5daee158-6a68-48c4-b643-7b78c61d441e
    */4 */4 * * * root /var/lib/openmediavault/cron.d/rsync-425ccdd2-9bc0-4026-ba18-27e443ef4bf7
    5 * * * * root /var/lib/openmediavault/cron.d/rsync-dfe2134c-025a-46fd-885b-df1fe5481987

    ---------------------------------------------
    My HP T610 thin client NAS
    ---------------------------------------------
    ---------------------------------------------
    My Thin Client single drive NAS build
    ---------------------------------------------
    -----------------------------------------------------
    I'm from the Netherlands, excuse me for bad english
    -----------------------------------------------------------------

  • Ändere mal bitte die Zeile:

    Code
    */0 */2 * * * root /var/lib/openmediavault/cron.d/rsync-5daee158-6a68-48c4-b643-7b78c61d441e


    in (das vordere */ weg)

    Code
    0 */2 * * * root /var/lib/openmediavault/cron.d/rsync-5daee158-6a68-48c4-b643-7b78c61d441e


    Ich nehme an, der job soll alle 2h laufen.
    */0 ist jede "nullte" Minute, was den Fehler verursachen könnte. Genau hab ichs aber nicht gecheckt.


    Edit:
    Versuch auch mal

    Code
    * */2 * * * root /var/lib/openmediavault/cron.d/rsync-5daee158-6a68-48c4-b643-7b78c61d441e


    wenns nicht klappt

  • Its not only the rule with the 0 in it, but all of these won't sync as scheduled.
    Would like to sync it every day on differtent times.

    ---------------------------------------------
    My HP T610 thin client NAS
    ---------------------------------------------
    ---------------------------------------------
    My Thin Client single drive NAS build
    ---------------------------------------------
    -----------------------------------------------------
    I'm from the Netherlands, excuse me for bad english
    -----------------------------------------------------------------

  • Simply by turning the jobs all off, save config, then turn all on, they work again.But I dont know if the stopping, because I'm getting every minute when a job started mail.I now checked out the mail notification. I dont know whats going wrong here.



    they are all the same in text


    Quote

    Please wait, syncing <rsync://root@nijland.mynetgear.com:/Downloads/> to </media/17f874e3-a771-4626-8446-5a3b471e8abc/BCKNAS/Downloads/> ... receiving incremental file list sent 303 bytes received 77168 bytes 51647.33 bytes/sec total size is 33669547284 speedup is 434608.40

    ---------------------------------------------
    My HP T610 thin client NAS
    ---------------------------------------------
    ---------------------------------------------
    My Thin Client single drive NAS build
    ---------------------------------------------
    -----------------------------------------------------
    I'm from the Netherlands, excuse me for bad english
    -----------------------------------------------------------------

  • please post again the new output of

    Code
    cat /etc/cron.d/openmediavault-rsync


    sorry that I answered german, but I think you understood it ;)

  • Yes I know about the wildcard * but I thought when not selected the checkbox behind it, that parameter wont be used.
    I will try with everything checked, and everything checked out to see if it makes sense.


    @Solo0815 I'm dutch and can understand german very well, talking back is a bit difficulter for me :)

    ---------------------------------------------
    My HP T610 thin client NAS
    ---------------------------------------------
    ---------------------------------------------
    My Thin Client single drive NAS build
    ---------------------------------------------
    -----------------------------------------------------
    I'm from the Netherlands, excuse me for bad english
    -----------------------------------------------------------------

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!