How to recompile Realtek drivers for Odroid XU4?

  • I tried that.



    Still get the same error (I changed the echo "Pin: release a=jessie-backports" >> /etc/apt/preferences.d/99backports.pref to wheezy).


    When I tried running aptitude install samba and it asked me to remove all of the plugins for OMV


    I don't know why it won't let me update just samba...

  • That is the problem with not using the official debian repos. If I had a working xu4, I could recommend other things to try but I don't want to recommend things that would break the system completely. Installing samba4 was just a suggestion. I don't know for sure that it would've fixed anything. You could always try to install a minimal Debian Jessie on it and then install OMV 3.x on top of that. Maybe that would fix the problems. I wouldn't mind maintaining an XU4 OMV image but I'm not buying another one (have two dead XU4s now).

    omv 5.5.11 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • How stable is OMV 3.x currently?

    It is very stable for me. Depends on what you are doing with it, what system it is running on, and what plugins you use.


    I have tried to install it before but it was very unstable and would crash and lock me out from the web gui.

    What was unstable? What version?

    omv 5.5.11 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • What was unstable? What version?

    I don't remember what version it was about 6 months ago.


    It is very stable for me. Depends on what you are doing with it, what system it is running on, and what plugins you use.


    I just want a server that can access our dumb usb printers, be able to torrent (although I have a RPi1 that I might just use the attached storage and torrent through VPN on that), and serve as a NAS for my network.

  • I don't remember what version it was about 6 months ago.

    A lot has changed in 6 months.


    I just want a server that can access our dumb usb printers, be able to torrent (although I have a RPi1 that I might just use the attached storage and torrent through VPN on that), and serve as a NAS for my network.

    Not sure how stable torrent plugins are since I don't use them but the other functions should be ok with OMV 3.x.

    omv 5.5.11 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • if you wouldn't mind working on a 3.X XU4 image I think a lot of people would be happy about it.

    Personally, I have no need for an xu4 (have too many arm boards now). In order to make the image, I need a working xu4 (my two are dead). If people want to contribute the $80-85, I would buy one and maintain the image.

    omv 5.5.11 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • ryecoaaron wrote:

    New 3.0.64 xu3/xu4 image on sourceforge.


    I get this error when I try to get to the web gui....

    Code
    Error #0:
    exception 'OMV\ExecException' with message 'Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; hostname --fqdn 2>&1' with exit code '1': hostname: No address associated with hostname' in /usr/share/php/openmediavault/system/process.inc:175
    Stack trace:
    #0 /usr/share/php/openmediavault/system/net/dns.inc(46): OMV\System\Process->execute(Array)
    #1 /usr/share/php/openmediavault/controlpanel/controlpanelabstract.inc(212): OMV\System\Net\Dns::getFqdn()
    #2 /usr/share/php/openmediavault/controlpanel/controlpanelabstract.inc(99): OMV\ControlPanel\ControlPanelAbstract->getTitle()
    #3 /var/www/openmediavault/index.php(46): OMV\ControlPanel\ControlPanelAbstract->render()
    #4 {main}
  • Probably because my network hands out a domain with dhcp. Never thought it would keep you from logging in. Maybe try logging in locally and try omv-firstaid. Strange that the RPi image doesn't need a domain name. I might have to file a bug report.

    omv 5.5.11 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Probably because my network hands out a domain with dhcp. Never thought it would keep you from logging in. Maybe try logging in locally and try omv-firstaid. Strange that the RPi image doesn't need a domain name.

    I'm using OpenWrt for my network so I get a .lan address when I use DHCP. also the XU4 has a static address through the router so it would still think it's IP could change... weird. I tried omv-firstaid, and set ip4 to dhcp and ip6 off.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!