New user needs a little guidance

  • Hi all,

    Let me first say i have been playnig with linux for about 8 years and until about 1.5 years ago always had a linux box running.

    So when i decided to dump whs for a linux based media server, omv seemed liked a good choice.

    My specs are
    asus p5kc
    intel core 2 dua 3 ghz
    4 gigs ram, plus 3 tb of storage.

    Now the install went fine no issue's there.
    after install i updated and rebooted.
    i installed the plugins repository to get transmission.
    red text means i have solved my issue, now i nedd to find a help section for acl's.

    now here's where im stumped, i format my drives to xfs, i create a share for torrents and incomplete and watched. now wehn i go into transmission it appeared like transmission creates it's own. so i removed the ones i created in the share settings. now transmission says to make sure debian-transmission is added to the groups, i have tried to add a group but it seems to not add anything, so i figured i would try and add a debian-transmission user, but this seems to defeat the purpose of groups.

    so it seems like each plugin adds it own shares and the share settings under user rights adds it own shares. I was first under the impression the user rights management would let me click on the shares and make changes to all shares. if thats the case i have issue's.

    i have used the gui to setup smb and as per my experince the gui is not working for samba shares, can someone post a link to the command line smb setup and maybe a guide on how to run the smb setup from a cmd.

    solved with acl list, now off to find a guide about acl's

    Thanks for any and all help.

    Edited once, last by Spy Alelo: Red, Italic & underlined text all at once makes eyes bleed ().

  • Ok If someone may have some advice on getting the shares to show in windows that would be great.

    I have set the privlidges and checked all the acl boxes and still no shares show in windows.

    I do however see the media-server in windows network, just no shares show up.

    Hope someone can shed some light.

  • ok it's been a day now and all of a sudden one of my shares went crazy.

    I was no longer able to open it up in windows or any device, access denied.

    so i opened omv web page and went to look at the acl list and was presented with this error.

    Error #4000:
    exception 'OMVException' with message 'Failed to execute command 'sudo find '/media/fc1ae037-8a2e-4aa2-9ec1-e7d432b525ca/' -maxdepth 1 -type d -printf '%f
    ' 2>&1': find: `/media/fc1ae037-8a2e-4aa2-9ec1-e7d432b525ca/': Invalid argument' in /var/www/openmediavault/rpc/
    Stack trace:
    #0 [internal function]: DirBrowserRpc->get(Array)
    #1 /usr/share/php/openmediavault/ call_user_func_array(Array, Array)
    #2 /usr/share/php/openmediavault/ OMVRpc::exec('DirBrowser', 'get', Array)
    #3 /var/www/openmediavault/rpc.php(44): OMVJsonRpcServer->handle()
    #4 {main}

    Maybe someone with more experience can explain how i might be able to fix this?


  • Ok I restarted the system and windows can now see and open the share.

    now i have 2 asus oplays and they can see the share but fail to open it. i have tried to use the gui to reset the smb share, made sure all the settings in shared folders are right. still my media players wont open the share.
    now i have a share for the kids movies and it works great.

    is there a way to remove all the share properties and leave the data, to start all over?

  • Ok I installed omv on a 250 gig drive and have the system connected to my kvm, so when the system boots i get this error,
    /sbin/fsck.xfs: xfs file system.
    /sbin/fsck.xfs: xfs file system.
    /sbin/fsck.xfs: xfs file system.
    /sbin/fsck.xfs: uuid=kldsfgjlis-sfawefgaREW-Asgfsd-SGDFsg DOES NOT EXIST
    fsck died with exit 8 status

    file system check failed

    control-d terminate this shell or enter password for maintenance.

    so my system drive is ext4 and two other internal drives are xfs and i formated 3 usb drives to xfs.

    as my linux skills are limited I'm thinking of starting all over.
    unless the error above is familiar to someone and they can maybe help?


  • Ok reinstalling was easy and getting back to where i was is done.
    but on start-up i still get the same message as above.

    maybe this will help, the system was running whs. i just put in the omv disk and installed (on first install).
    now on the second install i did get the screen that asked where to install, i chose my system drive (wd 250 gb) and did get the message about all my data would be erased. (on the first install i did not get that message). i went ahead and the boot process stops and gives me the options to enter my password for maintenance or ctrl d to continue.
    thank god i'm using a kvm and can actually see the boot messages.

    hope someone can shed a little light on my issue.

    Ok I just ran ls -l /dev/disk/by-uuid, and from what i can see the error related to the uuid i have an issue with is not in the list shown by running ls -l /dev/disk/by-uuid.
    How is this possible with a fresh install?

  • Had the same symptoms. Adding/Removing disks after installation may confuse OMV. Have a look at /etc/fstab and try to delete the line containing the "non-existing" disk (or first comment it out) - at your own risk

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!