Virtual Box Error

  • Having solved my original error with ext pack see here and I have tried to start the VM only to get this error;

    The virtual machine 'Windows 7' has terminated unexpectedly during startup with exit code 1 (0x1)

    I'm guessing that because I reinstalled the plugin and pointed it to the VM shared folder that all would be Ok, but obviously not, I would rather not have to recreate the vm itself.

    There are endless posts regarding the above error if you just google, some of which seem to make sense here but which one, as is usually the case it's not one fix fits all.

    If do dpkg -l | grep virtualbox I get the following output,

    ii openmediavault-virtualbox 3.0.8 all VirtualBox plugin for OpenMediaVault.
    ii phpvirtualbox 5.0-5-2 all Web interface for VirtualBox.
    ii virtualbox 5.1.26-dfsg-2 amd64 x86 virtualization solution - base binaries
    ii virtualbox-dkms 5.1.14-dfsg-1 all x86 virtualization solution - kernel module sources for dkms
    ii virtualbox-ext-pack-installer 5.1.26 all VirtualBox extension pack installer.

    Raid is not a backup! Would you go skydiving without a parachute?

    Edited once, last by geaves: Additional information ().

  • I'm going to answer my own thread :D

    So, removed the plugin for virtualbox, apt-clean, reboot.

    From cli dpkg -l scrolled down the list until I found all reference to virtualbox, then proceeded to run sudo apt remove on any reference to virtual box, then dpkg -l left me with one reference: rc virtualbox 5.1.26-dfsg-2 amd64 x86 virtualization solution - base binaries this was the one I had installed!!

    So further research and I found this;

    Remove / Uninstall packages marked ‘rc’ on Debian / Ubuntu.
    While checking the status of packages using dpkg, it is possible to see a ‘rc’ state for some unused packages, this corresponds to:
    r: the package was marked for removal
    c: the configuration files are currently present in the system

    In other words: the package is not completely removed (config files are still present), but not installed anymore (and obviously not used).

    To see a list of packages marked as ‘rc’:

    dpkg --list | grep "^rc"
    Or, to see only package names:

    dpkg --list | grep "^rc" | cut -d " " -f 3
    It is now time to remove all the marked packages (WARNING: All configuration data will be lost!):

    dpkg --list | grep "^rc" | cut -d " " -f 3 | xargs sudo dpkg --purge

    The above solved the final problem, with no reference to virtualbox!! :thumbup:

    Reinstalled the plugin and it's all working....however, I cannot get RDP to work via Remmina, but somewhere on here is a reference to removing VNC from virtualbox so it defaults and uses RDP.....but I can't it!! :cursing:

    I had to do this on the previous install and it worked.

    EDIT: found it here post 25 :thumbsup::thumbsup:

    Raid is not a backup! Would you go skydiving without a parachute?

    Edited once, last by geaves ().

  • Yes, its worked on 4.1 !!
    Many thanks for help!
    I remove virtualbox plugin, than
    dpkg --purge virtualbox
    dpkg --purge virtualbox-dkms

    And then just install virtualbox plugin again. All my VMs are work now.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!