Error while installing: base-installer tar process failed

  • Hi guys,


    I get an error when I try to install OMV on my server. After 100% of "Copying data to disk..." the background turns red and following dialog appears:

    Quote

    [!!] Install the system


    Installation step failed
    An installation step failed. You can try to run the failing item again from the menu, or skip it and choose something else. The failing step is: Install the system


    I've attached the syslog. Also, here are the last few lines of the log, which might describe the problem:


    I've tried to install with the current 3.0.86-amd64 image, as well as 3.0.74. I also checked if the MD5 sums match, they do.


    Picking any other install step from the Debian installer main menu also results in errors.


    I also tried to launch a shell and install Grub as explained in the Wiki, which fails with "error: cannot find a device for /boot/grub"


    Any ideas what to do? I've had OMV installed successfully some while ago. (I guess it was v2)


    The system is a small AMD APU with only a 30GB SSD and the USB drive with the image attached to it

  • Huh. Thats interesting but strange at the same time.


    I gave the installer another try to look if theres anything else I could try, but this time it worked flawlessly. Same image, same USB drive, same settings, same everything.


    Would still be good to know what caused it to fail multiple times.

  • Have you run memtest on the system? I've seen memory issues cause random problems with tar.

    omv 5.6.4 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Didn't think about that, ryecoaaron. I did three passes with memtest 5.01 now. No errors. But thanks for the suggestion!


    I also had the issue earlier, where the server occasionally froze when I was transferring large files to it over the network, but that's a different topic. I just thought it would be an easy fix for both issues, if I could simply swap a malfunctioning memory module.

  • It's not really that "old". I bought it about 3 years ago for the sole purpose of this NAS server. Since then it has ~12.000 power on hours (~1,4 years 24/7) and 140 power cycles, no obvious failures (as far as I can tell). Formatted just twice, once when bought and yesterday, has never been used as storage.
    What leaves me puzzled though, is the amount of LBAs written as low as 860. At a sector size of 512 bytes I'm looking at 440.320 bytes and only 20 LBAs read (10kb). That can't be right.


    It's a Kingston SSDNow S200 30GB btw. Certainly not a top performer, was rather cheap.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!