No WebGui update 2.2.14 to 3.x

  • Hi, I know that this problem has been agitated several times but I didn't find solution.
    Before updating from 2.2.14 to 3 I've uninstalled all plugins and omv extras from webgui.

    After that I put from console: omv-release-upgrade

    When it finished I've reboot WD My cloud and I can access to my shared folder, I can login by console but I can't log in by webgui. When I tried to do that there is no error, page is blank.

    I tried : omv-firstaid after that I have results:

    Traceback (most recent call last):
    File "/usr/sbin/omv-firstaid", line 24, in <module>
    import natsort
    ImportError: No module named 'natsort'

    When I put: dpkg -l | grep openm

    I have:

    iU openmediavault 3.0.89 all
    Open network attached storage solution

    Next steps what I did:

    omv-update - after that I received monit alert:

    I also run:
    apt-get update

    apt-get upgrade - after that I've received information:

    so I've put: apt-get -f install

    next step:

    apt-get autoremove

    next step:

    apt-get -f install

    I do also:
    apt-get -y install nginx

    and I have next monit:

    I tried also this:

    root@MyCloud:~# omv-mkconf nginx
    root@MyCloud:~# omv-mkconf php5fpm
    root@MyCloud:~# service nginx restart
    Restarting nginx: nginx: [emerg] open() "/etc/nginx/fastcgi.conf" failed (2: No such file or directory) in /etc/nginx/sites-enabled/openmediavault-webgui:32
    nginx: configuration file /etc/nginx/nginx.conf test failed
    root@MyCloud:~# service php5-fpm restart

    Thanks for help.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!