Docker bridge port 80 to another, not working?

  • Hi,


    Just installed this to Docker:
    https://hub.docker.com/r/linuxserver/muximux/


    It is Muximux, a site that will gather all the services in one place (sonarr, transmission etc.).


    I did the install in Docker, setting it in Bridge mode, Host IP 0.0.0.0, Host Port 6060 (which is not used by anything else), selected 80/tcp in exposed port and added it.
    Then did the other necessary thing like setup where the config is saved and PUID, PGID.


    It starts without any problems according to the log, but I cannot reach it at 192.168.1.2:6060
    I have tried to setup another bridge for 443 with the same result.


    Do I have to do anything to make the bridge function work?


    As Muximux does seem to use port 80 this is the only way to set it up right? Other plugins have a predefined port like CouchPotato 5050 etc.


    Please help!

  • This is my docker config for muximux, I can connect on port 8099 and my files are at /media/muximux


    docker create \
    --name=muximux --restart=unless-stopped\
    -v /media/muximux:/config \
    -e PGID=378 -e PUID=380 \
    -e TZ=Europe\London \
    -p 8099:80 \
    -linuxserver/muximux

  • Got it running, when I tried it again a few hours later it loaded.


    But it wasn't really what I expected. My thought was that it connected to sonarr and radarr and plex, not just doing an iframe. This means I need to have all my services online with SSL to view them secure, thought I would be able to take them "offline" and make Muximux the frontend.
    Plus I need to manually login to each site Muximux shows, even after logging in to Muximux.


    Is there anything like what I'm thinking about?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!