smb shares not accessible after upgrade to 4.0.11

  • I just did an omv-release-upgrade. At first it seemed that upgrading to 4.0.11-1 was a smooth thing to do.


    But I cannot access my shared folders (mounted on my Win10-machine) anymore. I do always get the error that the password is incorrect...


    My shares are configured. Changed the user-password of my omv-user - did not help.


    Any hints??

  • Worked my way through the 'easy stuff':

    • Disable windows firewall, till you get it working.
      = yes
    • Use ip addresses so dns is not involved.
      = yes


      Doing \\ip-address isn't working. error = wrong password

    • Be sure the workgroup is the same. Set the domain to the workgroup name. =yes


      Workgroup(Win10) = Workgroup(OMV-smb/cifs) = Domain(OMV-network)

    • Check the network type configuration in windows (public, work or home). I think public disables netbios.


      = home

    • Be sure you can ping your OMV from windows and ping windows from OMV.


      = yes

    • Make sure the time is set on both. Windows does weird things if they are not close enough.


      = yes

    • Try to connect to OMV from as many devices as possible, phone, kodi box, ipad, linux etc.


      = enigma2-boxes have access

    • If any connects or at least asks for a user password samba is probably running. If so look at sharing settings and rights on OMV


      = cannot access OMV or any smb-share - everytime it's the error 'wrong password'

    systemctl status smbd:


    ● smbd.service - Samba SMB Daemon
    Loaded: loaded (/lib/systemd/system/smbd.service; enabled; vendor preset: ena
    Active: active (running) since Sat 2017-11-25 15:16:30 CET; 28min ago
    Docs: man:smbd(8)
    man:samba(7)
    man:smb.conf(5)
    Main PID: 16314 (smbd)
    Status: "smbd: ready to serve connections..."
    Tasks: 6 (limit: 4915)
    CGroup: /system.slice/smbd.service
    ├─16314 /usr/sbin/smbd
    ├─16315 /usr/sbin/smbd
    ├─16316 /usr/sbin/smbd
    ├─21793 /usr/sbin/smbd
    ├─21794 /usr/sbin/smbd
    └─21795 /usr/sbin/smbd


    Nov 25 15:16:30 Halut-NAS systemd[1]: Starting Samba SMB Daemon...
    Nov 25 15:16:30 Halut-NAS systemd[1]: smbd.service: Supervising process 16314 wh
    Nov 25 15:16:30 Halut-NAS systemd[1]: Started Samba SMB Daemon.


    systemctl status nmbd:


    ● nmbd.service - Samba NMB Daemon
    Loaded: loaded (/lib/systemd/system/nmbd.service; enabled; vendor preset: ena
    Active: active (running) since Sat 2017-11-25 15:16:31 CET; 28min ago
    Docs: man:nmbd(8)
    man:samba(7)
    man:smb.conf(5)
    Main PID: 16392 (nmbd)
    Status: "nmbd: ready to serve connections..."
    Tasks: 1 (limit: 4915)
    CGroup: /system.slice/nmbd.service
    └─16392 /usr/sbin/nmbd


    Nov 25 15:16:31 Halut-NAS systemd[1]: Starting Samba NMB Daemon...
    Nov 25 15:16:31 Halut-NAS systemd[1]: nmbd.service: Supervising process 16392 wh
    Nov 25 15:16:31 Halut-NAS systemd[1]: Started Samba NMB Daemon.


    ps aux | grep smb:


    root 11108 0.0 0.0 39596 4780 pts/0 T 14:56 0:00 systemctl status smbd
    root 16314 0.0 0.2 318124 15404 ? Ss 15:16 0:00 /usr/sbin/smbd
    root 16315 0.0 0.0 310128 5912 ? S 15:16 0:00 /usr/sbin/smbd
    root 16316 0.0 0.0 310144 5836 ? S 15:16 0:00 /usr/sbin/smbd
    root 21808 0.0 0.0 39596 4876 pts/1 T 15:44 0:00 systemctl status smbd
    root 21978 0.0 0.0 318128 4096 ? S 15:45 0:00 /usr/sbin/smbd
    root 21979 0.0 0.0 318128 4096 ? S 15:45 0:00 /usr/sbin/smbd
    root 21980 0.0 0.0 318128 4096 ? S 15:45 0:00 /usr/sbin/smbd
    root 21998 0.0 0.0 12788 984 pts/1 R+ 15:46 0:00 grep smb


    This are my shares:


    drwxrws---+ 1 root users 70 Okt 18 21:13 @AM
    drwxrws---+ 1 root users 40 Okt 18 20:03 @Backup
    drwxrws---+ 1 root users 46 Okt 31 16:39 @Multimedia
    drwxrws---+ 1 root users 4 Okt 18 20:27 @Save
    drwxrws---+ 1 root users 114 Okt 22 06:40 @VUplus
    drwxrws---+ 1 root users 1326 Nov 11 07:52 @Win_usr



    I did this also:


    1/ run cmd as admin
    2/ sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
    3/ sc.exe config mrxsmb20 start= disabled
    Restart and you are done!


    = No, I'm not done! Nothing changed...


    mounting a share manually by cmd is also getting error 'wrong password'


    I hope somebody knows how to read this outputs as I cannot.

  • I would try:


    omv-mkconf samba
    systemctl restart smbd
    systemctl restart nmbd


    If that doesn't help, try making sure the user's samba password is correct with smbpasswd


    If that doesn't help, post cat /etc/samba/smb.conf

    omv 6.0.5-2 Shaitan | 64 bit | 5.13 proxmox kernel | omvextrasorg 6.0.4 | kvm plugin 6.0
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Unfortunately it didn't help...


    This is my smb.conf:


    #======================= Global Settings =======================
    [global]
    workgroup = WORKGROUP
    server string = %h server
    dns proxy = no
    log level = 0
    syslog = 0
    log file = /var/log/samba/log.%m
    max log size = 1000
    syslog only = yes
    panic action = /usr/share/samba/panic-action %d
    encrypt passwords = true
    passdb backend = tdbsam
    obey pam restrictions = no
    unix password sync = no
    passwd program = /usr/bin/passwd %u
    passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
    pam password change = yes
    socket options = TCP_NODELAY IPTOS_LOWDELAY
    guest account = nobody
    load printers = no
    disable spoolss = yes
    printing = bsd
    printcap name = /dev/null
    unix extensions = yes
    wide links = no
    create mask = 0777
    directory mask = 0777
    use sendfile = yes
    aio read size = 16384
    aio write size = 16384
    null passwords = no
    local master = yes
    time server = yes
    wins support = yes
    #======================= Share Definitions =======================
    [Multimedia]
    path = /srv/dev-disk-by-id-md-name-Halut-NAS-HalutNASData/@Multimedia
    guest ok = no
    read only = no
    browseable = yes
    inherit acls = yes
    inherit permissions = no
    ea support = no
    store dos attributes = no
    vfs objects = recycle
    recycle:repository = .recycle/%U
    recycle:keeptree = yes
    recycle:versions = yes
    recycle:touch = yes
    recycle:directory_mode = 0777
    recycle:subdir_mode = 0700
    recycle:exclude =
    recycle:exclude_dir =
    recycle:maxsize = 0
    printable = no
    create mask = 0664
    force create mode = 0664
    directory mask = 0775
    force directory mode = 0775
    hide special files = yes
    follow symlinks = yes
    hosts allow = 192.168.246.0/24
    hide dot files = yes
    valid users = "thomassc"
    invalid users =
    read list =
    write list = "thomassc"
    [AM]
    path = /srv/dev-disk-by-id-md-name-Halut-NAS-HalutNASData/@AM
    guest ok = no
    read only = no
    browseable = yes
    inherit acls = yes
    inherit permissions = no
    ea support = no
    store dos attributes = no
    vfs objects = recycle
    recycle:repository = .recycle/%U
    recycle:keeptree = yes
    recycle:versions = yes
    recycle:touch = yes
    recycle:directory_mode = 0777
    recycle:subdir_mode = 0700
    recycle:exclude =
    recycle:exclude_dir =
    recycle:maxsize = 0
    printable = no
    create mask = 0664
    force create mode = 0664
    directory mask = 0775
    force directory mode = 0775
    hide special files = yes
    follow symlinks = yes
    hide dot files = yes
    valid users = "thomassc"
    invalid users =
    read list =
    write list = "thomassc"
    [Save]
    path = /srv/dev-disk-by-id-md-name-Halut-NAS-HalutNASData/@Save
    guest ok = no
    read only = no
    browseable = yes
    inherit acls = yes
    inherit permissions = no
    ea support = no
    store dos attributes = no
    vfs objects = recycle
    recycle:repository = .recycle/%U
    recycle:keeptree = yes
    recycle:versions = yes
    recycle:touch = yes
    recycle:directory_mode = 0777
    recycle:subdir_mode = 0700
    recycle:exclude =
    recycle:exclude_dir =
    recycle:maxsize = 0
    printable = no
    create mask = 0664
    force create mode = 0664
    directory mask = 0775
    force directory mode = 0775
    hide special files = yes
    follow symlinks = yes
    hosts allow = 192.168.246.0/24
    hide dot files = yes
    valid users = "thomassc"
    invalid users =
    read list =
    write list = "thomassc"
    [VUplus]
    path = /srv/dev-disk-by-id-md-name-Halut-NAS-HalutNASData/@VUplus
    guest ok = no
    read only = no
    browseable = yes
    inherit acls = yes
    inherit permissions = no
    ea support = no
    store dos attributes = no
    vfs objects = recycle
    recycle:repository = .recycle/%U
    recycle:keeptree = yes
    recycle:versions = yes
    recycle:touch = yes
    recycle:directory_mode = 0777
    recycle:subdir_mode = 0700
    recycle:exclude =
    recycle:exclude_dir =
    recycle:maxsize = 0
    printable = no
    create mask = 0664
    force create mode = 0664
    directory mask = 0775
    force directory mode = 0775
    hide special files = yes
    follow symlinks = yes
    hosts allow = 192.168.246.0/24
    hide dot files = yes
    valid users = "thomassc"
    invalid users =
    read list =
    write list = "thomassc"
    [Win_usr]
    path = /srv/dev-disk-by-id-md-name-Halut-NAS-HalutNASData/@Win_usr
    guest ok = no
    read only = no
    browseable = yes
    inherit acls = yes
    inherit permissions = no
    ea support = no
    store dos attributes = no
    vfs objects = recycle
    recycle:repository = .recycle/%U
    recycle:keeptree = yes
    recycle:versions = yes
    recycle:touch = yes
    recycle:directory_mode = 0777
    recycle:subdir_mode = 0700
    recycle:exclude =
    recycle:exclude_dir =
    recycle:maxsize = 0
    printable = no
    create mask = 0664
    force create mode = 0664
    directory mask = 0775
    force directory mode = 0775
    hide special files = yes
    follow symlinks = yes
    hosts allow = 192.168.246.0/24
    hide dot files = yes
    valid users = "thomassc"
    invalid users =
    read list =
    write list = "thomassc"
    [OMV-Data]
    path = /srv/dev-disk-by-label-OMV-Data
    guest ok = no
    read only = no
    browseable = yes
    inherit acls = yes
    inherit permissions = no
    ea support = no
    store dos attributes = no
    vfs objects = recycle
    recycle:repository = .recycle/%U
    recycle:keeptree = yes
    recycle:versions = yes
    recycle:touch = yes
    recycle:directory_mode = 0777
    recycle:subdir_mode = 0700
    recycle:exclude =
    recycle:exclude_dir =
    recycle:maxsize = 0
    printable = no
    create mask = 0664
    force create mode = 0664
    directory mask = 0775
    force directory mode = 0775
    hide special files = yes
    follow symlinks = yes
    hosts allow = 192.168.246.0/24
    hide dot files = yes
    valid users = "thomassc","thomassc-docker"
    invalid users =
    read list =
    write list = "thomassc","thomassc-docker"



    I just upgraded to 4.0.12. Now the NAS cannot be reached from windows (Error = Network not activated).
    smbd and nmbd are running!

  • What is the IP address of your Windows machine? I assume your windows username is thomassc?

    omv 6.0.5-2 Shaitan | 64 bit | 5.13 proxmox kernel | omvextrasorg 6.0.4 | kvm plugin 6.0
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Try changing your hosts allow field on all shares to 192.168.246. (notice trailing period) or leaving it blank all together.

    omv 6.0.5-2 Shaitan | 64 bit | 5.13 proxmox kernel | omvextrasorg 6.0.4 | kvm plugin 6.0
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Deleted hosts allow setting for all shares.


    I still cannot reach or connect to my mounted shares - 'no network' error.


    But it seems to be up... ;)

  • No need to keep posting smbd and nmbd status output. That is not the problem. All I can think is that it is some weird authentication problem. You could try enabling debug logging in settings tab and enable logging for a share or two and see what is in the logs.

    omv 6.0.5-2 Shaitan | 64 bit | 5.13 proxmox kernel | omvextrasorg 6.0.4 | kvm plugin 6.0
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • This is my syslog after OMV-reboot and a try to access the smb share:


    Nov 26 18:13:23 Halut-NAS kernel: [ 6.761597] r8169 0000:03:00.0 eth1: link up
    Nov 26 18:13:24 Halut-NAS ntpd[1229]: Listen normally on 4 eth1 192.168.246.231:123
    Nov 26 18:13:24 Halut-NAS nmbd[1262]: [2017/11/26 18:13:24.237736, 0] ../source3/nmbd/nmbd_namequery.c:109(query_name_response)
    Nov 26 18:13:24 Halut-NAS nmbd[1262]: query_name_response: Multiple (2) responses received for a query on subnet 192.168.246.231 for name WORKGROUP<1d>.
    Nov 26 18:13:24 Halut-NAS nmbd[1262]: This response was from IP 192.168.246.201, reporting an IP address of 192.168.246.201.
    Nov 26 18:13:24 Halut-NAS systemd[1]: Mounted /srv/dev-disk-by-id-md-name-Halut-NAS-HalutNASData.
    Nov 26 18:13:24 Halut-NAS systemd[1]: Mounting /sharedfolders/AM...
    Nov 26 18:13:24 Halut-NAS systemd[1]: Mounting /export/Multimedia...
    Nov 26 18:13:24 Halut-NAS systemd[1]: Mounting /sharedfolders/VUplus...
    Nov 26 18:13:24 Halut-NAS systemd[1]: Mounting /sharedfolders/Multimedia...
    Nov 26 18:13:24 Halut-NAS systemd[1]: Mounting /sharedfolders/Save...
    Nov 26 18:13:24 Halut-NAS systemd[1]: Mounting /sharedfolders/Win_usr...
    Nov 26 18:13:24 Halut-NAS systemd[1]: Mounting /export/Win_usr...
    Nov 26 18:13:24 Halut-NAS systemd[1]: Mounting /export/AM...
    Nov 26 18:13:24 Halut-NAS systemd[1]: Mounting /export/Save...
    Nov 26 18:13:24 Halut-NAS systemd[1]: Mounting /export/VUplus...
    Nov 26 18:13:24 Halut-NAS systemd[1]: Mounting /sharedfolders/Backup...
    Nov 26 18:13:24 Halut-NAS systemd[1]: Mounted /export/Win_usr.
    Nov 26 18:13:24 Halut-NAS systemd[1]: Mounted /export/VUplus.
    Nov 26 18:13:24 Halut-NAS systemd[1]: Mounted /export/Save.
    Nov 26 18:13:24 Halut-NAS systemd[1]: Mounted /export/AM.
    Nov 26 18:13:24 Halut-NAS systemd[1]: Mounted /export/Multimedia.
    Nov 26 18:13:24 Halut-NAS systemd[1]: Mounted /sharedfolders/Win_usr.
    Nov 26 18:13:24 Halut-NAS systemd[1]: Mounted /sharedfolders/Backup.
    Nov 26 18:13:24 Halut-NAS systemd[1]: Mounted /sharedfolders/Multimedia.
    Nov 26 18:13:24 Halut-NAS systemd[1]: Mounted /sharedfolders/VUplus.
    Nov 26 18:13:24 Halut-NAS systemd[1]: Mounted /sharedfolders/Save.
    Nov 26 18:13:24 Halut-NAS systemd[1]: Mounted /sharedfolders/AM.
    Nov 26 18:13:24 Halut-NAS systemd[1]: Startup finished in 2.919s (kernel) + 5.133s (userspace) = 8.052s.
    Nov 26 18:13:52 Halut-NAS monit[1231]: 'Halut-NAS' Monit 5.20.0 started
    Nov 26 18:14:23 Halut-NAS smbd[1298]: [2017/11/26 18:14:23.239994, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 26 18:14:23 Halut-NAS smbd[1298]: Closing idle connection
    Nov 26 18:14:23 Halut-NAS smbd[1301]: [2017/11/26 18:14:23.978385, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 26 18:14:23 Halut-NAS smbd[1301]: Closing idle connection
    Nov 26 18:14:24 Halut-NAS smbd[1302]: [2017/11/26 18:14:24.037156, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 26 18:14:24 Halut-NAS smbd[1302]: Closing idle connection



    192.168.246.201 is my router...

  • have you tried this, what i upper suggestet ?


    "try from command line your (omv-) debian nas from a not admin acout
    a connect with smbclient and use account and passwort from your windows machine"


    also i remember, that i had to add user to samba :


    https://www.cyberciti.biz/faq/…ser-to-a-samba-smb-share/


    # on debian side
    smbpasswd -U USER1
    smbpasswd -U USER2


    # on windows side
    net use Y: \\192.168.178.36\Daten "USER1" /User:j3455-itx\USER1
    net use Z: \\192.168.178.36\Daten "USER2" /User:j3455-itx\USER2

  • I checked the password on the NAS. I also added the user to the samba-group. Worked this way with OMV3.


    'net use' gave the error 'wrong password' just as connection within the win-explorer did.


    Right now - after upgrading to 4.0.12 - there is no 'NAS-Network' shown in Windows 10 to connect with.


    But I do have a lot of smbd-messages within the syslog - this is just the last 30 minutes:


    Nov 27 15:30:01 Halut-NAS CRON[7491]: (root) CMD (/usr/sbin/omv-mkgraph >/dev/null 2>&1)
    Nov 27 15:30:01 Halut-NAS CRON[7492]: (root) CMD (/usr/sbin/omv-mkrrdgraph >/dev/null 2>&1)
    Nov 27 15:30:32 Halut-NAS smbd[7480]: [2017/11/27 15:30:32.271242, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 27 15:30:32 Halut-NAS smbd[7480]: Closing idle connection
    Nov 27 15:31:32 Halut-NAS smbd[7623]: [2017/11/27 15:31:32.328049, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 27 15:31:32 Halut-NAS smbd[7623]: Closing idle connection
    Nov 27 15:32:32 Halut-NAS smbd[7640]: [2017/11/27 15:32:32.397395, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 27 15:32:32 Halut-NAS smbd[7640]: Closing idle connection
    Nov 27 15:33:32 Halut-NAS smbd[7657]: [2017/11/27 15:33:32.467168, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 27 15:33:32 Halut-NAS smbd[7657]: Closing idle connection
    Nov 27 15:34:32 Halut-NAS smbd[7674]: [2017/11/27 15:34:32.536891, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 27 15:34:32 Halut-NAS smbd[7674]: Closing idle connection
    Nov 27 15:35:32 Halut-NAS smbd[7691]: [2017/11/27 15:35:32.591851, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 27 15:35:32 Halut-NAS smbd[7691]: Closing idle connection
    Nov 27 15:36:32 Halut-NAS smbd[7708]: [2017/11/27 15:36:32.625845, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 27 15:36:32 Halut-NAS smbd[7708]: Closing idle connection
    Nov 27 15:37:32 Halut-NAS smbd[7725]: [2017/11/27 15:37:32.669300, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 27 15:37:32 Halut-NAS smbd[7725]: Closing idle connection
    Nov 27 15:38:32 Halut-NAS smbd[7742]: [2017/11/27 15:38:32.726120, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 27 15:38:32 Halut-NAS smbd[7742]: Closing idle connection
    Nov 27 15:39:00 Halut-NAS systemd[1]: Starting Clean php session files...
    Nov 27 15:39:00 Halut-NAS systemd[1]: Started Clean php session files.
    Nov 27 15:39:01 Halut-NAS CRON[7831]: (root) CMD ( [ -x /usr/lib/php/sessionclean ] && if [ ! -d /run/systemd/system ]; then /usr/lib/php/sessionclean; fi)
    Nov 27 15:39:01 Halut-NAS CRON[7832]: (root) CMD ( [ -x /usr/lib/php5/sessionclean ] && /usr/lib/php5/sessionclean)
    Nov 27 15:39:32 Halut-NAS smbd[7759]: [2017/11/27 15:39:32.795750, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 27 15:39:32 Halut-NAS smbd[7759]: Closing idle connection
    Nov 27 15:40:32 Halut-NAS smbd[7841]: [2017/11/27 15:40:32.865396, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 27 15:40:32 Halut-NAS smbd[7841]: Closing idle connection
    Nov 27 15:41:32 Halut-NAS smbd[7858]: [2017/11/27 15:41:32.934639, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 27 15:41:32 Halut-NAS smbd[7858]: Closing idle connection
    Nov 27 15:42:33 Halut-NAS smbd[7875]: [2017/11/27 15:42:33.003985, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 27 15:42:33 Halut-NAS smbd[7875]: Closing idle connection
    Nov 27 15:43:24 Halut-NAS smbd[1264]: [2017/11/27 15:43:24.876241, 2] ../source3/smbd/server.c:794(remove_child_pid)
    Nov 27 15:43:24 Halut-NAS smbd[1264]: Could not find child 7905 -- ignoring
    Nov 27 15:43:33 Halut-NAS smbd[7892]: [2017/11/27 15:43:33.073849, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 27 15:43:33 Halut-NAS smbd[7892]: Closing idle connection
    Nov 27 15:44:33 Halut-NAS smbd[7911]: [2017/11/27 15:44:33.090286, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 27 15:44:33 Halut-NAS smbd[7911]: Closing idle connection
    Nov 27 15:45:01 Halut-NAS CRON[7939]: (root) CMD (/usr/sbin/omv-mkrrdgraph >/dev/null 2>&1)
    Nov 27 15:45:01 Halut-NAS CRON[7940]: (root) CMD (/usr/sbin/omv-mkgraph >/dev/null 2>&1)
    Nov 27 15:45:33 Halut-NAS smbd[7928]: [2017/11/27 15:45:33.160071, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 27 15:45:33 Halut-NAS smbd[7928]: Closing idle connection
    Nov 27 15:46:33 Halut-NAS smbd[8071]: [2017/11/27 15:46:33.205921, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 27 15:46:33 Halut-NAS smbd[8071]: Closing idle connection
    Nov 27 15:47:33 Halut-NAS smbd[8088]: [2017/11/27 15:47:33.267854, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 27 15:47:33 Halut-NAS smbd[8088]: Closing idle connection
    Nov 27 15:48:33 Halut-NAS smbd[8105]: [2017/11/27 15:48:33.337051, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 27 15:48:33 Halut-NAS smbd[8105]: Closing idle connection
    Nov 27 15:49:33 Halut-NAS smbd[8122]: [2017/11/27 15:49:33.371230, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 27 15:49:33 Halut-NAS smbd[8122]: Closing idle connection
    Nov 27 15:50:33 Halut-NAS smbd[8139]: [2017/11/27 15:50:33.441947, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 27 15:50:33 Halut-NAS smbd[8139]: Closing idle connection
    Nov 27 15:51:33 Halut-NAS smbd[8156]: [2017/11/27 15:51:33.461748, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 27 15:51:33 Halut-NAS smbd[8156]: Closing idle connection
    Nov 27 15:52:33 Halut-NAS smbd[8173]: [2017/11/27 15:52:33.531588, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 27 15:52:33 Halut-NAS smbd[8173]: Closing idle connection
    Nov 27 15:53:33 Halut-NAS smbd[8190]: [2017/11/27 15:53:33.585133, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 27 15:53:33 Halut-NAS smbd[8190]: Closing idle connection
    Nov 27 15:54:33 Halut-NAS smbd[8207]: [2017/11/27 15:54:33.650784, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 27 15:54:33 Halut-NAS smbd[8207]: Closing idle connection
    Nov 27 15:55:33 Halut-NAS smbd[8224]: [2017/11/27 15:55:33.716449, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 27 15:55:33 Halut-NAS smbd[8224]: Closing idle connection
    Nov 27 15:56:33 Halut-NAS smbd[8241]: [2017/11/27 15:56:33.743857, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 27 15:56:33 Halut-NAS smbd[8241]: Closing idle connection
    Nov 27 15:57:33 Halut-NAS smbd[8258]: [2017/11/27 15:57:33.753885, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 27 15:57:33 Halut-NAS smbd[8258]: Closing idle connection
    Nov 27 15:58:24 Halut-NAS smbd[1264]: [2017/11/27 15:58:24.905863, 2] ../source3/smbd/server.c:794(remove_child_pid)
    Nov 27 15:58:24 Halut-NAS smbd[1264]: Could not find child 8288 -- ignoring
    Nov 27 15:58:33 Halut-NAS smbd[8275]: [2017/11/27 15:58:33.803855, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 27 15:58:33 Halut-NAS smbd[8275]: Closing idle connection
    Nov 27 15:59:33 Halut-NAS smbd[8290]: [2017/11/27 15:59:33.866488, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 27 15:59:33 Halut-NAS smbd[8290]: Closing idle connection
    Nov 27 16:00:01 Halut-NAS CRON[8345]: (root) CMD (/usr/sbin/omv-mkgraph >/dev/null 2>&1)
    Nov 27 16:00:01 Halut-NAS CRON[8347]: (root) CMD (/usr/sbin/omv-mkrrdgraph >/dev/null 2>&1)
    Nov 27 16:00:33 Halut-NAS smbd[8306]: [2017/11/27 16:00:33.877810, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 27 16:00:33 Halut-NAS smbd[8306]: Closing idle connection
    Nov 27 16:01:33 Halut-NAS smbd[9126]: [2017/11/27 16:01:33.947701, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 27 16:01:33 Halut-NAS smbd[9126]: Closing idle connection
    Nov 27 16:02:34 Halut-NAS smbd[9152]: [2017/11/27 16:02:34.019332, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 27 16:02:34 Halut-NAS smbd[9152]: Closing idle connection
    Nov 27 16:03:34 Halut-NAS smbd[9177]: [2017/11/27 16:03:34.089026, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 27 16:03:34 Halut-NAS smbd[9177]: Closing idle connection
    Nov 27 16:04:34 Halut-NAS smbd[9202]: [2017/11/27 16:04:34.127855, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 27 16:04:34 Halut-NAS smbd[9202]: Closing idle connection
    Nov 27 16:05:00 Halut-NAS systemd[1]: Started Run anacron jobs.
    Nov 27 16:05:00 Halut-NAS anacron[9240]: Anacron 2.3 started on 2017-11-27
    Nov 27 16:05:00 Halut-NAS anacron[9240]: Normal exit (0 jobs run)
    Nov 27 16:05:00 Halut-NAS systemd[1]: anacron.timer: Adding 2min 27.183165s random time.
    Nov 27 16:05:34 Halut-NAS smbd[9227]: [2017/11/27 16:05:34.166363, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 27 16:05:34 Halut-NAS smbd[9227]: Closing idle connection

  • I'll check your smb.conf against mine


    differences:


    mine (simplier) has:


    [global]
    ....
    time server = no
    wins support = no


    [share XXXX]
    path = /srv/dev-disk-by-id-md-name-Halut-NAS-HalutNASData/@Multimedia // is the @ allowed ?, i'm not an expert
    ...
    vfs objects = // no recylce object
    ...
    // no -> hosts allow = 192.168.246.0/24 -> remove it for tests

  • I already turned time server and WINS off, just as I removed the setting for hosts allow - no effect.


    This @folder are my btrfs-subvolumes. No problem with OMV3

  • One interesting thing I haven't thought of...


    Is this problem because of me using 'omv-release-upgrade'?


    If there is no problem with installing OMV 4 - as there is 4.0.9 available as an image - I would think about doing it, as I have to install OMV3 or OMV4 anyway, if there is no solution...



    ...this are the latest messages:


    Nov 28 13:41:21 Halut-NAS smbd[18350]: [2017/11/28 13:41:21.813823, 1] ../lib/param/loadparm.c:1729(lpcfg_do_global_parameter)
    Nov 28 13:41:21 Halut-NAS smbd[18350]: WARNING: The "syslog" option is deprecated
    Nov 28 13:41:21 Halut-NAS smbd[18350]: [2017/11/28 13:41:21.813889, 1] ../lib/param/loadparm.c:1729(lpcfg_do_global_parameter)
    Nov 28 13:41:21 Halut-NAS smbd[18350]: WARNING: The "syslog only" option is deprecated
    Nov 28 13:41:21 Halut-NAS smbd[18350]: [2017/11/28 13:41:21.814197, 1] ../lib/param/loadparm.c:1729(lpcfg_do_global_parameter)
    Nov 28 13:41:21 Halut-NAS smbd[18350]: WARNING: The "null passwords" option is deprecated
    Nov 28 13:41:21 Halut-NAS smbd[18350]: [2017/11/28 13:41:21.814245, 2] ../source3/param/loadparm.c:2685(lp_do_section)
    Nov 28 13:41:21 Halut-NAS smbd[18350]: Processing section "[Backup]"
    Nov 28 13:41:21 Halut-NAS smbd[18350]: [2017/11/28 13:41:21.814686, 2] ../source3/param/loadparm.c:2685(lp_do_section)
    Nov 28 13:41:21 Halut-NAS smbd[18350]: Processing section "[Multimedia]"
    Nov 28 13:41:21 Halut-NAS smbd[18350]: [2017/11/28 13:41:21.815134, 2] ../source3/param/loadparm.c:2685(lp_do_section)
    Nov 28 13:41:21 Halut-NAS smbd[18350]: Processing section "[AM]"
    Nov 28 13:41:21 Halut-NAS systemd[1]: smbd.service: Supervising process 18352 which is not our child. We'll most likely not notice when it exits.
    Nov 28 13:41:21 Halut-NAS smbd[18350]: [2017/11/28 13:41:21.815579, 2] ../source3/param/loadparm.c:2685(lp_do_section)
    Nov 28 13:41:21 Halut-NAS smbd[18350]: Processing section "[Save]"
    Nov 28 13:41:21 Halut-NAS smbd[18350]: [2017/11/28 13:41:21.816025, 2] ../source3/param/loadparm.c:2685(lp_do_section)
    Nov 28 13:41:21 Halut-NAS smbd[18350]: Processing section "[VUplus]"
    Nov 28 13:41:21 Halut-NAS smbd[18350]: [2017/11/28 13:41:21.816480, 2] ../source3/param/loadparm.c:2685(lp_do_section)
    Nov 28 13:41:21 Halut-NAS smbd[18350]: Processing section "[Win_usr]"
    Nov 28 13:41:21 Halut-NAS smbd[18350]: [2017/11/28 13:41:21.816932, 2] ../source3/param/loadparm.c:2685(lp_do_section)
    Nov 28 13:41:21 Halut-NAS smbd[18350]: Processing section "[OMV-Data]"
    Nov 28 13:41:21 Halut-NAS smbd[18350]: [2017/11/28 13:41:21.817827, 2] ../source3/lib/interface.c:345(add_interface)
    Nov 28 13:41:21 Halut-NAS smbd[18350]: added interface eth1 ip=192.168.246.231 bcast=192.168.246.255 netmask=255.255.255.0
    Nov 28 13:41:21 Halut-NAS smbd[18350]: [2017/11/28 13:41:21.817914, 1] ../source3/profile/profile_dummy.c:30(set_profile_level)
    Nov 28 13:41:21 Halut-NAS smbd[18350]: INFO: Profiling support unavailable in this build.
    Nov 28 13:41:21 Halut-NAS smbd[18352]: [2017/11/28 13:41:21.833636, 0] ../lib/util/become_daemon.c:124(daemon_ready)
    Nov 28 13:41:21 Halut-NAS smbd[18352]: STATUS=daemon 'smbd' finished starting up and ready to serve connections
    Nov 28 13:41:21 Halut-NAS systemd[1]: Started Samba SMB Daemon.
    Nov 28 13:41:21 Halut-NAS smbd[18352]: [2017/11/28 13:41:21.833829, 2] ../source3/smbd/server.c:1382(smbd_parent_loop)
    Nov 28 13:41:21 Halut-NAS smbd[18352]: waiting for connections
    Nov 28 13:42:24 Halut-NAS smbd[18359]: [2017/11/28 13:42:24.728331, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 28 13:42:24 Halut-NAS smbd[18357]: [2017/11/28 13:42:24.728331, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 28 13:42:24 Halut-NAS smbd[18357]: Closing idle connection
    Nov 28 13:42:24 Halut-NAS smbd[18359]: Closing idle connection
    Nov 28 13:42:24 Halut-NAS smbd[18358]: [2017/11/28 13:42:24.785205, 2] ../source3/smbd/process.c:2877(deadtime_fn)
    Nov 28 13:42:24 Halut-NAS smbd[18358]: Closing idle connection



    I don't know how to read this but I would guess it is samba that is kind of broken...?

  • I started with a clean install of debian 9 stretch
    after that I added the omv 4 arrakis repos to /etc/apt/*
    and installed omv4


    I've had also some problems with connecting my win 7 client to samba,
    not sure, but I think I've reinstalled samba again from the debian console


    then I've added samba users with smbpasswd -U USERx

  • Installed OMV4 from scratch = still no samba share to connect to from Windows 10 (error: wrong password)


    Installed Rockstor just to test it = samba share can be mounted from Windows 10


    Do I really have to go back to OMV3??

  • Installed Ubuntu Server 16.04.3LTS = some shares could be accessed, some don't. Couldn't figure out what is the problem with activating/deactivating smb protocol 1 on Win10 or changing the permissions in smb.conf.
    Updated Server 16.04.3 to 17.10 = no share could be accessed.


    Installed OMV3 again and magic happened - all shares can be accessed (read, write) on Win10.


    I don't know what M$ did wrong - as there is to read all the time that M$ configured SMB/CIFS wrong. But why is it working with samba on OMV3? Where is the difference? Why not use the configuration and file version OMV3 uses?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!