[SOLVED] NFS share not visible to Kodi (or anything else)

  • I think you are right that the client has some issues. I have just tried connecting with Kodi running on my Android phone and ... success! I can browse the test share and play its media files.

    I did make one important change to the OMV share setup. In my first post I said that I felt that there was something obvious that I was missing. I had been using the server IP address when configuring the NFS share, not the client IP. Obvious, and a ridiculous mistake, but that's what happens sometimes. [facepalm]

    The correct configuration of the NFS share was (client IP) with options read/write and subtree_check,insecure. Using this, I can browse the share and play media from it using Kodi on Android. However, I still cannot see or connect to the share from the RPi running Kodi so my original problem (and reason for this post) remain unsolved. I cannot even browse NFS generally. Clicking on that item does nothing on the RPi, yet on Android I see a list of available NFS shares from which I can choose.

    This puzzles me because the share is set up to accept a client with a specific IP address ( yet the Android client with dynamic IP address can connect without trouble.

  • Solved, and rather simply, too.

    Kodi on Arch Linux has a dependency on libnfs which is not installed by default. This explains the inability of the RPi to browse NFS shares. Kodi on Android has no such dependency, or at least has built-in NFS support.

    More information is available here. This post on the arch linux forum was also very helpful.

    My problem was a missing library in Kodi, and not a configuration problem with OMV. And that only took 25 posts to work out. :rolleyes:

    Thank you all for your help, especially subzero79. :saint:

    I've updated this thread to show SOLVED and edited the first post to include the solution.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!