solved: NFS Shares erst nach Service restart sichtbar

  • Hy,


    ich habe seit dem Upgrad von 3.x auf 4.x massive Probleme mit NFS Shares.
    Diese werden erst nach einer Änderung in den NFS Freigaben der GUI sichtbar bzw. nutzbar.


    Nach einem reboot der OMV kein NFS Shares aktiv. SMB etc. funktioniert einwandfrei.
    Hab die Freigegebenen Verzeichnisse mehrmals gelöscht, die Rechte zurückgesetzt, Vollzugriff etc. alles ohne dauerhaften Erfolg.


    das export Verzeichnis sieht nach dem reboot so aus


    Code
    drwxr-xr-x 5 root root 28672 Mai 1 18:27 .
    drwxr-xr-x 27 root root 4096 Apr 22 21:04 ..
    drwx------ 2 root root 4096 Mai 1 13:48 Filme
    drwx------ 2 root root 4096 Mai 1 18:27 Serien
    drwx------ 2 root root 4096 Mai 1 18:06 Test



    der NFS Service zeigt folgendes



    ich hab dann mal ein neuen NFS Share hinzugefügt und dann kommt das


    Code
    omv:/export# ls -la
    insgesamt 1800
    drwxr-xr-x 6 root root 28672 Mai 1 19:08 .
    drwxr-xr-x 27 root root 4096 Apr 22 21:04 ..
    drwxrwsrwx+ 865 root users 57344 Apr 27 00:10 Filme
    drwxrwsrwx 2 root users 1720320 Mai 1 00:06 Musik
    drwxrwsrwx 59 root users 4096 Apr 16 21:52 Serien
    drwxrwsrw-+ 2 root users 4096 Mai 1 18:03 Test

    also so wie es auch nach einem reboot sein sollte und ich kann die Shares auch mounten jetzt. Nach einem reboot ist wieder alls wie vorher X(


    Hab jetzt keine Idee mehr nach was ich suchen soll


    Jemand eine Idee ?


    Anakim


    im Log steht dann übrigens folgendes



  • i think it seems like ok


  • No, it does not look valid. The hostnames or IPs that are allowed to access the shares are missing.
    Systemd has mentioned that in one of your first posts.

    ok .. i try it with IP .. but i thought it was not important or doesn't help .. i read something else on Google Search.


    ... sorry it doesn't help. Same error



    Code
    Mai 02 20:18:21 omv avahi-daemon[399]: Service "omv - NFS - Test" (/services/nfs-Test.service) successfully established.
    Mai 02 20:18:21 omv avahi-daemon[399]: Service "omv - NFS - Serien" (/services/nfs-Serien.service) successfully established.
    Mai 02 20:18:21 omv avahi-daemon[399]: Service "omv - NFS - Musik" (/services/nfs-Musik.service) successfully established.
    Mai 02 20:18:21 omv avahi-daemon[399]: Service "omv - NFS - Filme" (/services/nfs-Filme.service) successfully established.


    Code
    Mai 02 20:18:23 omv nfsdcltrack[875]: Failed to init database: -13
    Mai 02 20:18:23 omv kernel: NFSD: Using /var/lib/nfs/v4recovery as the NFSv4 state recovery directory
    Mai 02 20:18:24 omv systemd[1]: Started NFS server and services.
    Mai 02 20:18:24 omv systemd[1]: Reached target Remote File Systems (Pre).
    Mai 02 20:18:24 omv kernel: NFSD: starting 90-second grace period (net f0000099)
    Mai 02 20:18:24 omv systemd[1]: Reached target Remote File Systems.

    ?(

  • my Problem solved !
    after omv Update 4.1.6 the export Directory works


    thx
    for help


    OMG .. i have the Problem again.
    After Start or reboot the NFS shares not working..


    See my first post.. directories empty:-((
    When i add or delete a new nfs share it works fine?!? I think the deamon works not correctly. OMV do something when i reconfigure nfs what the omv Start not do


    ? Someone an idea?


    Thx

  • Habe genau das selbe Problem :-( wenn ich eine Freigabe wegnehme oder hinzufüge funktionieren die mounts wieder. ( mount -a ) funktioniert bei mir leider nicht . Glaube aber das es mit dem union filesystem zusammen hängt . Wenn ich die Freigabe direkt auf die Festplatte mache und nicht auf den pool kann ich nach dem reboot darauf zugreifen .

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!