[SOLVED] Used omv-firstaid and yet can't login

  • I've tried restarting, used omv-firstaid and yet everytime I try to login it says "Incorrect username or password".


    The strange about this is that I didn't restarted the machine, and I believe it didn't restart itself, I was by it's side all the time and it didn't beep. I used it like 2 hours ago and it worked flawlessly, now it's just not letting me log in. Used different browsers, but it didn't work anyways.


    What else can I do?


    Thank y'all!

  • What did you use in ovm-firstaid? If you did the reset Web-GUI password your password to login to the web-gui should be:


    userid: admin
    password: openmediavault


    Can you sill log into root? Tell me more.

  • It actually prompted me to type a new password. But openmediavault didn't worked. I tried simple passwords, 'cos my main passwords involve letters, special characters and numbers, but only numbers or letters didn't work. I was enjoying the hack of it... now I'm sad. I had almost everything set on the server ;(



  • Quote from "tekkbebe"

    Yes, use the password that you put in. I gave you old instructions. I forgot you could put in your own password now.


    Can you still login as root user via ssh?


    Yeah, all services are working like they should, even SABnzbd, Sickbeard, Couchpotato, OpenVPN, Transmission... only WebGUI that's not letting me log in or commit the password change.


    Hum! Can the source of the problem be the MySQL PlugIn that I installed yesterday? I have also installed PHP Modules, php5-curl php-pdo and probably php5-gd... but everything worked fine, even after I restarted apache2 and mysql. It was like 4:00PM here when I installed those things and I kept using the panel without any problem, for several hours I kept logging in and out WebGUI, even changed computers, left my work and connected from my PC on the same LAN OMV is. But when it was close to midnight I noticed this problem.


    Stupid me... I have installed OwnClowd using their php file that sets everything on the server... I removed it, like in a hardcore way, just deleted owncloud directory inside the server... But I don't think that could be the cause, can it be? Where OpenMediaVault saves it's password? is it inside apaches web configuration or is it inside a XML file?


    Just hope I don't need to re-install everything... I know that the storage I have will be re-mounted without any hustle, but re-configuring OMV will be a pain...

  • Quote from "tekkbebe"

    Did you run a rsync job? I'm wondering if something is wrong with php with the mods you did. The password is encrypted and stored in /etc/shadow.


    A rsync job? I have no idea, probably not. I can remove'em all, if they're not needed for openmediavault to work. I have then installed so I could use OwnCloud, that I regreted and removed. I can get rid of MySQL also, if I find a way to properly remove it using SSH. Is apt-get remove the solution?


    I indeed set a USB Backup job, but the folder to get backup'ed have no files inside it, so pretty much nothing was copied. And not a single system file is involved in any backup.

  • Quote from "tekkbebe"

    The backup job may have got saved in the wrong place. Do this command:


    df -h


    Give me the results..


    Here it goes. I think the USB HDD (1.5 or 2 TB) drive is not listed... but I restarted the machine with the reboot command through putty, so it's probably waiting for me to remount it. Is there a command to list all drives, even those not mounted? Or this was it?


    Code
    root@Savannah:~# df -h
    Sist. Arq.            Size  Used Avail Use% Montado em
    /dev/sdd1              57G  2,4G   51G   5% /
    tmpfs                 3,5G     0  3,5G   0% /lib/init/rw
    udev                  3,5G  220K  3,5G   1% /dev
    tmpfs                 3,5G     0  3,5G   0% /dev/shm
    /dev/md127            8,1T  1,2T  6,6T  15% /media/16a3b191-9594-46ec-9f0a-c1c292676dfa
    root@Savannah:~#
  • Well that is not the problem. When the system disk is full you cannot log into the web-gui. For Owncloud Ryecoaron made a script to install it. So I would use his script. Don't mess with anything yet. Let us think about this some more.

  • Quote from "tekkbebe"

    Well that is not the problem. When the system disk is full you cannot log into the web-gui. For Owncloud Ryecoaron made a script to install it. So I would use his script. Don't mess with anything yet. Let us think about this some more.


    Oh, I hard removed OwnCloud (rm -R) But it was like 5 hours before the problem appear, I logged in and out lots of times after that, from two different locations. I'm not messing with nothing right now, just using the services that are properly working. I mean, everything else is working but WebGUI.


    Can it be apache2 trying to find a web that doesn't exist anymore? Do you want me to paste apache2 configuration here? If so, point me the direction and I'll do that ;)


    Thank you very much for your time, attention and support.

    • Official Post

    What is the output of:

    Code
    cat /etc/apache2/ports.conf
    cat /etc/apache2/openmediavault-webgui.d/default.conf
    cat /etc/apache2/sites-enabled/openmediavault-webgui
    dpkg -l | grep owncloud

    omv 6.1.0-1 Shaitan | 64 bit | 5.19 proxmox kernel | plugins :: omvextrasorg 6.1.1 | kvm 6.2.5 | mergerfs 6.3.3 | zfs 6.0.12
    omv-extras.org plugins source code and issue tracker - github


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • Quote from "ryecoaaron"

    What is the output of:

    Code
    cat /etc/apache2/ports.conf
    cat /etc/apache2/openmediavault-webgui.d/default.conf
    cat /etc/apache2/sites-enabled/openmediavault-webgui
    dpkg -l | grep owncloud


    cat /etc/apache2/ports.conf

    Code
    root@Savannah:~# cat /etc/apache2/ports.conf
    NameVirtualHost *:8082
    Listen 8082
    
    
    root@Savannah:~#


    cat /etc/apache2/openmediavault-webgui.d/default.conf


    cat /etc/apache2/sites-enabled/openmediavault-webgui

    Code
    root@Savannah:~# cat /etc/apache2/sites-enabled/openmediavault-webgui
    <VirtualHost *:8082>
        Include /etc/apache2/openmediavault-webgui.d/*.conf
        SSLEngine off
    </Virtualhost>
    root@Savannah:~#


    dpkg -l | grep owncloud

    Code
    root@Savannah:~# dpkg -l | grep owncloud
    root@Savannah:~#


    I used the setup-owncloud.php file to setup owncloud.


    setup-owncloud.php

    • Official Post

    Your server is set for port 8082. Can you access the server at:


    Code
    http://omv-ip-address:8082

    omv 6.1.0-1 Shaitan | 64 bit | 5.19 proxmox kernel | plugins :: omvextrasorg 6.1.1 | kvm 6.2.5 | mergerfs 6.3.3 | zfs 6.0.12
    omv-extras.org plugins source code and issue tracker - github


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • Quote from "ryecoaaron"

    Your server is set for port 8082. Can you access the server at:


    Code
    http://omv-ip-address:8082


    I have updated some information on my reply above, doesn't know if it could help something.


    I can access the WebGUI locally and remotely, I just can't login.

    • Official Post

    Ok. How about:

    Code
    ls -al /var/www/opemediavault/
    cat /etc/passwd | grep admin:

    omv 6.1.0-1 Shaitan | 64 bit | 5.19 proxmox kernel | plugins :: omvextrasorg 6.1.1 | kvm 6.2.5 | mergerfs 6.3.3 | zfs 6.0.12
    omv-extras.org plugins source code and issue tracker - github


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!