Can't get OpenVPN to work with OMV 4

  • I previously had OpenVPN working on OMV 3 but I lost it when I upgraded to OMV 4. I recently saw that the plugin has been updated so I installed it and tried to set it up with the same settings as before, but I can't get my phone to connect to it.


    I used the settings found in this post.


    Here they are:


    Port1194
    ProtocolUDP
    Use compressionEnabled
    PAM AuthenticationDisabled
    Address10.8.0.0
    Mask255.255.255.0
    Gateway Interfaceeth0
    Default GatewayEnabled
    Client to clientDisabled
    DNS Server8.8.8.8,8.8.4.4
    Pubic AddressMy DDNS address


    Every time I try to connect with the OpenVPN app it just times out.

  • I haven't worked on OMV 3, but recently switched to OMV 4 on my raspberry pi.
    Sadly, OpenVPN is broken. Even, that dashboard showing 2 green dots on service, however from logs I see that OpenVPN exit with error.


    Code
    raspberrypi systemd[1]: Failed to start OpenVPN connection to server.
    raspberrypi systemd[1]: openvpn@server.service: Unit entered failed state.
    raspberrypi systemd[1]: openvpn@server.service: Failed with result 'exit-code'.


    During plugin installation all looks fine in logs


    Code
    Jul 16 06:15:54 raspberrypi monit[1140]: 'omv-engined' restart on user request
    Jul 16 06:15:54 raspberrypi monit[1140]: Monit daemon with PID 1140 awakened
    Jul 16 06:15:54 raspberrypi monit[1140]: Awakened by User defined signal 1
    Jul 16 06:15:54 raspberrypi monit[1140]: 'omv-engined' trying to restart
    Jul 16 06:15:54 raspberrypi monit[1140]: 'omv-engined' stop: '/bin/systemctl stop openmediavault-engined'
    Jul 16 06:15:54 raspberrypi systemd[1]: Stopping The OpenMediaVault engine daemon that processes the RPC request...
    Jul 16 06:15:54 raspberrypi systemd[1]: Stopped The OpenMediaVault engine daemon that processes the RPC request.
    Jul 16 06:15:54 raspberrypi monit[1140]: 'omv-engined' start: '/bin/systemctl start openmediavault-engined'
    Jul 16 06:15:54 raspberrypi systemd[1]: Starting The OpenMediaVault engine daemon that processes the RPC request...
    Jul 16 06:15:54 raspberrypi systemd[1]: Started The OpenMediaVault engine daemon that processes the RPC request.

    However not working.


    Will investigate when will have a minute.


    Also, when trying to create certificates got following error



    Code
    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; omv-mkconf openvpn add '58f01e6b-5192-497d-834f-27caef22789a' 2>&1' with exit code '1': Easy-RSA error: EASYRSA_PKI does not exist (perhaps you need to run init-pki)? Expected to find the EASYRSA_PKI at: /etc/openvpn/pki Run easyrsa without commands for usage and command help.
  • Hi,


    any news on this?
    I have the same problem. Dashboard shows green lights, but openvpn is not running. I installed and configured the openvpn plugin the same way as in OMV3.
    Any help would be greatly appreciated.


    p.parker


    Code
    root@Odroid-HC1:~# ps -aux | grep openvpn
    root 11313 0.0 0.0 3764 588 pts/0 S+ 15:15 0:00 grep openvpn
    root@Odroid-HC1:~#

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!