Clean install of omv 4, can't import Plex database

  • I just finished a clean install of omv 4. I previously had Plexmediaserver running on top of omv 3. My libraries had many collections and customizations.


    After installing omv 4 I reinstalled the plexmediaserver plugin. The database folder field says the same directory that holds the existing metadata. When i open Plex web, there are no libraries. If I create a library and point it to the media location, it redownloads all of the metadata. I installed plexmediaserver using omv-extrasorg


    I want Plex to just import all of the existing metadata.


    Thanks in advance.

  • Is Plex running as a user:group that has at least read permissions to the database folder?

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on Chenbro NR12000 1U 1x 8m Quad Core E3-1220 3.1GHz 16GB ECC RAM.

  • The most frequently seen problem with Plex is improper permissions and ownership of the files it needs to read.


    I asked you about this but did not get an answer.


    What are the permissions and ownerships of the plex metadata directory and the media files and directories in your media collection?


    What user and group is Plex running as?

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on Chenbro NR12000 1U 1x 8m Quad Core E3-1220 3.1GHz 16GB ECC RAM.

    Edited once, last by gderf ().

  • I think that I have almost solved the issue. By changing the home directory to the existing metadata directory and reinstalling plexmediaserver, it is close to working.


    The only problem is that now, when I start the plexmediaserver service and then check the status, I get this error:



    I thought that this issue is to do with permissions but I have set /usr/lib/plexmediaserver and all of the files and folders inside to have write, read, and execute permissions.

  • You shouldn't have played with what's in /usr/lib/plexmediaserver as their permissions and ownerships are properly set when Plex is installed. There is no need to ever change anything in there.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on Chenbro NR12000 1U 1x 8m Quad Core E3-1220 3.1GHz 16GB ECC RAM.

  • I suggest you completely purge the Plex plugin and PMS installation and start over. You may want to consider running Plex in a docker instead.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on Chenbro NR12000 1U 1x 8m Quad Core E3-1220 3.1GHz 16GB ECC RAM.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!