Remote Mount will not mount

  • It just will not mount from one OMV to the Next all setting are correct (I think ) just will not mount.




    Code
    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; mount '/srv/a5f52b92-c76f-4caa-9d81-a0e932642505' 2>&1' with exit code '32': mount error(115): Operation now in progress Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)


  • It might not make a difference but the share name should not have the leading slash. if it still fails, it is likely a permissions issue. is the remote host a Windows 10 Home system?

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Correct, Host is omv 2.0. and im trying to mount on OMV4

    Then the username should be a local user on the OMV 2.x host with permissions to the share not darkvodka34@outlook.com.

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • That is my username under 2.0 the share works fine and it in use with other devices. just will not mount in 4.0

    I am surprised that even works. It is a terrible idea. The @outlook.com is overriding the hostname. I assume you added it because that is your windows login name but you should use Windows 10 credential manager instead. This will never work in remotemount because the fstab entry appends the hostname in the fstab string. So, you end up with two @ symbols which won't work. Create another user with the same permissions to use with remote mount.

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I am surprised that even works. It is a terrible idea. The @outlook.com is overriding the hostname. I assume you added it because that is your windows login name but you should use Windows 10 credential manager instead. This will never work in remotemount because the fstab entry appends the hostname in the fstab string. So, you end up with two @ symbols which won't work. Create another user with the same permissions to use with remote mount.

    I did same problem works fine on 2.0 must be something in 4.0

  • Getting this now even tho the host defo NOT down. this is with user "remote"

    Code
    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; mount '/srv/e692c910-4494-47c6-b23f-4bb56e0e4945' 2>&1' with exit code '32': mount error(112): Host is down Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)


  • I did same problem works fine on 2.0 must be something in 4.0

    Yep, the remotemount plugin didn't exist in 2.0. The remoteshare plugin did things much differently. I wrote both of them. OMV 2.x also used samba 3.6 vs 4.5 for OMV 4.x. Regardless, I still wouldn't use a user with a domain appended.

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Yep, the remotemount plugin didn't exist in 2.0. The remoteshare plugin did things much differently. I wrote both of them. OMV 2.x also used samba 3.6 vs 4.5 for OMV 4.x. Regardless, I still wouldn't use a user with a domain appended.

    Yup remoteshare that worked fine. ive used the username "remote" now and tells me host is down when its indeed not.


    Think its a problem coming from samba 3.6 to the 4.5 from omv4.0?

  • No fix than other than upgrade my 2.0 box?

    While that is a good idea (actually a fresh install is better), it is possible to specify the smb protocol version of a mount in the mount options.

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!