Cant umount degraded raid

  • Hello,

    again i got the same problem like in this already solved thread. last months it happend from time to time, but i could solve it by doing the discribed steps again.
    Clean, degraded Raid (Mirror)

    but today it doesnt work, because i cant umount the raid. i get this error-message:

    root@HomeServer:~# mdadm --stop /dev/md127
    mdadm: Cannot get exclusive access to /dev/md127:Perhaps a running process, mounted filesystem or active volume group?

    of course i tried to umount the raid before without getting a error-message - but the raid is still mounted.

    even these commands dont bring up a result:

    root@HomeServer:~# lsof /dev/md127
    root@HomeServer:~# fuser -m /dev/md127

    can you help me to get the raid unmounted?

    thanks, alex!

    • Official Post

    Since you are using OMV4, if you have a shared folder on the array, that means you have a bind mount at /sharedfolders/SHARE_NAME. You need to unmount that bind mount first. Then you should be able to unmount the filesystem.

    omv 6.1.1-1 Shaitan | 64 bit | 5.19 proxmox kernel | plugins :: omvextrasorg 6.1.1 | kvm 6.2.5 | compose 6.3 | mergerfs 6.3.4 | zfs 6.0.12 plugins source code and issue tracker - github

    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!