No USB drives detected after apt-get update/upgrade

  • Hello all,

    I installed OMV 4 on my Odroid C2 using OMV_4_Odroid_C2.img.xz dated 2018-06-03. MD5 checked out.

    I ran the package updates in the webui and all seemed fine but since a reboot, no USB drives are detected.

    I click 'scan' under the drives section of the webui - only the system's SD card is listed.

    I've tried a few known good drives (external HDD and flash drives) - the indicator lights on the drive don't even light up on connection to USB port.

    I tried booting from my old OMV 3 SD card, to make sure it's not a hardware problem - drives worked fine.

    I tried starting again, reflashing the image - again it's fine before I install updates, but same problem after updates.

    Any suggestions welcome!

    OMV 5 on Raspberry Pi 3, Odroid C2 + HC2 and two cobbled together x64 boxes running Snapraid.

  • Any suggestions welcome!

    Maybe USB has been screwed up (again) with ODROID-C2 and mainline kernel in Armbian. Unfortunately I lost track and have not a single Amlogic device any more. The OMV3 image used the horribly outdated and unmaintained Amlogic 3.14 kernel which is somewhat of a mess but since no one worked on this outdated kernel for years... it's stable.

    Since it's Armbian based can you please provide output from armbianmonitor -u?

  • OK thanks again tkaiser.

    Taking a lead from another post on that armbian forum, I tried:

    1. Boot with USB drive attached - USB drive not detected.
    2. Plug in an additional 2nd drive (in my case a 2GB flash) - USB drives not detected. But the flash drive LED blinks in a regular pattern, suggesting something's happening.
    3. Boot with both USB drives attached - both detected! Flash drive assigned sda, big desktop drive sdb.

    So I suppose that's a workaround for now.

    OMV 5 on Raspberry Pi 3, Odroid C2 + HC2 and two cobbled together x64 boxes running Snapraid.

  • So I suppose that's a workaround for now

    Well, I hope the drives remain accessible. Anyway, all ODROIDs except HC1 and HC2 (and hopefully the upcoming N2 too) are no great choices for the NAS use case. On the Amlogic based ODROIDs all USB ports are behind an internal USB hub which is something I would always try to avoid (shared bandwidth and bus contention issues) and the XU4 has its own problems.

    Don't get me wrong please: Hardkernel is one of the few SBC makers who offers outstanding support. But this doesn't matter that much wrt OMV since all we need here is a working kernel and the rest is done by Armbian. And kernel situation with Amlogic in general is underwhelming: With C1 it's a horribly outdated 3.10 and with C2 it's either a horribly outdated 3.14 or a WiP mainline kernel prone to 'issues'.

    Debian Stretch (OMV 4 requirement) requires at least 3.16 so with Amlogic it's either unstable or nope. Choose one please.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!