OMV - SMB/CIFS - The "syslog only" option is deprecated

  • When running "testparm -s" from CLI there is a message :


    WARNING: The "syslog only" option is deprecated


    Maybe this is an old option for SAMBA 3.X that is no longer available in SAMBA 4.X


    From WEB GUI Services => SMB/CIFS => Advanced settings => Log level mine is set to Normal and I see no LOGs in /va/log/samba


    I mean all log files have zero bytes.


    Thanks,


    Ricardo

  • From WEB GUI Services => SMB/CIFS => Advanced settings => Log level mine is set to Normal and I see no LOGs in /va/log/samba

    Enabling logs for samba is a two part process. You have to enable it as a setting for samba and you have to enable audit for the share(s) you want it on.

    omv 5.5.11 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I am running version 4.1.12 and even after run "omv-mkconf samba" which returns no message I still see the message after "testparm -s"


    WARNING: The "syslog only" option is deprecated


    I did not restart OMV

    Thanks again,


    Ricardo

  • WARNING: The "syslog only" option is deprecated

    Strange since it should be written. What is the output of: grep syslog /etc/samba/smb.conf


    And this really isn't something to worry about. Deprecated means it should still work fine. When it is removed, that is a different problem but that won't happen with OMV 4.x since Debian doesn't change major versions in a release.

    omv 5.5.11 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Sorry for the late reply.


    Command ( grep syslog /etc/samba/smb.conf ) returns syslog only = yes


    I can see LOGs going into /var/log/syslog but what I really want is that SMB LOG goes to /var/log/samba


    I think it will be easier to find things using separate files instead of a single big file.


    By the way this is the smb.conf related to log "word" :


    grep -i log /etc/samba/smb.conf
    log level = 2
    log file = /var/log/samba/log.%m
    max log size = 1000
    syslog only = yes


    Thank you,


    Ricardo Jorge

  • # smbclient -U racoonsn -L //bigben
    WARNING: The "syslog only" option is deprecated
    Enter racoonsn's password:


    # omv-sysinfo -c 00
    ================================================================================
    = OS/Debian information
    ================================================================================
    No LSB modules are available.
    Distributor ID: Debian
    Description: Debian GNU/Linux 9.5 (stretch)
    Release: 9.5
    Codename: stretch


    ================================================================================
    = openmediavault information
    ================================================================================
    Release: 4.1.12
    Codename: Arrakis


    Code
    # ls -l /usr/share/openmediavault/mkconf/samba.d/10global
    -rwxr-xr-x 1 root root 5005 Sep 13 07:59 /usr/share/openmediavault/mkconf/samba.d/10global
    # grep -i syslog /usr/share/openmediavault/mkconf/samba.d/10global
    OMV_SAMBA_SYSLOGONLY=${OMV_SAMBA_SYSLOGONLY:-"yes"}
    -o "syslog only = ${OMV_SAMBA_SYSLOGONLY}" -n \
  • I just looked at the github commit again and it only removes the syslog = line and not the syslog only = line. I just commented on the issue - https://github.com/openmediavault/openmediavault/issues/139

    omv 5.5.11 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!