Cockpit - Qemu and VirtMachine

  • Good evening


    I followed TechnoDadLife's tutorial for docker cockpit (Thanks a lot :))


    I'm just having a problem because I wanted to make a VM but when I launch the virtual machine I get the following error message:


    Code
    INSTALL VM action failedshow less
    Networking does not appear to be successful. If it was, you can restart your domain by running: virsh --connect qemu: /// start system Mint19 otherwise, please restart your installation.


    I looked on the internet for this error message but unfortunately it does not seem to correct my network level error.
    https://www.systutorials.com/2…th-matching-name-default/


    Now I end up with no default network for qemu because I placed the order

    Code
    virsh net-destroy default
    Code
    root@openmediavault:~# virsh net-list --all
    Name State Autostart Persistent
    ----------------------------------------------------------

    but I can not put a hand back a card by default


    Could you help me to put a default route back and if possible allow me to run the vm ?

    AMD Ryzen 5 2400G on Asus TUF B450M-PLUS - 8Gb RAM - 3 * 3To RAID5 on LSI Megaraid SAS 9260-8i and 3 SSD in Fractal Design Node 804 Black
    OS: OMV 4.1.26-1

  • I logically found I have to do one:

    Code
    root @ openmediavault: ~ # virsh net-create default.xml
    error: Failed to create network from default.xml
    error: internal error: Failed to initialize a valid firewall backend



    but I have an error message regarding the Backend Firewall


    on the internet it indicates to fix this problem that it is necessary to install dnsmasq and firewalld ebtables


    Code
    apt-get install ebtables dnsmasq firewalld


    but if I do this after a reboot I no longer have access on the services on OMV, the rules of the firewall must block the access.


    I try the command :


    Code
    virsh # net-define /root/default.xml

    and the network card was created but I still end up with the same firewall backend problem.



    EDIT :


    I think I found, there would be a bug in ebtables:
    https://bugs.archlinux.org/task/60062

    AMD Ryzen 5 2400G on Asus TUF B450M-PLUS - 8Gb RAM - 3 * 3To RAID5 on LSI Megaraid SAS 9260-8i and 3 SSD in Fractal Design Node 804 Black
    OS: OMV 4.1.26-1

    Edited 2 times, last by Methy ().

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!